Tutorial How to successfully pack and unpack .pak files

Discussion in 'Starbound Modding' started by SexualRhinoceros, Jan 26, 2014.

  1. KazeSkyfox

    KazeSkyfox Scruffy Nerf-Herder

    I love you so much right now :D
    CommanderWasp1x likes this.
  2. Dolan

    Dolan Pangalactic Porcupine

    I'm glad to see that my helper is still usefull ;)
    CommanderWasp1x likes this.
  3. moddownloader

    moddownloader Phantasmal Quasar

    unpak/pak program does not work
  4. Dolan

    Dolan Pangalactic Porcupine

    Hi moddownload, could you be more specific on what's not working ?
    - What version did you use (Win/Linux) ?
    - What actions have you choose ?
    - What mod have you tried to pack/unpack ?
    - If it's a custom mod, did you have a .modinfo file in your mod folder ?
  5. moddownloader

    moddownloader Phantasmal Quasar

    i chose unpak
    i did not unpak a mod as you cant do that, i was trying to unpak the pakked thing in the assets folder so that i could make a recepie to cheat in this one item from one mod in the tabula rasa
  6. Dolan

    Dolan Pangalactic Porcupine

    So you choose action 0] ? (Unpacking Starbound assets)
    If you put the bat file in your mod folder and choose action 0], it will extract the assets in your "Starbound\assets\_unpacked" folder.
    But you'll have to wait, depending on your computer, it could take a while.
  7. moddownloader

    moddownloader Phantasmal Quasar

    i was using this one thing where you drag the things into it
  8. Dolan

    Dolan Pangalactic Porcupine

    So that's not mine. I think you are talking about wraithbone tool.
    You should ask him or you could also try my tool. Its also easy.
    Drop the .bat file in Starbound\mods folder and pick choice 0].
    It's done.
  9. deurker

    deurker Void-Bound Voyager

    programs a load of crap dosnt work at all.
  10. The | Suit

    The | Suit Agent S. Forum Moderator

    Peelz likes this.
  11. deurker

    deurker Void-Bound Voyager

    did and its beter. iv already done what i needed t0 do but thanks.
  12. awesomesauce333

    awesomesauce333 Void-Bound Voyager

    how to pack files on mac? i can't get it to work. Also, when i edit unpacked files, it doesn't do anything ingame
  13. The | Suit

    The | Suit Agent S. Forum Moderator

  14. Thundercraft

    Thundercraft Phantasmal Quasar

    Thanks for the programs. I'm sure I'm not the only one who'd rather avoid command prompts if they can.
    However, the drag-n-drop thing is not my style. So, I'd prefer to use your V1.

    I did try your V2 and it does work. However, at first, it refused to work on my packed file. It gave an error:
    I had to rename the mod's pak file from (as an example) "ISE2.modpak" to "ISE2.pak" in order for it to process it.

    Also, I was disappointed that V2 did not remember where my asset_unpacker.exe and/or asset_packer.exe files were located the next time I tried to use it.

    Like the V2, this V1 did not want to process a PAK file with the extension "*.modpak". Again, I had to rename it to "*.pak". Except, in this case, .modpak files would not even show up in the window as an option.

    :up:This GUI is definitely more my style! :up: However, like your V2, this V1 did not remember where my asset_unpacker.exe and/or asset_packer.exe files were located the next time I tried to use it. As such, the GUI seems like a wasted opportunity. If you could only have it create a .cfg or .ini file or some such to store the location of these files, this GUI would be almost perfect!

    PS: Using V1, I noticed that even though the program put checkmarks next to each step successfully completed (Asset_unpacker.exe location, .pak file location, destination location), after all that is done the [unPak] button remains greyed-out and hard to read. I can click on this greyed-out button and it functions. But I expected either the text to go black or the button to change color or something to indicate it was ready to proceed.
    Last edited: Oct 20, 2014
  15. Qrowler

    Qrowler Aquatic Astronaut

  16. DarkzXD

    DarkzXD Void-Bound Voyager

    im using a mac, how do i pack it using
    "cd ~/Library/Application\ Support/Steam/SteamApps/common/Starbound/
    Starbound.app/Contents/MacOS/asset_unpacker assets/packed.pak assets/test"
    please reply soon
    i figured it out
    Last edited: Nov 13, 2014
  17. NanoPi

    NanoPi Scruffy Nerf-Herder

    since my last post I have had a chance to try Windows 8.1 and the File Explorer is awesome. it is very easy to open a command prompt in the folder you have open by opening the File menu. this method will work well if you use relative paths to access the unpacker executable and pak files instead of copying and pasting the full path to the executable.

    it is also painless to open a command prompt from the desktop by right-clicking the start button (using mouse). all of this is staying in Windows 10. good job Microsoft.

    if you happen to be on Windows 8 and not 8.1, using mouse, right-click the bottom left corner of screen to get the menu.
  18. JUstin17

    JUstin17 Void-Bound Voyager

    Does all of this work to unpack the ".modpak" file?
  19. The | Suit

    The | Suit Agent S. Forum Moderator

    Yes it is the same method - just make sure you get the extensions right.
  20. JUstin17

    JUstin17 Void-Bound Voyager

    What the:
    Exception caught: DBException: DB content identifier does not match expected val
    ue of 'Assets1'
      0043DFED asset_unpacker.exe
      00407857 asset_unpacker.exe
      00402602 asset_unpacker.exe
      004A7AC8 asset_unpacker.exe
      00401413 asset_unpacker.exe
      00401585 asset_unpacker.exe
      76EA37EB ntdll.dll
      76EA37BE ntdll.dll
    [DOUBLEPOST=1416923703][/DOUBLEPOST]This is the file that i'm trying to unpack; trying to make it compatible to my Enraged Koala


    Attached Files:

    Last edited: Nov 25, 2014
    NanoPi likes this.

Share This Page