Modding Help How to release mods in V. Offended Koala

Discussion in 'Starbound Modding' started by tifel100, Dec 15, 2013.

Thread Status:
Not open for further replies.
  1. sirylcat

    sirylcat Scruffy Nerf-Herder

    Is the mod feature already released? Because after recent patch all the mods cannot be loaded. I've checked the starbound.log but there's no messages indicating any of them were loaded. All the mods were working fine before that patch.

    How exactly should I modify the mods to be loaded from mods folder?
  2. G4M5T3R

    G4M5T3R Cosmic Narwhal

    So wait? The path is only used in this format "../<modname>" if your mod isn't inside the pre-existing mods folder. Good to know :)

    Yes it was in the patch, page1 describes how-to

    You might want to add that the dependency name to use is the one found in the .modinfo your mod is dependent on. Not the file directory name. So if that mod isn't up to date with this yet. You need to make a temp .modinfo for it too.

    *sry double post. there
    Last edited: Dec 15, 2013
  3. CJacobs

    CJacobs Void-Bound Voyager

    I started a new character real quick and I've come across the exact same problem. If I have player.config in the main mod folder, then it's the same problem as before. If I have it in the /assets/ folder which mimic's the game's architecture, it doesn't work at all. That's weird and frustrating.
  4. tifel100

    tifel100 Void-Bound Voyager

    Basically Copy all the files that you added or modified into a folder and name it for your mod like mod_sirylcat then put that in the mods folder, add a mod_sirylcat.modinfo. (Also delete any - ONLY ADDED - files from the default starbound assets.)
  5. tifel100

    tifel100 Void-Bound Voyager

    Can you tell me the structure of where you placed your files now?
  6. Leosky

    Leosky Void-Bound Voyager

    yeah, even if you havn't modified the images, you have to put them exactly next of your file
  7. CJacobs

    CJacobs Void-Bound Voyager



    Here's how I have my mod's files arranged. When Player.config is in the /Cjacobs_DS_RIGs/ folder, the mod works except for the sprites. When Player.config is in the /assets/ folder, it doesn't even show up.

    From the /assets/ folder inside my mod's folder I mimic-ed the game's architecture because there are multiple craftable outfits whose images have the same filename. The recipes and crafting the items work perfectly fine, it's just that the sprites don't. If I have to put them in the same directory as the modinfo file then it won't work because the armor images have the same filenames (head.png, chest.png, etc).
  8. Leosky

    Leosky Void-Bound Voyager

    your images have to be in the 'rig-tier1c' and 'rig-tier1i' folders
  9. CJacobs

    CJacobs Void-Bound Voyager

    They ARE in those folders!

  10. Leosky

    Leosky Void-Bound Voyager

    can you show us the content of your .chest .head and .legs files ?
  11. Taiwendo

    Taiwendo Void-Bound Voyager

    The structure is wrong.
    The Assets folder must be deleted.
    It may only be taken the subfolders that are in the assets in it.
    Leosky and G4M5T3R like this.
  12. CJacobs

    CJacobs Void-Bound Voyager


    Oh wow, you're right, it works now. I certainly feel like a dummy.

    Thanks for the troubleshooting help guys!
  13. Taiwendo

    Taiwendo Void-Bound Voyager

    What really needs to be written purely in the "player.config"?

    I just change the the "Animal Armor Mod" in the new modfolder System.
    And I have the problem that get the "tanningrack" I do not see the build.
  14. Cayote

    Cayote Aquatic Astronaut

    The file hierarchy shouldn't start with assets, make your file hierarchy as if it was inside assets.

    like this:
  15. Carty1234

    Carty1234 Zero Gravity Genie

    Can anyone explain to me what the "mods_go_here" file actually is? Also, since I started putting mods into sub folders of the mod name, the game can no longer load. Any help?
  16. Cayote

    Cayote Aquatic Astronaut

    probably just an indicator for you to know where your mods go.
  17. Taiwendo

    Taiwendo Void-Bound Voyager

    Ok, now I know what needs to be purely written to the file.

    The problem with the system time is that you can only use a MOD
    the "player.config" overrides.

    If two mods gave me the "player.config" this does not work anymore.
    I hope that the still improve.
  18. Carty1234

    Carty1234 Zero Gravity Genie

    I get this error when trying to install a race. What have I done wrong?

    amfinError.png amfinStructure.png
  19. aMannus

    aMannus Space Kumquat

    I'm having an entirely different problem. Crafting tables always use a weird set filepath for their configs. For example, the normal crafting table has this: "config" : "/interface/windowconfig/craftingtable.config", And it basically starts looking from the assets folder. Now, when I had my custom crafting tables before, I just put my folder into the assets folder and made a path like this: /CreativeMode/spawningtable/spawningtable.config. This worked because it was placed in the assets folder. Now that I need to put my mods into the mods folder, I can't point to the same path because it starts looking from the assets folder.

    Does anybody know how to change this to make the game look a folder in front of assets, THEN goes into the mod folder etcetera? I've tried something like this: "config" : "../mods/CreativeMode/spawningtable/spawningtable.config", but it doesn't seem to work. Anyone else having these issues?

    EDIT: Made it work by recreating the same kind of structure in my own mod folder. So I made it look like this: /mods/CreativeMode/interface/windowconfig/spawningtable.config, and made the code for my spawning table like this:

    "config" : "/interface/windowconfig/spawningtable.config",

    For anyone that has this issue as well.
    Last edited: Dec 15, 2013
  20. G4M5T3R

    G4M5T3R Cosmic Narwhal

    Just about to say that
    It looks as if something in the charcreation.config is out of order. The syntax maybe? no that's a different error. Can you post what's in that file. Are you using another mod for the interface? Like Kawa's mod? if so you need to delete the /interface/windowconfig folder in the species mod.
Thread Status:
Not open for further replies.

Share This Page