Tutorial How to get Starbound to work on SteamOS

Discussion in 'Starbound FAQs, Q&A, and General Help' started by Halogen002, Jan 6, 2016.

  1. Halogen002

    Halogen002 Void-Bound Voyager

    On SteamOS, Starbound launches, but it ends up flickering between the launcher and main game as SteamOS hates it when more than one window is open. The idea of this workaround is to bypass the launcher and have Steam directly open the game. You'll want a keyboard plugged in for this to type in a few commands into Terminal, and a mouse plugged in to work on the desktop.

    What you want to do first is enable Desktop mode. You will need this in order to access the Terminal. To enable Desktop mode, you'll need to go to Settings, then go to Interface (under Display), and make sure "Enable access to the Linux desktop" is checked. If this is the first time you have enabled the desktop, it will warn you that enabling desktop mode is not supported and you can break things if you're not careful. Go back to the main menu and click the power button, then click the "Switch to Desktop Mode" option. Move your cursor to the top left corner, click Show Applications (the icon that has 9 squares on it), and click Terminal.

    On the Terminal, you should first type "passwd" and press enter if you have not done this already in order to assign a password to the desktop account. Keep in mind:
    • It needs to be at least 6 characters in order to be accepted.
    • You will need to remember this password, as there is NO way to recover the password from SteamOS, nor can you change it without remembering the previous password.
    • This is the password to the "desktop" account, NOT your Steam account.
    • You may not see any feedback from entering your password (it'll just say "Enter new password:" with nothing after it); this is normal, and you are still entering a password.
    Type "sudo -u steam bash" and press enter to switch to the steam user. You will need to enter that password that you entered not long ago. Be careful, especially whenever "sudo" is involved.

    Type "cd ~/.local/share/Steam/steamapps/common/Starbound" and press enter to get to the Starbound folder. Note that a tilde (~) is being used in this particular command, not a hyphen (-).

    Type "cd linux64' and press enter to get to the folder that contains the launcher. One of SteamOS's requirements is a 64-bit processor, and SteamOS is Linux, so the folder should always be linux64.

    Type "rm launcher" and press enter to remove the launcher. If you would rather back it up, use "mv launcher launcher_old" instead, though verifying the game files will restore it anyway.

    Type "ln -s starbound launcher" and press enter to create a symbolic link. Steam will now launch Starbound directly instead of opening the launcher.

    Type "exit" and press enter to switch back to the desktop user. Again, be sure to remember that password, though you can optionally just clear it with "sudo passwd -d desktop" if you don't want to risk forgetting it.

    Close the Terminal window and double click the Steam icon on the desktop. If you open Starbound, it should go straight to the game now.

    Note: If the launcher is updated, or if you click "Validate Content" in Manage Game in Starbound, then Steam will delete the shortcut you made and restore the launcher. If that happens, you will have to do this again, though
    Last edited: Feb 7, 2016
  2. Tacohobbit

    Tacohobbit Void-Bound Voyager

    After typing "cd ~/.local/share/Steam/steamapps/common/Starbound" I get:

    bash: cd: -/: invalid option

    Stuck here, can't move on.
  3. Halogen002

    Halogen002 Void-Bound Voyager

    It looks like you're putting a hyphen (-) where there should be a tilde (~). I'll edit my original post and have the commands in a different font family to make it a little easier to see this, because it's a bit difficult to see with the default post font family.

    edit: Done!
    Last edited: Feb 7, 2016

Share This Page