Modding Help How to fix mods broken in Stardew Valley 1.2

Discussion in 'Mods' started by Pathoschild, Apr 12, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. Constance

    Constance Void-Bound Voyager

    Pathos, wow you went above and beyond. Thanks!
     
      Pathoschild likes this.
    • Pathoschild

      Pathoschild Cosmos Killer

    • Pathoschild

      Pathoschild Cosmos Killer

      FarmAutomation.ItemCollector is now unofficially updated too (see the first post for details).
       
      • Pathoschild

        Pathoschild Cosmos Killer

      • Pathoschild

        Pathoschild Cosmos Killer

        @Topinambour Extended Fridge doesn't seem to be open-source, so I can't update it. I submitted a bug report on the Nexus page.
         
        • Tinkerbelch

          Tinkerbelch Void-Bound Voyager

          Pathoschild likes this.
        • Reihart

          Reihart Void-Bound Voyager

          I hope you could update the mod 'Part of the community' I seem to experience some crashes @Pathoschild such as CTD during sleep.
          http://www.nexusmods.com/stardewvalley/mods/923/?http://www.nexusmods.com/stardewvalley/mods/923/?tab=14&navtag=http://www.nexusmods.com/stardewvalley/ajax/modbugs/?id=923&pUp=1

          the error displays as:
          A mod failed handling the GameEvents.UpdateTick event:
          System.NullReferenceException: Object reference not set to an instance of an object.
          at StardewValley.Farmer.isDivorced()
          at SB_PotC.ModEntry.ModUpdate(Object sender, EventArgs e)
          at StardewModdingAPI.Framework.InternalExtensions.SafelyRaisePlainEvent(IMonitor monitor, String name, IEnumerable`1 handlers, Object sender, EventArgs args) in D:\source\_Stardew\SMAPI\src\StardewModdingAPI\Framework\InternalExtensions.cs:line 46
           
          • Pathoschild

            Pathoschild Cosmos Killer

          • Topinambour

            Topinambour Void-Bound Voyager

            Awesome for the GetDressed fix, thanks a lot! As for Extended Fridge, damn. Let's hope the creator is still around :)
             
            • demonhunter352

              demonhunter352 Subatomic Cosmonaut

              Alrighty, got a list here. I've gone through all my installed mods and found that these ones do not function.

              The following list causes a crash to desktop upon loading a savegame. It is unknown to me whether they are due to incompatibilities with SMAPI1.10, SDV1.2 or Entoarax Framework 1.7.1. Please note that all of these mods were tested with a fresh savefile at the start of the first day of play.

              -Better Quality More Seeds
              -FarmAutomation.BarnDoorAutomation
              -FarmAutomation.ItemCollector (yes, the unofficial update you posted here, I'm afraid)
              -OmniFarm (additional note: XNBLoader doesn't seem to be overwriting the combat farm map with OmniFarm's version)
              -Tractor Mod

              EvenMoreCrops Unofficial Continuation causes the game to freeze when mousing over seeds (including vanilla seeds: it occurs when I try to mouse over parsnip seeds in a new game) in the inventory when the modded ObjectInformation.xnb is used in place of the vanilla. I suspect due to changes in how the game handles descriptions.

              PelicanFiber lacks support for the new controller behaviour, causing the cursor to get stuck on the "close" button unless you use a mouse.

              Crash and freeze logs for the listed mods are in the .rar file >HERE<, each labelled with the name of the mod they refer to.

              EDIT: Also, it appears the savefile I started the day before the update went live, which contained all of the above listed mods and then some, also crashes to desktop (likely because said mods aren't present)
               
                Last edited: Apr 25, 2017
              • chazwhiz

                chazwhiz Space Hobo

                Chest Pooling is still not working when using the 1.3better release - is there a newer unofficial update I'm missing?

                Error:
                Code:
                [10:25:37 ERROR SMAPI] A mod failed handling the PlayerEvents.InventoryChanged event:
                Failed loading type: : System.TypeLoadException: Failure has occurred while loading a type.
                  at ChestPooling.ChestPoolingMainClass.QueryChests (System.Collections.Generic.List`1 chestList, StardewValley.Item itemRemoved) <0x1651d4900 + 0x0004b> in <filename unknown>:0
                  at ChestPooling.ChestPoolingMainClass.Event_InventoryChanged (System.Object sender, System.EventArgs e) <0x1784893a0 + 0x000ea> in <filename unknown>:0
                  at StardewModdingAPI.Framework.InternalExtensions.SafelyRaiseGenericEvent[TEventArgs] (IMonitor monitor, System.String name, IEnumerable`1 handlers, System.Object sender, StardewModdingAPI.Framework.TEventArgs args) <0x16380d4c0 + 0x000f3> in <filename unknown>:0 
                 
                • FarmerRen

                  FarmerRen Void-Bound Voyager

                  I did the fix for Save Anywhere v 2.3 and it still crashed my game. =/
                  Any idea why?
                   
                  • Stardews

                    Stardews Void-Bound Voyager

                    OmniFarm is working fine for me, I just reinstalled it.
                     
                    • Pathoschild

                      Pathoschild Cosmos Killer

                      @demonhunter352 Thanks for the detailed report! Here are the problematic mods:
                      • Entoarox Framework caused most of the crashes (BarnDoorAutomation, Better Quality More Seeds, ItemCollector, and OmniFarm). The author is actively updating his code for Stardew Valley 1.2, so I suggest posting those logs in that mod's support thread.
                      • Even More Crops seems to be broken in 1.2, but might not be eligible for an unofficial update if the problem is in the XNB part. I'll take a look, but I suggest requesting an update in that mod's support thread.
                      • TractorMod is broken, but the author hasn't started updating yet. I'll add it to the incompatible list, and prepare a pull request and unofficial update soon.
                      • PelicanFiber has a bug (rather than a compatibility issue), so you'll need to ask the author for a fix. You can submit a bug report on its Nexus page.
                       
                      • BrandonPotter0

                        BrandonPotter0 Big Damn Hero

                        Some (not all) xnb files in Stardew 1.11 have different .yaml format compare to 1.2
                        So if the mod you're using is replacing some XNB that got a format update, your game crashes.
                        This is probably why the Even More Crops mod is not compatible.
                         
                        • ebrown22

                          ebrown22 Void-Bound Voyager

                          I just watched a great youtube video that recommended a bunch of visual mods, so I"m pretty bummed with the timing of this update.
                          Any update for the following mods:
                          • Victorian Era Buildings & Victorian Mailbox
                          • House remodel-interior design
                          • Mi's Furniture
                          • Mi's Bathroom
                          • Mi's Fireplace
                          • Bathroom after 2nd Houseupgrade
                          • Just a New Map Recolour
                          • Alternate Fences & Gates
                          • Darker Wood & Gold Craftables
                          • Babies Take After Spouse Plus New Toddler Hair and Clothes
                          • hojichas' Wallpaper and Flooring

                          Also these:
                          • Simple Crop Label
                          • Gift Taste Helper
                          • Interaction Helper
                          • Loved Labels
                          • Harvest With Scythe

                          I know this is a lot, but any info on if these are updated or will be would be great!
                           
                          • Sable19

                            Sable19 Void-Bound Voyager

                            I use the Gift Taste Helper and Loved Labels, and the current ones still work with the update for me. Hope that helps. ^^
                             
                            • KThxBye910

                              KThxBye910 Void-Bound Voyager

                              I use the same Victorian, Mi's, map recolour, craftables, fences, and hojicha's stuff with no issue.
                               
                              • ebrown22

                                ebrown22 Void-Bound Voyager

                                *s
                                I'm going to try deleting them and reinstalling them. Is there some key you have to push or anything like that to activate the loved labels? That mod has not worked for me even before the update. :(
                                 
                                • Sable19

                                  Sable19 Void-Bound Voyager

                                  No, once I have it installed it just showed up when I loaded my game. I hope you get it to work. I have had some mods that I had to install a couple times to get them to work.
                                   
                                  Thread Status:
                                  Not open for further replies.

                                  Share This Page