Modding Help How to fix mods broken in Stardew Valley 1.2

Discussion in 'Mods' started by Pathoschild, Apr 12, 2017.

Tags:
  1. Oxyligen

    Oxyligen Tentacle Wrangler

    Isn't there a Modmanager which combines the xnb.
     
    • lelelego

      lelelego Aquatic Astronaut

      Hi, thanks for all your hard work! Unfortunately, I can't seem to get GetDressed to work, and since I've updated SMAPI to v.1.12 having GetDressed in my mods folder crashes my game whenever I try to get to the load game menu. :(
       
      • Pathoschild

        Pathoschild Giant Laser Beams

      • xrubyx

        xrubyx Space Spelunker

        Is it possible to update CJB Cheat Menu mod? Doesn't seem to work as in can't access the menu, downgrading smapi doesn't help either using the 1.14.1 version of CJB Cheat Menu Mod
         
        • Minakie

          Minakie Scruffy Nerf-Herder

          I upgraded my game to version 1.2 yesterday, installed SMAPI 1.12 and CheatsMenu 1.14.1 and everything in it seems to be working fine for me. It was also working fine yesterday when I still had Stardew 1.11 and an older version of SMAPI and all the CJB mods. Did you check the config file to see which hotkey you have assigned to open the menu? Also, do you have any other mods that could be conflicting?
           
          • xrubyx

            xrubyx Space Spelunker

            no other mods, and I checked the config the hotkey is indeed "P"....Using Steam updated my game to 1.2.30 I dunno if it worked before then I haven't played since the 1.07 patch. The Mod API says CJB Cheat Menu is running.

            The only other mods that would possibly conflict is the pokemon retexture mods that I've used on this forum [http://community.playstarbound.com/threads/pokemon-retextures-list.111179/#post-2839953] But doubt it... [portrait,building,Spring/Summer/Fall/Winter map mods.]

            Edit: I gonna guess CJB Cheat file I downloaded yesterday got corrupted somehow, reinstalled it did the trick
             
              Last edited: May 14, 2017
            • Entoarox

              Entoarox Oxygen Tank

              repeat the attempt to get the menu to display, then post your SMAPI-latest.txt log file so we can see what is happening.
               
              • xrubyx

                xrubyx Space Spelunker

                its fine, I figured it out...well actually not, reinstalling the CJB mod fixed it...its lame cause somehow the files must of got corrupted or something when I downloaded them yesterday. I just gave it a shot, the files were the same kb size which is why I say lame, who woulda knew lol
                 
                  Minakie likes this.
                • lelelego

                  lelelego Aquatic Astronaut

                  Hi Pathoschild! Unfortunately that's what I did, and I just tried it again with no success. I get the rainbow wheel of death (I'm on a Mac), and it refuses to boot up the load page with my save files and then Stardew Valley shows up as "not responding" in my activity monitor. And when I remove the GetDressed folder, everything works fine. :( ! I'm not sure if this is Mac-specific or not.
                   
                  • Pathoschild

                    Pathoschild Giant Laser Beams

                  • lelelego

                    lelelego Aquatic Astronaut

                    Sure thing, here it is!
                     

                      Attached Files:

                    • Mogipoki

                      Mogipoki Aquatic Astronaut

                      Does the better sprinklers mod work with Smapi 1.9 game version 1.11?
                       
                      • WickedOtaku

                        WickedOtaku Intergalactic Tourist

                        I put in the latest SMAPI 1.12 and I put in CJB item spawner and CJB cheats menu and it still won't work though.
                         
                        • Xuomi

                          Xuomi Zero Gravity Genie

                          The mods in this thread are meant to be used with Stardew Valley 1.2+. If you want older versions of mods that work, then go to the mod creator's pages and download them.
                           
                          • SonOfaSubmariner

                            SonOfaSubmariner Void-Bound Voyager

                            I recently discovered the Jiggling Junimo mod, but it apparently doesn't work with the newest version of SMAPI. I was curious if there was either a fix for it or perhaps a similar mod that adds a tool tip?
                             
                            • AbdiBP

                              AbdiBP Master Chief

                            • Voltaic123

                              Voltaic123 Void-Bound Voyager

                            • DerekX

                              DerekX Intergalactic Tourist

                            • missvy

                              missvy Space Spelunker

                              Note : Im running on Mac!

                              I get this when i try to use the Entoarox framework.

                              [00:45:19 WARN SMAPI] The Entoarox Framework mod failed on entry initialisation. It will still be loaded, but may not function correctly.

                              Failed loading type '': System.TypeLoadException: Failure has occurred while loading a type.

                              at Entoarox.Framework.EntoFramework.Entry (IModHelper helper) <0x16368b940 + 0x0045c> in <filename unknown>:0

                              at StardewModdingAPI.Program.LoadMods () <0x160180a20 + 0x02680> in <filename unknown>:0


                              I get this error once I load a game (Get Dressed/Entoarox Framework seem to be the culprits)

                              [00:50:21 ERROR SMAPI] A mod failed handling the GameEvents.UpdateTick event:

                              System.InvalidOperationException: This image format is not supported ---> System.TypeInitializationException: The type initializer for 'System.Drawing.GDIPlus' threw an exception. ---> System.DllNotFoundException: libgdiplus.dylib

                              at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)

                              at System.Drawing.GDIPlus..cctor () <0x16b91f560 + 0x001d9> in <filename unknown>:0

                              --- End of inner exception stack trace ---

                              at System.Drawing.Image.InitFromStream (System.IO.Stream stream) <0x16b91f0e0 + 0x00139> in <filename unknown>:0

                              at System.Drawing.Image.LoadFromStream (System.IO.Stream stream, Boolean keepAlive) <0x16b91ef50 + 0x00030> in <filename unknown>:0

                              at System.Drawing.Image.FromStream (System.IO.Stream stream) <0x16b91ef20 + 0x00016> in <filename unknown>:0

                              at Microsoft.Xna.Framework.Graphics.Texture2D.PlatformFromStream (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice, System.IO.Stream stream) <0x16b91e980 + 0x00040> in <filename unknown>:0

                              at Microsoft.Xna.Framework.Graphics.Texture2D.FromStream (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice, System.IO.Stream stream) <0x16b91e8b0 + 0x0002c> in <filename unknown>:0

                              --- End of inner exception stack trace ---

                              at Microsoft.Xna.Framework.Graphics.Texture2D.FromStream (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice, System.IO.Stream stream) <0x16b91e8b0 + 0x000b1> in <filename unknown>:0

                              at GetDressed.Framework.ContentHelper.PatchTexture (Microsoft.Xna.Framework.Graphics.Texture2D& targetTexture, System.String sourceTextureName, Int32 sourceID, Int32 targetID, Int32 gridWidth, Int32 gridHeight, Int32 adjustedHeight) <0x16b91e520 + 0x000fc> in <filename unknown>:0

                              at GetDressed.GetDressed.PatchFarmerTexture (StardewValley.Farmer player, GetDressed.Framework.LocalConfig config) <0x16b91dd60 + 0x00432> in <filename unknown>:0

                              at GetDressed.GetDressed.PatchLoadMenu () <0x16a15fa20 + 0x0038f> in <filename unknown>:0

                              at GetDressed.GetDressed.Event_UpdateTick (System.Object sender, System.EventArgs e) <0x16a15f5b0 + 0x0004c> in <filename unknown>:0

                              at StardewModdingAPI.Framework.InternalExtensions.SafelyRaisePlainEvent (IMonitor monitor, System.String name, IEnumerable`1 handlers, System.Object sender, System.EventArgs args) <0x112c16230 + 0x001cc> in <filename unknown>:0
                               
                              • Pathoschild

                                Pathoschild Giant Laser Beams

                                Stardew Valley Package Manager can merge image XNBs, but unfortunately it doesn't support data XNBs.

                                Can you post your latest SMAPI log after trying them? Both those mods should work.

                                There's no error in the log, which makes it hard to diagnose. I have some changes in the upcoming SMAPI 1.13 that might affect your issue; can you try it again when 1.13 is released in a few days and post a new log then?

                                Can you post your latest SMAPI log after trying it? The mod doesn't seem to be open-source, but I'll add it to the list. In the meantime, you could try Lookup Anything which shows whether you still need an item (see example screenshot).

                                I've seen a few people mention that error with Entoarox Framework on Linux/Mac. I suggest asking for help in the Entoarox Framework support thread (and include a copy of your latest SMAPI log file after the error happens).

                                Make sure you're using the latest version of SMAPI, which has a possible fix for that. If it happens with 1.12, can you attach your latest SMAPI log after it happens?
                                 

                                Share This Page