Modding Help How to apply steam workshop mods to starbound 1.0 server

Discussion in 'Starbound Modding' started by McLeige, Jul 23, 2016.

  1. McLeige

    McLeige Void-Bound Voyager

    Does anybody know how to get this to work, I only want to get frackinUniverse to work but the only time it loads into assets is if its singleplayer, the server window output doesnt load it if it is the workshop version, it only loads into server if its the github version, and no other workshop mods are recognized by my server.
  2. lazarus78

    lazarus78 The Waste of Time

    The server uses the same universe and mods as the computer it is hosted on, so you install mods the exact same way.

    Alternativly, you can download the mod from here and not worry about steam at all.
  3. Akreao

    Akreao Scruffy Nerf-Herder

    I'm beginning to think this is a misconception as my shared dedi explicitly prints out the mods in the mod folder but my locally hosted server does not print any mods at all. The server may not look in %steamapps%/workshop.
  4. lazarus78

    lazarus78 The Waste of Time

    Why would it look there? That isn't where mods need to be installed.
  5. SleepySquidd

    SleepySquidd Tragically Magic Hands

    That's where the mods downloaded from the workshop are stored.
  6. lazarus78

    lazarus78 The Waste of Time

    Far as I can tell, the game will never look there for mods, unless it is a hard coded internal variable.
  7. PulseNeon

    PulseNeon Void-Bound Voyager

    This won't work for server systems that lock a game to it's folder;
    my dedicated server doesn't even -have- a workshop folder,
    and copying the .pak files either as full directory or seperate file doesn't work.

    So.... Chucklefish implemented Workshop support without supporting dedicated servers?
  8. Akreao

    Akreao Scruffy Nerf-Herder

    I imagine it pulls the directory(s) from steamworks.
    It's possible since shared hosts may be providing the dedi without having steam installed on the box at all.
  9. Nessus

    Nessus Void-Bound Voyager

    So, I tried this. I saw stuff coming up in the console, but despite that it didn't work properly. After a bit of scratching my head as to why, I noticed that it wasn't listing .pak files. This is because it doesn't look into subfolders.

    In other words you have to, frustratingly, specify each and every individual subdirectory in the \\workshop\\content\\211820\\ directory. So if you're planning on hosting a server with a ton of mods, you get to have fun monotonously copy and pasting a ton of crap.

    I'm not sure if there's a wildcard parameter you can use in the config file (I tried * and a few other things I thought might work, none did) but as it stands this is a real pain in the ass and it's going to drive people who use multiplayer with mods away from using the Steam workshop, which frankly kinda defeats the purpose.

    Mod edit: removed deleted quote
    Last edited by a moderator: Aug 4, 2016
  10. Naevera

    Naevera Scruffy Nerf-Herder

    Or copy the .pak's from the workshop folders and put them into the mods folder. :D
    I haven't tested this, will do so now...
    --- Post updated ---
    That did not work. It seemed like it was as the server was booting, but then I got a nasty error message. I'm only using four mods so doing the painstaking process Nessus suggested wasn't so bad... Like so:

    "assetDirectories" : [

    "storageDirectory" : "..\\storage\\",

    "defaultConfiguration" : {
    "gameServerBind" : "*",
    "queryServerBind" : "*",
    "rconServerBind" : "*"
    UpbeatCitizen likes this.
  11. Oshkell

    Oshkell Scruffy Nerf-Herder

    You folks are really clever. :)

    So, I tried that tool and it just got frustrating to me because it didn't work, and frankly I'm not even sure why. Ultimately, what I did is subscribed to a Steam workshop mod, located the .pak (which for me was ...Program Files (x86)\Steam\steamapps\workshop\content\211820\731767697\contents.pak) copied it, renamed it, and dropped it in the Starbound/mods folder. Then I unsubscribed from the Steam workshop file, and joined the server. (which I host on my own computer) It didn't seem to work until I unsubscribed.
  12. Glitch623

    Glitch623 Space Hobo

    What you are going to want to do is subscribe to the mod, then go into the steam mods folder and find the mod you subbed to. Copy and past that into the mod folder in the Starbound folder. The Starbound folder should already have a file in it that says "mods go here".
  13. Talamar1

    Talamar1 Void-Bound Voyager

    Short term fix.
    1. Use Windows File Explorer and go into the Steam Workshop directory, something like Program Files (x86)\Steam\steamapps\workshop\content\211820\
    2. Search for *.pak
    3. Copy all the files (Ctrl-A Ctrl-C, etc...)
    4. Go to your mods directory, something like \Program Files (x86)\Steam\SteamLibrary\SteamApps\common\Starbound\mods
    5. Paste the files (Ctrl-V)
    6. You will get an overwrite file error. Tell it to keep all the files and just rename them.
    7. Start server.
    This is a short term fix but will get it running. You will have no idea what the mod files are. You could do this via a batch file and creative use of the dir/copy subdir search functions.
  14. dyre00

    dyre00 Poptop Tamer

    To add to that, I think if you unpack the "content.pak" files (as they will all be named in the workshop directory), you'll probably be able to determine what each mod does. Then you can rename the content.pak file to whatever it actually is.

    edit: actually just noticed this is a bit of a thread necro, oops
  15. Lazla

    Lazla Phantasmal Quasar

    is there way to take parts of mod and put them on your own game. where i find all files in steam version. How could i take sail or ship from custom race mod and make it work for human

Share This Page