1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Closed Handy Space Helmet - "Matter Block" recipe issue - I found the fix too

Discussion in 'Support' started by scousekid92, Dec 13, 2013.

Thread Status:
Not open for further replies.
  1. scousekid92

    scousekid92 Void-Bound Voyager

    There is a small problem with the recipe file for the helmets asking for a Matter Block, eg, the Handy Space Helmet and the Neat Welders Helmet. It lies in the object name in the recipe file, it's asking for a "matterblock" item, which is all well and good, this is the item it turns into when it's spewed out of the machine in the dungeon. The problem is that the collectable item with the name "Matter Block" links back to an item called "matteritem" - they have the same image, but they are NOT the same thing. Screenshot time!!
    [​IMG]
    This is the recipe file for the "t2helm1" in the recipes folder. It displays the item needed as "matterblock". This is fine, it links to something, and doesnt cause an error - it DOES in fact exist in the game. Now lets have an example second item - the monster plating (referred to as its filename "monsterplating" in the recipe).
    [​IMG]
    When I checked for the "matterblock" item in the files, it did return an existing file with that name. However "monsterplating" is not in this folder - when I checked, this is in the same folder as building materials (Starbound/assets/items/materials).
    This struck me as a little odd, so I simply searched for "matter" - I was shown both "matterblock" and "matteritem" in the search list.
    [​IMG]
    This is the folder with "matteritem" inside (Starbound/assets/items/generic/crafting) and there indeed is the "monsterplating" item below it.

    To test this out, I edited the recipe file.
    [​IMG]
    It works. The recipe is fixed :3

    Thanks for taking the time to read all of this!
     
    Rarity, gman21, Zabuza and 4 others like this.
  2. Vlarik

    Vlarik Space Hobo

    I tried exactly this and it didn't work for me at all. Wonder what i did wrong?
     
  3. jackd23

    jackd23 Void-Bound Voyager

    Nice find! I'm sad this bug is so far down the priority list that it's still there, for the lack of armor progression.

    Are you sure you have edited the file in "steamapps\common\starbound\assets\recipes\armor\other\t2helm1\t2helm1.recipe" and changed "item" : "matterblock" to "item" : "matteritem"? The game also needs to be not running, so it load the changed file when it starts up. Double-check for typos : -)
     
  4. scousekid92

    scousekid92 Void-Bound Voyager

    To be honest, while the devs are still handling issues with higher priority, like people getting error messages after quitting saying the program exited strangely and not being allowed to play again until they end starbound's process in the task manager, it's probably best for me to just throw a zip folder on mediafire with this file in it just so people don't have to worry about editing the file themselves. It'd make things easier for everyone.
    http://www.mediafire.com/download/tvbx82yroycu7e1/Starbound+Helmets+Fix.zip
    I included a README file for those who need help with the recipe file replacement.
    I'll keep my eye out for any more bugs ^^
     
  5. gman21

    gman21 Orbital Explorer

    I don't believe this bug existed before the most recent patch. I may be wrong because I hadn't gotten this far before the wipe, but I think people have been able to make the helmets before the patch. Either way, I ran into this just now and went online to find out if others were experiencing the same, so I am very happy that you were awesome enough to not only make a post, but also find the root cause of the issue. Thank you.
     
  6. scousekid92

    scousekid92 Void-Bound Voyager

    No problem! Glad I'm able to help ^^
     
  7. oblivion5683

    oblivion5683 Big Damn Hero

    no it was always there
     
  8. gman21

    gman21 Orbital Explorer

    I sit corrected.
     
  9. NCR Ranger

    NCR Ranger Space Hobo

    Thank you for this fix! I was so disappointed when I couldn't make the doom guy helmet.
     
  10. codysewell

    codysewell Poptop Tamer

    scousekid92 ever since i downloaded your fix and installed it my game crashes every know and again
     
  11. codysewell

    codysewell Poptop Tamer

    o but it might now be the download it's just i didn't crash before i installed it just telling you incase it is the download i didn't crash before i downloaded your space helmat fix that's all.
     
  12. codysewell

    codysewell Poptop Tamer

    by the way guys sometimes when you fix bugs you only get more bugs to fix (sometimes)
     
  13. RvLesh

    RvLesh Parsec Taste Tester

    Before the patch, the only place I saw Matter Blocks (matteritems) was chests.

    AFTER the patch, the only place I've seen them is dungeon spawners (matterblocks). These didn't stack with the ones I'd previously obtained from chests.
     
  14. codysewell

    codysewell Poptop Tamer

    rvlesh so that is why there is a bug there i think
     
Thread Status:
Not open for further replies.

Share This Page