1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

"Halley has aborted..." Crash at Launch on Steam

Discussion in 'Support' started by LordNightmareX, Feb 4, 2019.

  1. LordNightmareX

    LordNightmareX Big Damn Hero

    Have tried a few other tricks to fix this but regardless of what launch settings I use I keep getting this error.
    I own the game on Steam. I have a lot of programs and peripherals and controllers set up and plugged in at all times, 3 monitors, and Steam and the game are installed on my E: drive.

    My system:
    Windows 7
    i7-5820k 3.30GHz
    16gig ram
    GTX 1080ti
     

      Attached Files:

    • Shubeans

      Shubeans QA Wizard Chucklefish

      Heya, could you try running with the launch perimeters ' --skip-intro ' and see if that helps?
      If not could you send me the log file found in ApPData/Roaming/Chucklefish/Wargroove

      Thank you, and sorry that you're having trouble launching, hopefully we can get it fixed asap!
       
      • LordNightmareX

        LordNightmareX Big Damn Hero

        Absolutely. I tried the -skip-intro launch perimeter and it did not help. As well as running in OpenGL just caused an additional error box. All of this is after the 2/4/2019 update. I looked through the log and noticed under computer data there is just nothing and that seemed odd, but im not sure how it is supposed to look.
        Here is my log file, let me know if you want me to run any other test or get you any other files. I know others have had this problem too so just let me know if I can help.
         

          Attached Files:

          • log.txt
            File size:
            2.4 KB
            Views:
            6
        • Shubeans

          Shubeans QA Wizard Chucklefish

          hmmn. I'm sorry about this,
          Here are a couple of other ways to fix the issue that user's are reporting. Could you give them a try for me and see if any of them help at all:

          - Try to run steam in Administrator mode

          - Make sure your Media Package is up to date or installed: https://support.microsoft.com/en-us/help/3145500/media-feature-pack-list-for-windows-n-editions

          - Make sure that Visual C++ is update to date: https://www.chip.de/downloads/Visual-C-2010-Express_24081894.html

          - Make sure all your drivers are up to date, including Windows updates

          - Run the game in OpenGL

          Thank you
           
          • LordNightmareX

            LordNightmareX Big Damn Hero

            Ok I will try these and see if it helps. I am running windows 7 so there is no MediaPackage option for me. It there another that I should have?
            I also notice I have a lot of versions of Visual C++ installed and was wondering if there that could be causing a version conflict?
            Thank you for your help again.

            So I gave all of that a try and am still having the same error.

            Here is what I have tried so far:
            I have uninstalled all instances of Visual C++, then reinstalled 2010, 2012, 2013, and 2017. From their website and the link you provided.
            I have checked for, and update all Microsoft media programs.
            I have launched the game in OpenGL both with and without the --skip-intro perimeter.
            I have launched the game regularly both with and without the --skip-intro perimeter.
            I have launched the game regularly and in OpenGl both with and without the --skip-intro perimeter, while running steam as an administrator.

            Here is my DxDiag and Log files again to see if anything has changed. Let me know if you have any other ideas or if this is something for a future patch that i just need to wait for.
             

              Attached Files:

              Last edited by a moderator: Feb 8, 2019
            • Shubeans

              Shubeans QA Wizard Chucklefish

              This is going to be a weird question.
              Could you unplug your Joystick and XInput controllers?
               
              • DLT64

                DLT64 Space Hobo

                I have encountered a similar problem with this "Halley" issue. I was in the middle of a mission and my game or computer froze. I was unable to open task manager and close the game manually. so I hard reset my computer and logged back into steam and attempted to start the game. that's when that error appeared. I attempted to reinstall the game,thinking there was maybe a corrupted file. It didn't work. so I tried validating the cache: same problem. Then I tried that "--skip-intro" solution, and it is still not fixed.

                This is what the error looks like, maybe that can show more details about the problem. if that doesn't help I can triy to find those two game files you mentioned before
                 

                  Attached Files:

                  Last edited by a moderator: Feb 8, 2019
                • LordNightmareX

                  LordNightmareX Big Damn Hero

                  I did not think of that....
                  BUT, we have fix. Kindof. So I disconnected all of my extra devices (360 controller, 2 joysticks, a throttle, pedals, trackir camera, webcam, extra keypad, headset transmitter, and microphone) so that I had just a mouse and keyboard plugged in, and restarted my pc. After that I was able to launch the game as normal and get through the opening cinematic. I have yet to try playing but if there's a problem ill let you know. I know I have a lot plugged in, my pc is also a sim pit.
                  Problem is, I cant do that every time. I do use these things often, and because of how it is set up i cant just flick a switch and disconnect it. So for now, great im glad its playable and this works ok, I will see if more problems arise. Ill try unplugging less things and see if i can get away with keeping cameras and some controllers plugged in but it does seem like a controller conflict. Heres hoping a fix for that is possible. Thank you for your help, ill update here if there are more problems and check back and try to be active on the forms.

                  Let me know if you want me to try anything else and hope this helps others out.
                   
                  • Shubeans

                    Shubeans QA Wizard Chucklefish

                    Thats awesome.
                    I'm now about 100% sure it's related to joysticks or flight setups plugged in. You're the 3rd person that's managed to get the game working by unplugging them :)

                    I'll get this passed to our programming department and get a fix out asap!
                     
                    • kamiromario

                      kamiromario Lucky Number 13

                      Hi i have tried all of these thing suggested and im still experiencing the same issue. i also just have my mouse and keyboard plugged in

                      I am no computer wiz i bought the game to play not to be doing all of this. all i have connected is my mouse and keyboard and im still receving the same message

                      this is honestly $20 wasted
                       
                        Last edited by a moderator: Feb 8, 2019
                        Zarupta and robbierob711 like this.
                      • Shubeans

                        Shubeans QA Wizard Chucklefish

                        Have you also tried some of the things suggested here: https://steamcommunity.com/app/607050/discussions/0/1778261844038074432/

                        Do you get any error messages. Do you have a log you can send me? Could you also send me your PC specs.
                         
                        • kamiromario

                          kamiromario Lucky Number 13

                          Attached Files:

                        • Shubeans

                          Shubeans QA Wizard Chucklefish

                          The log will be found in ApPData/Roaming/Chucklefish/Wargroove
                          If you open up the file explorer, and type %appdata% in the address bar, it will take you straight to folder.
                           
                          • kamiromario

                            kamiromario Lucky Number 13

                            Halley is initializing...
                            It is 2019-02-08 17:31:58
                            Program dir: C:/Program Files (x86)/Steam/steamapps/common/Wargroove/win64_bin/.
                            Data dir: C:/Users/Romario/AppData/Roaming/Chucklefish/Wargroove/.
                            Computer data:
                            OS:
                            CPU:
                            GPU:
                            RAM: 0 B
                            Time: Fri Feb 8 17:31:58 2019

                            System plugin: System/SDL
                            Video plugin: Video/DX11
                            Input plugin: Input/SDL
                            Audio output plugin: Audio/SDL
                            Network plugin: Network/ASIO
                            Platform plugin: Platform/Steam
                            Movie plugin: Movie/MediaFoundation

                            Initializing SDL...
                            Version/Compiled: 2.0.7
                            Version/Linked: 2.0.7

                            Initializing audio...
                            Audio devices available:
                            0: [Default]
                            1: Speakers (Realtek High Definition Audio)
                            Steam initialised.
                            Starting Wargroove with build #16090

                            Initializing Video Display...
                            Drivers available:
                            0: windows
                            1: dummy
                            Video driver: windows


                            Unhandled exception: Process aborting with signal #SIGSEGV (11)
                            0# 0x00007FF6A9F947D2 in wargroove64
                            1# _C_specific_handler in VCRUNTIME140
                            2# _chkstk in ntdll
                            3# RtlImageNtHeaderEx in ntdll
                            4# KiUserExceptionDispatcher in ntdll
                            5# DumpRegistryKeyDefinitions in ig9icd64
                            6# DumpRegistryKeyDefinitions in ig9icd64
                            7# DumpRegistryKeyDefinitions in ig9icd64
                            8# RegisterProcTableCallback in ig9icd64
                            9# DumpRegistryKeyDefinitions in ig9icd64
                            10# DrvCreateLayerContext in ig9icd64
                            11# wglSwapMultipleBuffers in OPENGL32
                            12# wglCreateLayerContext in OPENGL32
                            13# SDL_wcslen in SDL2
                            14# SDL_wcslen in SDL2
                            15# SDL_wcslen in SDL2
                            16# SDL_wcslen in SDL2
                            17# 0x00007FF6A9E21677 in wargroove64
                            18# 0x00007FF6A9ED7A72 in wargroove64
                            19# 0x00007FF6A948C3E5 in wargroove64
                            20# 0x00007FF6A948B7B9 in wargroove64
                            21# 0x00007FF6A9D00C9D in wargroove64
                            22# 0x00007FF6A9CC4669 in wargroove64
                            23# 0x00007FF6A9D1DB5C in wargroove64
                            24# 0x00007FF6A9CC376E in wargroove64
                            25# 0x00007FF6A948D7E1 in wargroove64
                            26# 0x00007FF6A9EE26DA in wargroove64
                            27# BaseThreadInitThunk in KERNEL32
                            28# RtlUserThreadStart in ntdll

                            Last traces:

                            End of traces.
                             
                            • Blastronaght

                              Blastronaght Void-Bound Voyager

                              I ran into this problem just a few hours ago, I was in the port mission and my pc froze (which it is prone to doing) so I hard reset and I've had the Halley has aborted problem since, the links here I either can't install, or have tried and don't work (mostly can't install except the skip intro thing). I've tried uninstalling, restarting my pc and steam but nothing seems to work. I only want to try and use the delete save file as a last resort and only if I know it will work because I've spent a fair time playing the campaign (which is good btw)

                              Edit: sorry I forgot to add a picture of the error

                              If there is anything I can do advice would be appreciated.
                               

                                Attached Files:

                                Last edited: Feb 11, 2019
                              • kamiromario

                                kamiromario Lucky Number 13

                                I had the issue. It wont allow me to update the media package, i was able to update the visual c++ and it worked for two days and crashed again "Halley has aborted with an unhandled expectation"
                                 
                                • Shubeans

                                  Shubeans QA Wizard Chucklefish

                                  Heya, you're issue is completely different to the one reported in this thread.
                                  For you the save has been corrupted:
                                  Take out the PlayerProgress file found in %appdata%/chucklefish/Wargroove/Saves
                                  Rename the file 'playerProgress.bak', and remove the '.bak' from the name.
                                  Make sure Steam Cloud is disabled for Wargroove
                                  Relaunch the game.
                                   
                                  • Shubeans

                                    Shubeans QA Wizard Chucklefish

                                    Could you please run sfc /scannow in the command prompt; this will find and replace any corrupted files that might be causing the issue
                                     
                                    • Blastronaght

                                      Blastronaght Void-Bound Voyager

                                      Really sorry about this but I don't know where else to post this, I did all that you told me to do but I'm still having the problem. I deleted the file and renamed the .bak file. I can't find a way to permanently delete files on steam cloud to remove the ones I already had before the problem occurred, I'm also worried my renamed .bak file may also be corrupt.

                                      Any help/advice would be appreciated and thanks for getting back to me before
                                       
                                      • Shubeans

                                        Shubeans QA Wizard Chucklefish

                                        You don't need to delete files on steam, just disable to Cloud by right clicking on Wargroove in your library, going to 'properties' then 'Updates' and unchecking the box at the bottom of the popup.
                                        You may need to do the process again if Cloud has re-written the files
                                         

                                        Share This Page