1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Getting major delay from internal server

Discussion in 'Starbound Support' started by Silverdagger, Aug 10, 2016.

  1. Silverdagger

    Silverdagger Void-Bound Voyager

    Hello, while playing starbound i noticed some weird behavior that led me to believe that the local server used to host my game is not working properly.

    This behavior includes: Enemies not responding for at least 4 seconds to my pressence, large chunks of the world getting blacked out and dont load for at least 2 seconds after, all npcs stop moving for 2 seconds, items i mine just float in mid - air for 2 seconds, items from chests not getting looted ( have to press the loot all button 5-6 times for it to register).

    Note that during this "delay", i can freely move my character around and the game plays at 62 fps according to steam overlay fps counter, but the world seems completely unresponsive.I am using:windows 10 x64, Intel Core i7 2670QM, 8GB ram.

    This behavior would be expected if i was connected to a remote server but the fact that it happens while i play on singleplayer is troubling. Does anyone have any suggestions as to how i can fix this issue and improve my experience?
     
  2. Cupa

    Cupa Big Damn Hero

    Please attach the starbound.log to see if any error may slow down the game. Also, do you have any programs in the background? Try the game on a server too. For tries, I can supply you with access to my own one.
     
  3. Silverdagger

    Silverdagger Void-Bound Voyager

    [00:30:02.355] [Info] Root: Preparing Root...
    [00:30:02.355] [Info] Root: Done preparing Root.
    [00:30:02.355] [Info] Client Version 1.0.5 (windows x86_64) Source ID: 7d4a2bbba04d43bd7f43f0ca940db23b2187edc1 Protocol: 724
    [00:30:02.355] [Info] Root: Scanning for asset sources in directory '..\assets\'
    [00:30:02.702] [Info] Root: Scanning for asset sources in directory '..\mods\'
    [00:30:02.702] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [00:30:02.702] [Info] Root: Detected asset source named 'base' at '..\assets\packed.pak'
    [00:30:02.702] [Info] Root: Detected unnamed asset source at '..\assets\user'
    [00:30:02.702] [Info] Loading assets from: '..\assets\packed.pak'
    [00:30:03.127] [Info] Loading assets from: '..\assets\user'
    [00:30:04.060] [Info] Assets digest is 835de2a06240fd303c5cfc854388f3b67407dac8e006f903343715672b0705a3
    [00:30:04.060] [Info] Root: Loaded Assets in 1.70484 seconds
    [00:30:04.065] [Info] Application: Initializing SDL Video
    [00:30:04.067] [Info] Application: Initializing SDL Joystick
    [00:30:04.135] [Info] Application: Initializing SDL Sound
    [00:30:04.223] [Info] Initialized Steam services
    [00:30:04.224] [Info] Application: Creating SDL Window
    [00:30:04.678] [Info] Application: Enabling VSync with late swap tearing
    [00:30:04.693] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [00:30:04.702] [Info] OpenGL version: '4.5.0 NVIDIA 368.69' vendor: 'NVIDIA Corporation' renderer: 'GeForce GT 555M/PCIe/SSE2' shader: '4.50 NVIDIA'
    [00:30:04.704] [Info] Application: initialization...
    [00:30:04.706] [Info] Root: Loaded Configuration in 0.00103798 seconds
    [00:30:04.706] [Info] Application: Disabling VSync
    [00:30:04.719] [Info] Application: renderer initialization...
    [00:30:04.724] [Info] Root: Loaded ImageMetadataDatabase in 5.59811e-06 seconds
    [00:30:04.745] [Info] Application: main update loop...
    [00:30:04.747] [Info] Loading mods from user generated content with id '729726478' from directory 'C:\Program Files (x86)\Steam\steamapps\workshop\content\211820\729726478'
    [00:30:04.747] [Info] Loading mods from user generated content with id '729524482' from directory 'C:\Program Files (x86)\Steam\steamapps\workshop\content\211820\729524482'
    [00:30:04.747] [Info] Reloading to include all user generated content
    [00:30:04.747] [Info] Root: Reloading from disk
    [00:30:04.747] [Info] Root: Writing runtime configuration to '..\storage\starbound.config'
    [00:30:04.779] [Info] Root: Loaded Configuration in 0.00108697 seconds
    [00:30:04.779] [Info] Root: Scanning for asset sources in directory '..\assets\'
    [00:30:05.103] [Info] Root: Scanning for asset sources in directory '..\mods\'
    [00:30:05.103] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [00:30:05.103] [Info] Root: Scanning for asset sources in directory 'C:\Program Files (x86)\Steam\steamapps\workshop\content\211820\729726478'
    [00:30:05.103] [Info] Root: Scanning for asset sources in directory 'C:\Program Files (x86)\Steam\steamapps\workshop\content\211820\729524482'
    [00:30:05.104] [Info] Root: Detected asset source named 'base' at '..\assets\packed.pak'
    [00:30:05.104] [Info] Root: Detected asset source named 'Weapon Stats' at 'C:\Program Files (x86)\Steam\steamapps\workshop\content\211820\729726478\contents.pak'
    [00:30:05.104] [Info] Root: Detected asset source named 'ContainerUITweak' at 'C:\Program Files (x86)\Steam\steamapps\workshop\content\211820\729524482\contents.pak'
    [00:30:05.104] [Info] Root: Detected unnamed asset source at '..\assets\user'
    [00:30:05.104] [Info] Loading assets from: '..\assets\packed.pak'
    [00:30:05.546] [Info] Loading assets from: 'C:\Program Files (x86)\Steam\steamapps\workshop\content\211820\729726478\contents.pak'
    [00:30:05.546] [Info] Loading assets from: 'C:\Program Files (x86)\Steam\steamapps\workshop\content\211820\729524482\contents.pak'
    [00:30:05.547] [Info] Loading assets from: '..\assets\user'
    [00:30:06.511] [Info] Assets digest is 1090ff3583cbd1f575a99d36389d667141e508e37627da0a5dfe83f244d4e705
    [00:30:06.511] [Info] Root: Loaded Assets in 1.7314 seconds
    [00:30:06.513] [Info] Root: Loaded ImageMetadataDatabase in 5.13159e-06 seconds
    [00:30:06.517] [Info] Root: Loaded NameGenerator in 0.00527202 seconds
    [00:30:06.527] [Error] OpenGL errors this frame: GL_INVALID_VALUE
    [00:30:06.608] [Info] Root: Loaded PlantDatabase in 0.0906306 seconds
    [00:30:06.854] [Info] Root: Loaded ObjectDatabase in 0.342434 seconds
    [00:30:07.011] [Info] Root: Loaded MonsterDatabase in 0.15663 seconds
    [00:30:07.055] [Info] Root: Loaded NpcDatabase in 0.0434978 seconds
    [00:30:07.056] [Info] Root: Loaded StagehandDatabase in 0.000859776 seconds
    [00:30:07.058] [Info] Root: Loaded VehicleDatabase in 0.00236054 seconds
    [00:30:07.061] [Info] Root: Loaded PlayerFactory in 0.00334067 seconds
    [00:30:07.110] [Info] Root: Loaded ProjectileDatabase in 0.502175 seconds
    [00:30:07.112] [Info] Root: Loaded VersioningDatabase in 0.00131975 seconds
    [00:30:07.112] [Info] Root: Loaded EntityFactory in 0.0501856 seconds
    [00:30:07.158] [Info] Root: Loaded ParticleDatabase in 0.0464713 seconds
    [00:30:07.454] [Info] Root: Loaded MaterialDatabase in 0.342762 seconds
    [00:30:07.459] [Info] Root: Loaded TerrainDatabase in 0.0048307 seconds
    [00:30:07.492] [Info] Root: Loaded BiomeDatabase in 0.032581 seconds
    [00:30:07.492] [Info] Root: Loaded LiquidsDatabase in 0.000680637 seconds
    [00:30:07.499] [Info] Root: Loaded StatusEffectDatabase in 0.00647655 seconds
    [00:30:07.633] [Info] Root: Loaded DamageDatabase in 0.13388 seconds
    [00:30:07.638] [Info] Root: Loaded EffectSourceDatabase in 0.00483163 seconds
    [00:30:07.641] [Info] Root: Loaded FunctionDatabase in 0.00325997 seconds
    [00:30:07.669] [Info] Root: Loaded TreasureDatabase in 0.028131 seconds
    [00:30:07.952] [Info] Root: Loaded DungeonDefinitions in 0.282729 seconds
    [00:30:07.952] [Info] Root: Loaded TilesetDatabase in 4.19858e-05 seconds
    [00:30:07.954] [Info] Root: Loaded StatisticsDatabase in 0.00202605 seconds
    [00:30:07.954] [Info] Root: Loaded EmoteProcessor in 7.7907e-05 seconds
    [00:30:07.964] [Info] Root: Loaded SpeciesDatabase in 0.0093815 seconds
    [00:30:07.978] [Info] Root: Loaded QuestTemplateDatabase in 0.0142565 seconds
    [00:30:07.981] [Info] Root: Loaded AiDatabase in 0.00238946 seconds
    [00:30:07.982] [Info] Root: Loaded TechDatabase in 0.0010907 seconds
    [00:30:07.987] [Info] Root: Loaded CodexDatabase in 0.00525896 seconds
    [00:30:08.068] [Info] Root: Loaded BehaviorDatabase in 0.0805111 seconds
    [00:30:08.071] [Info] Root: Loaded DanceDatabase in 0.00304817 seconds
    [00:30:08.077] [Info] Root: Loaded SpawnTypeDatabase in 0.00640237 seconds
    [00:30:08.080] [Info] Root: Loaded RadioMessageDatabase in 0.00318952 seconds
    [00:30:09.976] [Info] Root: Loaded ItemDatabase in 2.8655 seconds
    [00:30:15.345] [Info] UniverseServer: Acquiring universe lock file
    [00:30:15.346] [Info] UniverseServer: Loading settings
    [00:30:15.348] [Info] UniverseServer: Starting UniverseServer with UUID: 590535b3d578bc143d4d6cd156515fab
    [00:30:15.364] [Info] UniverseServer: Logged in player 'Maxwell' locally
    [00:30:15.364] [Info] UniverseServer: Logged in account '<anonymous>' as player 'Maxwell' from address local
    [00:30:15.369] [Info] UniverseServer: Reviving player at ClientShipWorld:6068998b70e21887f0c68812c767d729
    [00:30:15.369] [Info] UniverseServer: Client 'Maxwell' <1> (local) connected
    [00:30:15.378] [Info] UniverseClient: Joined server as client 1
    [00:30:15.452] [Info] UniverseServer: Loading client ship world ClientShipWorld:6068998b70e21887f0c68812c767d729
    [00:30:15.678] [Error] Cannot set Steam achievement kill10poptops
    [00:30:15.678] [Error] Cannot set Steam achievement dismisscrewmember
    [00:30:16.743] [Info] UniverseServer: Warping player 1 to ClientShipWorld:6068998b70e21887f0c68812c767d729=996.2.1024
    [00:30:24.096] [Info] Root: Writing runtime configuration to '..\storage\starbound.config'
    [00:30:59.168] [Info] Root: Writing runtime configuration to '..\storage\starbound.config'
    [00:31:34.201] [Info] Root: Writing runtime configuration to '..\storage\starbound.config'
    [00:31:44.222] [Info] Root: Writing runtime configuration to '..\storage\starbound.config'
    [00:31:45.518] [Info] UniverseClient: Client disconnecting...
    [00:31:45.596] [Info] Client received world stop packet, leaving: Removed
    [00:31:45.790] [Info] UniverseServer: Client 'Maxwell' <1> (local) disconnected for reason:
    [00:31:45.791] [Info] UniverseServer: Stopping idle world ClientShipWorld:6068998b70e21887f0c68812c767d729
    [00:31:46.401] [Info] UniverseServer: Stopping UniverseServer
    [00:31:47.530] [Info] Application: quit requested
    [00:31:47.530] [Info] Application: quitting...
    [00:31:47.530] [Info] Application: shutdown...
    [00:31:47.675] [Info] Root: Shutting down Root
    [00:31:47.940] [Info] Application: Destroying SDL Window
    [00:31:47.970] [Info] Application: stopped gracefully
     
  4. Silverdagger

    Silverdagger Void-Bound Voyager

    Also running the game as Administrator and changing config file to save only 1 backup seems to have improved the issue alot
     
  5. Cupa

    Cupa Big Damn Hero

    Attach it, right next to "Post reply"
     
  6. Cupa

    Cupa Big Damn Hero

    Can you please tell what hardware you have?
     
  7. Silverdagger

    Silverdagger Void-Bound Voyager

    OS: Windows 10 Pro 64-bit
    CPU: Intel Core i7 2670QM @ 2.20GHz
    RAM: 8,00GB Dual-Channel DDR3
    VC: NVIDIA GeForce GT 555M 3071MB
    HDD: 931GB Hitachi HGST HTS721010A9E630 (SATA)
     
  8. Cupa

    Cupa Big Damn Hero

    Looks like your CPU has problems handling it.
    What version of the game are you using? 64-bit or 32-bit?
     
  9. Cupa

    Cupa Big Damn Hero

    Did a little googling, looks like the game had problems with multi-cores one year ago, dunno if it's fixed in the release.
     
  10. Silverdagger

    Silverdagger Void-Bound Voyager

    From Steam Store Page of Starbound:


    • RECOMMENDED:
      • OS: Windows XP or later
      • Processor: Core i3
    i have i7 with 4cores and no problems with any other games! Please explain how my CPU "has problems handlint it"!
    Of course i am using the 64 bit version...
     
  11. Cupa

    Cupa Big Damn Hero

    Look, if the game lags, that means that something probably went wrong with calculating.
    It could be a problem caused by your quad-core system.
     
  12. Silverdagger

    Silverdagger Void-Bound Voyager

    My system is able to run far more demanding games than this with no problem - if there are issues with how this game works(aka not sufficient optimization, or bugs)
    that is not a valid reason to blame my hardware! Please provide a positive contribution other than playing a "random blame game".
     
  13. Cupa

    Cupa Big Damn Hero

    Silverdagger, I'm completly free to either try to help you or stop everything and play the game myself, you know?
    If you don't show some more respect, I'll do the latter.

    You request help, I'm trying to help. Multi-cores can lead to problems through the internal mechanics of how they are
    handled by the game. For example, bad optimization might seem to support it, but will give all operations to every single
    core, which basically can lead to some issues when different results come in.

    As said, Starbound HAD some issues, I do not know if they are still here. If the game is only optimized for two cores, your
    CPU is just too weak to support it when only two cores รก 2,20 GHz. Or the scenario described above might be the case,
    which would explain why the game has such a high desync.
     
  14. Silverdagger

    Silverdagger Void-Bound Voyager

    My CPU s base clock is @2.2GHz with turbo boost the actual clock speed is ~2.6GHz for the most part. I am sorry if you feel offended but tbh i thought you were trolling...

    I am certain i do not need a server board with 2 Intel Xeons to run it..

    As i said in previous post the steps i took seem to improve the issue by a huge margin making the game responsive again..
     
  15. Cupa

    Cupa Big Damn Hero

    Try to also run it in compatibility mode maybe.

    And I were never trolling, just trying to help you. :)
     
  16. Silverdagger

    Silverdagger Void-Bound Voyager

    Which version should i set the compatability at?
     
  17. Cupa

    Cupa Big Damn Hero

    Windows 7 with the latest SP.
     
  18. MrStrangerPL

    MrStrangerPL Pangalactic Porcupine

    Or just acknowledge, that optimisation in this game is a fooken joke.
    i5 4430, 8gb RAM, GTX950, fps differ from 7, all the way to 60. Chunks often do not load, enemies do not respond. Same stuff basically.
     
    Xylia likes this.
  19. Cupa

    Cupa Big Damn Hero

    Try what he tried, maybe it'll help you too :)
     
  20. Xylia

    Xylia Tiy's Beard

    I run a 6-Core 3.5Ghz AMD with 16GB RAM and GTX 660 on Windows 7, and oftentimes I'll be having 60 FPS and I'll swing at a mob and it'll just continue to move at me and 2-3 seconds later, it FINALLY registers the hit on it.

    I'm not even playing on a server, I'm playing Local Singleplayer, lol.

    I've also seen the "Chunks take forever to load" problems too occasionally where I'll come to the edge of a chunk and have to wait 5 or more seconds for it to load in, even when I'm not running much of anything in the background.
     

Share This Page