1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Bug/Issue Game performance (Lags)

Discussion in 'Support' started by Cat_Fuzz, Sep 20, 2016.

  1. futons

    futons Void-Bound Voyager

    Menu and character creation were smooth, experienced extreme lag again as soon as the introduction mission began.
     
  2. Healthire

    Healthire Can't Most Program the Least Chucklefish

    There is a new unstable update as of a few minutes ago, could you try that one? If it says 1.2.1 RC2 at the bottom of the game menu you're on the correct version. Also if you haven't already, please post your system specs, or at least your CPU model and your graphics card model.

    Thank you for your help!
     
  3. ddlzz

    ddlzz Space Hobo

    RC2 version run much smoother but i still have the same problems with jumping. Sometimes (quite often) jumping while moving makes my character stop and stand still.

    my specs:
    Mobile QuadCore Intel Core i7-3632QM, 2900 MHz (29 x 100)
    8060 МБ (DDR3-1600 DDR3 SDRAM)
    NVIDIA GeForce GT 635M (2 Gb)
    win7 SP1 x64

    Btw am I the only one experiencing problems with in-game moving and jumping?
     
    Last edited: Dec 20, 2016
  4. futons

    futons Void-Bound Voyager

    I restarted the game, played for a bit, and it was still slow; I then saw your message, closed and reopened the game, and it was all smooth! I checked and it was definitely 1.2.1 RC2.

    For future reference, my specs are:

    iMac (24-inch Mid 2007)
    Processor - 2.4 GHz Intel Core 2 Duo
    Memory - 4GB 667 MHz DDR2 SDRAM
    Startup Disk - 512 SSD
    Graphics - ATI Radeon HD 2600 Pro 256MB

    I am well-aware that I am using a nearly 10-year-old machine :nurusad:

    EDIT: I know that this is the unstable version of the game, but not wanting to leave anything to chance, I tried closing and reopening the game again to see if I got the same results, and was faced with this:

    [​IMG]


    EDIT 2: Visuals all work fine again, perhaps it's random on when they work or when they don't.
     
    Last edited: Dec 20, 2016
  5. In_Ter_Face

    In_Ter_Face Orbital Explorer

    On a first look it seems to be working much better on the unstable branch.

    Specs:
    MacBook Air
    i7 2677M
    Intel HD Graphics 3000 384MB
    4GB 1333MHz DDR3 RAM
     
  6. Don Quixote

    Don Quixote Void-Bound Voyager

    Got a moment to test out current unstable build. On the ship and for a bit on the starter planet the game ran pretty much the smoothest I've seen it run. Then I got killed by a high-fps bird and ran out of time =P

    OSX 1.9.5
    late 2009 iMac, 3.06GHz Intel Core 2 Duo
    12GB 1067 MHz DDR3 RAM
    ATI Radeon HD 4670 256 MB
     
  7. metamorphexx

    metamorphexx Void-Bound Voyager

    Tested the unstable build, it runs fine although I'm getting some dips but it's way better than the stable one.
     
  8. Don Quixote

    Don Quixote Void-Bound Voyager

    The new stable build runs better than before, but it's still a mediocre framerate on the ship. Taking down some smoke-generating machines I had in the back helped a tiny bit, and I'm not sure that the multiplayer setting being on or off made a difference. Next I went to an isolated space station with no NPCs I'd built and the frame rate was silky smooth again, but my character sprite, the teleporter, and any other items and lights I had around were not visible. Seen here, I'm where the particles are.
     

    Attached Files:

  9. Marcus101RR

    Marcus101RR Star Wrangler

    Still have issues with Framerate, over all the game runs fine assuming nothing crazy is going on. Here are my issues:

    Specs
    FX-8350 8-Core 4.0 Ghz
    16 GB DDR3 1666Mhz RAM
    GTX 960 4 GB


    Rain Framerate Drop
    If the game is having a storm of rain, heavy rain in this case causes framerate to drop down to 45 fps or lower.

    Rope/Grappling Hook Extension
    The longer the Rope or Grappling hook become the more frame rate drop begins to occur until it can't go any further. Not sure why such a small piece of line can cause so much frame rate drops! It is even worst when the line is bending over many blocks.

    Pixel Printer Cluster
    The pixel printer provides all the scanned items you can possibly print, the more items appear in the list the more framerate drop becomes, this can go bad as about 30 fps or lower. Mind you, if you use /admin powers, pixel printer practically gives you every possible item that can be crafted. The game slows down to a crawl! Pretty sure this has nothing to do with the Hardware.
     
  10. Justin O.

    Justin O. Big Damn Hero

    Unstable:
    Still experiencing heavy lag on ship in steam launch, less so since 1.2.1. No lag in menus, no lag on option screen from title.
    Not experiencing any lag on ship, title, options, planetside in .exe launch

    Stable:
    Experienced lag upon first time in ship through steam launch, but not planet side, then not when returing to ship. Appears to be working well. Will advise of further issues. (did no test stable .exe launch) Let me know if you need further conditional testing

    Edit: after about 20 minutes playing I started to see bad lag planetside that I am able to rememdy by returning to ship and back down. Every 5 or minutes planetside I need to do this

    Macbook Pro
    2.4 GHz Intel Core i5
    8 GB 1067 MHz DDR
    NVIDIA GeForce GT 330M 256 MB
    Intel HD Graphics 288 MB
     
    Last edited: Dec 22, 2016
  11. futons

    futons Void-Bound Voyager

    Started up the stable build, and logged into my farm world; so far, no lagging!
    I will add edits to this post if any lagging occurs.

    I would also like to make a shout out to the game devs for being patient and working on the lagging issues, especially at this time of year.
     
  12. mintbubbles

    mintbubbles Void-Bound Voyager

    1.2.1 seems to have increased the framerate. I made no changes since my last post.
     
  13. Healthire

    Healthire Can't Most Program the Least Chucklefish

    For people who still experience severe framerate issues caused by 1.2, even after 1.2.1, there's a new option in starbound.config called "limitTextureAtlasSize". If you set that to true it will use the same size texture atlases as before 1.2 and should effectively work the same it did before.

    If you're having poor performance on a graphics card well above the minimum requirements of 256MB of memory you should not have to enable that option, and enabling that option will likely lead to worse performance rather than better.
     
  14. Don Quixote

    Don Quixote Void-Bound Voyager

    Is it in the OSX version? I opened up the .config for both current unstable and stable builds, but didn't find the option.
     

    Attached Files:

  15. Valiantic

    Valiantic Tentacle Wrangler

    After a very brief test (~20 minutes), it does seem to have improved a great deal for me.

    When on a ship, where I suffered most of my lagg, with the game launched through steam, I get ~60 fps regardless of what's actually on the ship. I've loaded in some old characters I had, one which still had a bunch of NPC's spawned from earlier testing, and the FPS seems to stick at 60. This was on a new install of the game, no mods, steam overlay enabled.

    http://imgur.com/a/fmgVl

    In the main menus, the FPS is equally steady, however, when I use the scroll-wheel of my mouse to scroll down the characters I have, the framerate drops with about 10 per 'tick'. (Or well, character.) After moving my mousewheel up and down a few times, the framerate literally becomes 1 for a few seconds (Longer the longer I used my mousewheel), making the game freeze before it regrips itself and works again. I assume loading a character potrait and a name shouldn't take up so much resource, so figured I'd report it in here.

    Another small issue I have now with the game is that to actually have full-screen working for me, I have to tick the option "Borderless fullscreen"; Somehow that and the "Fullscreen" option got mixed up it seems. (Last screenshot) If I untick all options, it runs the game semi-fullscreen with my task-bar overlapping the game, and a title-bar showing up at the top. If I select only fullscreen, it does exactly the same and merely moves the name of the game up a bit. (Last two screenshots) Figured it wouldn't be worth its own thread.

    That's all i got for now. On a starter ship (entirely dark) and a just post-tutorial ship (with some crap on it), FPS seems stable. I don't know how it is for bigger ships, I hope it stays like this! Thank you for (seemingly, I can't tell 100% yet!) fixing the issue.
     
  16. Justin O.

    Justin O. Big Damn Hero

    Not seeing this value in .config, but for the most part, in stable, I am having a playable experience, I still experience weird fps drops/lag spikes occasionally when I cross a specific point x coordinate on a world, often closing the game and reopening it (steam or .exe) will resolve the issue. Biggest problem I am having is second primary quest (Floran Hunting Grounds) is virtually unplayable, as is the Dreadwing mission, my character moves in slow motion and NPCs blink around the screen around my character and can still interact with my character (damage, knock back etc) Echarius Mining facility does not have this issue.
     
  17. Healthire

    Healthire Can't Most Program the Least Chucklefish

    If you don't see the option in your starbound.config just delete it and restart the game. It will create a new starbound.config with the option available.

    Do not use this option if you simply have some performance issues, i.e. 10-60fps. It's only a workaround for the severe performance issues caused by 1.2 where the game would run at extremely low framerates, 1 to 4 fps, on certain graphics cards. It's not a general performance improvement, and for most people enabling the option will result in reduced performance.
     
  18. Don Quixote

    Don Quixote Void-Bound Voyager

    Seems that just deleting the config and restarting the game solved all the problems. I didn't have to check the option, and fullscreen now works with a high frame rate like the unstable. Good show. =)
     
  19. Justin O.

    Justin O. Big Damn Hero

    Have deleted .config and restarted game, and do see limitTextureAtlasSize. After repopulating the .config, and with limitTextureAtlasSize value: false, still experiencing heavy slowdown as described above, so simply repopulating the .config did not fix, but setting that value to true appears to have fixed both the instanced mission slowdown as well as the surface traveling slowdown I was seeing as specific x coordinates while exploring planets. Issue is resolved for me.

    I appreciate you guys putting so much time and effort into these fixes
     
    Last edited: Dec 29, 2016
  20. Trinthakis

    Trinthakis Yeah, You!

    How do you download the 1.2.1 RC2 unstable update. I have Starbound - Unstable installed but the version is only 1.2.1 and I can't opt into any beta or nightly?
     

Share This Page