1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Bug/Issue Game performance (Lags)

Discussion in 'Support' started by Cat_Fuzz, Sep 20, 2016.

  1. mintbubbles

    mintbubbles Void-Bound Voyager

    Throwing my hat in here, I can play Overwatch on epic with 120fps-ish, Starbound is 1fps...ish. Nvidia gpu, amd cpu. Drivers updated.
     
  2. Jerln

    Jerln Master Astronaut

    Well, I fixed my previous issue, the lag spikes were the result of a mod. Now I just have constant lag.
     
  3. BigEaredKittens

    BigEaredKittens Spaceman Spiff

    I still has stuttering even with new update. Nothing changed with specs. No mods.
     
  4. Lumpy Spuds

    Lumpy Spuds Space Hobo

    After the update yesterday, my framerate dropped to unplayable levels (From 60FPS down to 5FPS). Happens upon selecting anything on the Title screen. Tried deleting all game files and reinstalling. My OS and all software is up to date. It happens in a window or in full screen

    MacBook Pro (15-inch, Mid 2010) (Sierra version 10.12.2)
    2.4 GHz Intel Core i5
    4 GB 1067 MHz DDR
    NVIDIA GeForce GT 330M 256 MB
    Intel HD Graphics 288 MB

    I've tried all the suggestions people listed in the forums (no mods turned on, I disabled the steam overlay, changed any settings anyone suggested, etc.)

    Is there any way to just un-update the last update? Everything was fine before that.
     
  5. Don Quixote

    Don Quixote Void-Bound Voyager

    I'll repost here too after seeing replies in the main Starbound thread. The replies there mentioned the possibility this is caused by the game using higher-res textures that 256MB GRAM can't handle. They weren't sure if it was a bug or feature, but it's possible the game is *forcing* the higher res textures instead of *allowing* them. If that's the case, maybe a resolution option would be a fix, but otherwise... well, 256GB is rather dated.

    EDIT: Indeed, the patch notes read as "Use larger texture atlases on graphics cards that support them", so hopefully it's a bug. I wanna meed space Santa =P


    OSX 1.9.5
    late 2009 iMac, 3.06GHz Intel Core 2 Duo
    12GB 1067 MHz DDR3 RAM
    ATI Radeon HD 4670 256 MB

     
    Lumpy Spuds likes this.
  6. Iris Blanche

    Iris Blanche Sealed Armament Forum Moderator

    Merged with the big topic.
    I also edited the topic title.


    Regards
    Iris Blanche
     
  7. Justin O.

    Justin O. Big Damn Hero



    I have nearly the same exact issues with the same computer, also without mods, running OSX Yosemite (10.10.5) with 8 gigs of the same RAM type. No other programs running except when testing with Steam running, but no change when playing with Steam closed. CPU usage never gets above 70%, Starbound shown as using ~20%-25% when on title screen, jumps to 45%-55% when I open the option menu from the title screen and experience the issue, even before starting a game; in game sees same issue, all objects in game animate with sever lag/jitter.

    I have tried the following (almost all testing has been between title screen and option screen from title screen, all attempts to play the game result in the same issue seen when accessing 'options' from the title screen):
    Running both from steam (with steam open) and from computer without ever opening Steam
    Steam overlay enabled and disabled
    VSync enabled and disabled
    Have deleted and reinstalled game multiple times (so far as to delete all files introduced with install, beyond what steam deletes with uninstall)
    Have tried full screen, borderless and windowed play all at every resolution combination between my computer settings and Starbound's settings (took forever to test every combination)
    Have edited frame skip in both directions in config file

    One point worth noting is often (not always) when opening Starbound: cursor will lag on title screen until I open options (cursor will continue to lag while on option screen) and then when going 'back' to the title screen the cursor will stop lagging on the title screen. But when returning to options, cursor lag will be present; going 'back' to title screen will stop cursor lag; 'options' lag, title screen no-lag, 'options' lag, title screen no-lag, 'options' lag, title screen no-lag

    Was unaware there was an update, but my timeline for this issue coincides with Lumpy Spuds'
     
    Last edited: Dec 17, 2016
    Lumpy Spuds likes this.
  8. mutantlittle

    mutantlittle Intergalactic Tourist

    I'm having a massive amount of lag as well in game, title screen and toon selector are at 60 fps but in game its 5-15 fps and the game eats my inputs; I have to mash left or right to start running, my weapons are failing to shoot and attack when I click (I have to hold to attack).
    my specs?
    Gpu is running version 376.19 i'm now updating it to 376.33 but i don't believe it matters.

    Operating System
    Windows 7 Home Premium 64-bit SP1
    CPU
    AMD FX-4300 22 °C
    Vishera 32nm Technology
    RAM
    8.00GB Dual-Channel DDR3 @ 799MHz (11-11-11-28)
    Motherboard
    MSI 970 GAMING (MS-7693) (CPU 1) 31 °C
    Graphics
    SANYO LCD (1920x1080@60Hz)
    ASUS VS197 (1366x768@60Hz)
    NVIDIA GeForce GTX 970 (MSI) 59 °C
    Storage
    465GB TOSHIBA DT01ACA050 SATA Disk Device (SATA) 41 °C
    Optical Drives
    HL-DT-ST DVDRAM GH24NSB0 SATA CdRom Device
    Audio
    Realtek High Definition Audio

    update
    after updating my drivers and restarting my pc starbound started running at 60 fps.
     
    Last edited: Dec 18, 2016
  9. biovixy

    biovixy Void-Bound Voyager

    I'm having severe fps drops every time I pick up an item or hit an enemy, otherwise the game runs fine after last update. I'm using a late 2009 iMac with macOS Sierra.
     
  10. Lumpy Spuds

    Lumpy Spuds Space Hobo

    I have the same random cursor thing on the title screen at times, too. And I also tried completely deleting all the files and reinstalling from scratch. I hope they fix it soon.
     
  11. Healthire

    Healthire Can't Most Program the Least Chucklefish

    Can you (and anyone with the same issue) try each of the following steps and see if any of them help?

    1. Go into options and uncheck "Multiplayer With Steam Friends"

    2. Run starbound directly from the executable, instead of launching it from steam.

    3. Update graphics drivers.

    I think there may be multiple issues going on. One that occurs when running the game through steam, and one that's related to the texture size change some people in this thread have mentioned. It would be nice to confirm whether this is two issues or just the steam one.

    Thank you!
     
  12. futons

    futons Void-Bound Voyager

    I've been having all the same problems as everybody else in the thread, so I came to try these, but there's already a problem with Step 1...

    Here's what I'm presented with...

    [​IMG]


    The player select screen is similar in appearance, and when I can actually get into a game, it either runs at a single frame per second, or all other graphics besides from the background imagery are invisible.

    Edit: It should be mentioned that when these problems present themselves, my mouse curser becomes invisible, and I can't select anything.

    Edit 2: Now NO images are showing, the only sign that the game is loading is the logo sound...
     
  13. F0bos

    F0bos Space Hobo

    Hi, buy the game yesterday, experience lag in full screen (5-15 fps). stretched window (10-20 fps) small windows (35-50 fps)

    • Laptop AMD Quad-Core A8 2.5GHz - dedicated Radeon R5 2gb - 4gb Ram
    • steam running
    • Windows10 64
    • Any selected zoomlevel works the same

    English isn't my first language, so please excuse any mistakes.
     
    Last edited: Dec 19, 2016
  14. Jerln

    Jerln Master Astronaut

    1. No change in framerate.

    2. Chucklefish logo did not animate, framerate was slightly worse.

    3. [Edit] After updating to the newest OS X version, my framerate has gotten significantly worse. Before, it was about 8 fps, now it is 1 fps.
     
    Last edited: Dec 19, 2016
  15. ddlzz

    ddlzz Space Hobo

    Hi everybody!
    I have the same issue with constant lags and this also affects my keyboard controls, especially trying to jump while moving stops the character. I also have some delay between pressing mouse button and using weapon.
    Tried every possible solution (run directly starbound.exe with every compability options, disabling vsync, maximizing zoom etc.) and nothing works.

    my specs:
    Mobile QuadCore Intel Core i7-3632QM, 2900 MHz (29 x 100)
    8060 МБ (DDR3-1600 DDR3 SDRAM)
    NVIDIA GeForce GT 635M (2 Gb)
    win7 SP1 x64

    Starbound 1.2.

    Hope you'll fix this with future updates because it's impossible to play for now.
    Best regards
     
    Last edited: Dec 19, 2016
  16. Disastericks

    Disastericks Aquatic Astronaut

    So i have a similar problem, The game is almost unplayable when i launch it from STEAM. Thats the weird part, When I go into the local files and launch as an Admin I can play the Game perfectly, but when i launch it from steam the FPS delay is unbearable.
    System Manufacturer ASUSTeK COMPUTER INC.
    System Model G771JM
    System Type x64-based PC
    System SKU ASUS-NotebookSKU
    Processor Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz, 2501 Mhz, 4 Core(s), 8 Logical Processor(s)
     
  17. Healthire

    Healthire Can't Most Program the Least Chucklefish

    There is a new unstable build of starbound out with potential fixes for the newly introduced framerate issues. If they turn out to work there can be a stable update in 1-2 days. Any help testing the unstable, by downloading the Starbound - Unstable app on Steam, is appreciated. Please report back with whether the unstable fixes your issue!

    Thank you!
     
  18. Jerln

    Jerln Master Astronaut

    The Unstable build worked like a charm, my render fps is better than ever before! I get 55-60 frames per second everywhere now, thank you!
     
  19. Don Quixote

    Don Quixote Void-Bound Voyager

    Unstable didn't fix the frame rate on my end. Best circumstances seem to be full screen with steam multiplayer turned off, but I still only get 5-10fps, even during the cutscenes in the opening.
     
  20. Justin O.

    Justin O. Big Damn Hero

    None of the above was able to correct the issue.

    Unstable version WAS able to correct issue except on ship, where lag was exceptionally bad, Planet side I did not see the issue. What is the problem that was addressed in unstable hotfix?
     

Share This Page