1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Bug/Issue Game performance (Lags)

Discussion in 'Support' started by Cat_Fuzz, Sep 20, 2016.

  1. Setarian

    Setarian Space Hobo

    Add me to the list, bought the game a week ago and it runs at 30 fps at best, 7-14 if I'm near any NPCs such as the ark.

    Win 10
    Intel i5-3230m 2.6
    8g ram
    Radeon hd 7650m 4gb ram

    Disappointing. It's such a great game, but it seems like an unacceptable chunk of the player base experiences this problem, or similar issues
     
  2. Ogninja84

    Ogninja84 Space Hobo

    Sounds like I'm not the only one having this problem! Turning off vsync in game got rid of the flashing screen, but now the screen tearing is constant! Any kind of help would be great

    Win 10
    Intel I5-4460 3.2ghz
    16g ram
    AMD Radeon R9 200 Series

    Really want to be able to play this game!
     
  3. Slavyanin

    Slavyanin Orbital Explorer

    Last unstable version
    1920x1080 zoom x2 34FPS in Outpost near Tech Terminal
    1680x1050 zoomX3 47FPS in Outpost near Tech Terminal
     
  4. PotatoMaster

    PotatoMaster Void-Bound Voyager

    So many lag problems and devs can't fix them. I think this lag problem is a thing for like.. 3 years. RIP
     
    archi8ald likes this.
  5. CaptainTaz

    CaptainTaz Starship Captain

    So I recently went to the ruin, and I found an interesting issue.

    Breaking blocks and moving around worked in full time, but enemies were slow and extremely laggy. I think a lot of the lag stems from AI activity in entities, there's something that makes them hard for starbound to handle (especially seeing as the ruin is literally filled with enemies). My computer wasn't even taxed either, so its whatever Starbound gets allocated to it I think.
     
  6. leracos

    leracos Subatomic Cosmonaut

    And here I go as well. Fine up until 1.3, now all of a sudden the crew on my ship (now christened the 'Lagship') are causing massive lag. By no means am I running an incapable system either.

    AMD Phenom 3.8GHZ 8-Core
    16GB DDR 2400 RAM
    ASUS AMD X9 270 2GB GPU
    Running on RAID 0 SSD array, 2x120GB
    Win 10 Pro x64

    All other areas work fine, it's just my 'Lagship.' I already fired and re-hired crew, and even without the max 12 crew the problem re-appears (worse than before even, it seems). V_V
     
  7. redking256

    redking256 Void-Bound Voyager

    Also having really low fps and stutter problem both on ship and planet surface (Ship is like 15~30 fps while Planet surface is 20~50) since 1.3

    i7-4720HQ 2.6ghz
    16gb RAM
    GTX 980m
    Win10 x64
     
  8. LightNeZz

    LightNeZz Space Hobo

    I'm having low fps and stutters in Starbound multiplayer.

    Specs: i7-2600 16GB RAM Asus R9 280X

    Every game works without lag on my computer except this one.
     
  9. CCal

    CCal Space Hobo

    Ryzen R1700 @ 3.2 GHz
    16 GB RAM
    GTX 1080
    Installed on SSD Evo 840

    I am getting like 35-40 FPS at teh outpost at maxed zoomed out level.
    What the hell?? I thought I''ll get to enjoy constant 60 FPS after getting this new rig....
     
  10. first_in_charge

    first_in_charge Yeah, You!

    my pc:
    CPU = FX-6300
    GPU = R9 FURY NANO driver version = 17.5.2
    RAM = 8GB DDR3 1600MHz
    windows 10 pro
    game version = 1.3

    not that high end but should be enough for this game

    before all there's no other game or heavy program opened and my pc is not overheating

    the game is very unstable and running at low fps less than 20 in the mech 'battles' , i also tested it in a i5 4210U and 820M laptop running linux and it ran at 60 i the same situation,
    you guys seem incapable of helping!
     
    Last edited: Jun 14, 2017
  11. first_in_charge

    first_in_charge Yeah, You!

    one way to get better performance is using Linux but i don't have the numbers to show cause my steam overlay was making the game crash
     
  12. leracos

    leracos Subatomic Cosmonaut

    All due respect, but this isn't a solution. It's a workaround.
    I think I speak for everyone here when I say we want a *solution*. None of us want to be forced to switch to another platform to play the game due to a problem that has either existed for a long time, or exists now because of the 1.3 update.
     
    Gotcha! and archi8ald like this.
  13. first_in_charge

    first_in_charge Yeah, You!

    I'm having this problem since 1.2 and by one way to get better performance i meant a workaround but we all still want a solution even if switching to linux make the game playable.
     
  14. bluervince

    bluervince Space Hobo

    so we wait for chucklefish to fix it? forever?
     
  15. 3nding

    3nding Void-Bound Voyager

    I just can't finish the game cause it gets too laggy in the arena with the last boss.

    (Not to mention the Outpost or The Ark)

    Shame.Shame.Shame.

    [It happens to be the only laggy game on my pc as well]
     
  16. Forum_Romana

    Forum_Romana Intergalactic Tourist

    So I've read through every guide I could find on the Steam Community, Subreddit, and, not to mention, the Chucklefish Forums! None of these fixes seem to have worked for me.
    First of all, since this seems to vary,

    What is the problem?

    When launching the game, I get the standard api-ms-runtime shtick that everyone else gets, and this error does not appear when launching through Steam. I can manually through the win32 folder, but the 64-bit version gives me the error code.
    When I launch the 32-bit version (I would like to remind you that I am running a 64-bit version of Windows 7), the game loads as usual and starting from the Title Screen, I am facing 1 - 5 FPS. The Title Screen. Navigating to play the game doesn't
    seem to work either, and I could barely make it through the first room of the tutorial.

    My computer's a piece of crap (see system details), but it can run other, more intense games just fine (and certainly things more intense than the Main Menu).

    What have I done to fix it?

    Now, I may be forgetting some of this as I've easily spent 4 hours at the computer trying to fix it, not to mention time spent while the computer was doing something. Here is the list, in no particular order:


    • Running the vc_redistx64/x86 .exe files and repairing them in Starbound\_CommonRedist\vcredist\2015
    • Completely deleting the Starbound directory in \Common and uninstalling/reinstalling the game. (Done multiple times throughout the process)
    • Turning off VSync in .config file.
    • Adding/Increasing MaxFrameskip in .config file.
    • Deleting the .config file.
    • Externally downloading Microsoft Visual C++ 2015, which wouldn't work because it's "Already installed on your computer."
    • Running both .exes as an administrator.
    • Removing "sw" from opengl32sw.dll in Win64.
    • Installing Windows 7 x64 Service Pack 1 (I already have it installed; and, contrary to the Microsoft Support Blog, cannot uninstall it and reinstall it from the Control Panel.)
    • Trying to manually install any of the recommended files with a .msu extension from the cryptic Microsoft Download Catalog (You seriously need a degree in Computer Science and knowledge of the Dark Arts to figure this website and its contents out).
      Doing this just results in it "Checking for Updates" indefinitely.
    • Trying to install the CRT thingamajigger from Microsoft.com with similar results as above.
    • Trying to run the fabled DirectX file that is supposed to be located under \_CommonRedist, but does not actually exist.
    • Turning my computer off and on again.
    • Running another nonexistent opengl.exe file.
    • Updating my computer. Oh boy, has this been hell. I have had updates turned off for a couple of years because I would get, like, three a day at some points. When I turned Windows Updates back on and shut down my computer, the first 54 of 152 went
      by fine. When I shut it down again so it could download the remaining 98, and the computer froze for several hours at "Downloading 1 of 98" and it eventually went to sleep. When I "woke the computer up" the screen turned on but was receiving no signal.
      After roughly half an hour, I just did a hard reboot and relaunched in Safe Mode. Once I had restarted it again, I went to the Update Center and saw half of these updates in the second batch had failed. There appeared to be no option for fixing them, so I
      resorted to the Microsoft Update Catalog. shudders Here's the issue: I could do a search for an update, let's use a made-up example here: KB236789. When I searched this it would give me a list of options I could download. I was looking for "Update for Windows
      7 64-Bit (KB236789)," and two of those entries had that exact name. And different file sizes. When you click on one of those entries, it gives you downloading options for two (apparently) different files: one in .msu format, and one in .exe format. I
      downloaded the .msu and received similar infuriating results as above.


    What is my computer like?

    OS: Windows 7 Home Premium 64-bit (6.1, Build 7601)
    Processor: AMD E-350 Processor (2 CPUs), ~1.6 GHz
    Memory: 3072 MB RAM
    DirectX Version: DirectX 11
    Graphics: AMD Radeon HD 6310 Graphics
    Display: 1920 x 1080 (32 bit) (60Hz)
    Free Space: 206 GB



    Error Logs

    Code:
    [13:25:16.100] [Info] Root: Preparing Root...
    [13:25:16.101] [Info] Root: Done preparing Root.
    [13:25:16.102] [Info] Client Version 1.3.1 (windows i386) Source ID: 09b4358d76e61cf447ecb3e11612af0c2f387fad Protocol: 742
    [13:25:16.158] [Info] Root: Scanning for asset sources in directory '..\assets\'
    [13:25:19.255] [Info] Root: Scanning for asset sources in directory '..\mods\'
    [13:25:19.256] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [13:25:19.256] [Info] Root: Detected asset source named 'base' at '..\assets\packed.pak'
    [13:25:19.256] [Info] Root: Detected unnamed asset source at '..\assets\user'
    [13:25:19.256] [Info] Loading assets from: '..\assets\packed.pak'
    [13:25:21.366] [Info] Loading assets from: '..\assets\user'
    [13:25:23.967] [Info] Assets digest is 4e8de69be5bcd2006d0b0672905ed9b023d5b430ac6540941d2fb31a8e0c9397
    [13:25:23.968] [Info] Root: Loaded Assets in 7.80907 seconds
    [13:25:24.012] [Info] Application: Initializing SDL Video
    [13:25:24.091] [Info] Application: Initializing SDL Joystick
    [13:25:24.715] [Info] Application: Initializing SDL Sound
    [13:25:24.822] [Info] Failed to initialize Steam platform services
    [13:25:24.822] [Info] Application: No platform services available
    [13:25:24.822] [Info] Application: Creating SDL Window
    [13:26:39.243] [Info] Application: Enabling VSync with late swap tearing
    [13:26:39.421] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [13:26:39.664] [Info] OpenGL version: '4.5.13399 Compatibility Profile Context 15.200.1062.1004' vendor: 'ATI Technologies Inc.' renderer: 'AMD Radeon HD 6310 Graphics' shader: '4.40'
    [13:26:39.758] [Info] Application: initialization...
    [13:26:39.819] [Info] Root: no runtime config file, creating new default runtime config
    [13:26:39.819] [Info] Root: Loaded Configuration in 0.000444459 seconds
    [13:26:39.995] [Info] Application: renderer initialization...
    [13:26:40.023] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 128
    [13:26:40.315] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 64
    [13:26:40.362] [Info] Root: Loaded ImageMetadataDatabase in 5.77219e-06 seconds
    [13:26:41.321] [Info] Application: main update loop...
    [13:26:42.506] [Info] Root: Loaded NameGenerator in 0.543368 seconds
    [13:26:43.478] [Info] Root: Loaded PlantDatabase in 0.97217 seconds
    [13:26:49.350] [Info] Root: Loaded ProjectileDatabase in 5.87105 seconds
    [13:26:51.140] [Info] Root: Loaded MonsterDatabase in 1.78926 seconds
    [13:26:51.568] [Info] Root: Loaded NpcDatabase in 0.428278 seconds
    [13:26:51.588] [Info] Root: Loaded StagehandDatabase in 0.0191861 seconds
    [13:26:51.619] [Info] Root: Loaded VehicleDatabase in 0.0312385 seconds
    [13:26:51.731] [Info] Root: Loaded PlayerFactory in 0.11126 seconds
    [13:26:52.767] [Info] Root: Loaded ObjectDatabase in 10.8 seconds
    [13:26:52.776] [Info] Root: Writing runtime configuration to '..\storage\starbound.config'
    [13:26:52.932] [Info] Root: Loaded VersioningDatabase in 0.162793 seconds
    [13:26:52.932] [Info] Root: Loaded EntityFactory in 1.20102 seconds
    [13:26:53.285] [Info] Root: Loaded ParticleDatabase in 0.352299 seconds
    [13:26:56.180] [Info] Root: Loaded MaterialDatabase in 3.24879 seconds
    [13:26:56.244] [Info] Root: Loaded TerrainDatabase in 0.0633999 seconds
    [13:26:56.666] [Info] Root: Loaded BiomeDatabase in 0.421737 seconds
    [13:26:56.706] [Info] Root: Loaded LiquidsDatabase in 0.0394818 seconds
    [13:26:56.812] [Info] Root: Loaded StatusEffectDatabase in 0.105967 seconds
    [13:26:59.669] [Info] Root: Loaded DamageDatabase in 2.85732 seconds
    [13:26:59.716] [Info] Root: Loaded EffectSourceDatabase in 0.0461019 seconds
    [13:26:59.813] [Info] Root: Loaded FunctionDatabase in 0.096522 seconds
    [13:27:00.209] [Info] Root: Loaded TreasureDatabase in 0.396075 seconds
    [13:27:03.972] [Info] Root: Loaded DungeonDefinitions in 3.76312 seconds
    [13:27:04.033] [Info] Root: Loaded TilesetDatabase in 0.060669 seconds
    [13:27:04.270] [Info] Root: Loaded StatisticsDatabase in 0.237138 seconds
    [13:27:04.344] [Info] Root: Loaded EmoteProcessor in 0.0733813 seconds
    [13:27:04.802] [Info] Root: Loaded SpeciesDatabase in 0.457046 seconds
    [13:27:05.419] [Info] Root: Loaded QuestTemplateDatabase in 0.617618 seconds
    [13:27:05.645] [Info] Root: Loaded AiDatabase in 0.225333 seconds
    [13:27:05.694] [Info] Root: Loaded TechDatabase in 0.0483338 seconds
    [13:27:06.141] [Info] Root: Loaded CodexDatabase in 0.445683 seconds
    [13:27:10.347] [Info] Root: Loaded BehaviorDatabase in 4.20566 seconds
    [13:27:10.434] [Info] Root: Loaded DanceDatabase in 0.0870396 seconds
    [13:27:10.514] [Info] Root: Loaded SpawnTypeDatabase in 0.07968 seconds
    [13:27:10.565] [Info] Root: Loaded RadioMessageDatabase in 0.0506247 seconds
    [13:27:30.705] [Info] Root: Loaded ItemDatabase in 37.937 seconds
    [13:27:31.380] [Info] Root: Loaded CollectionDatabase in 20.8149 seconds
    [13:27:31.659] [Info] Creating player storage directory
    [13:27:33.771] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [13:28:13.485] [Info] Root: Writing runtime configuration to '..\storage\starbound.config'
    [13:28:39.936] [Info] Application: quit requested
    [13:28:39.937] [Info] Application: quitting...
    [13:28:39.937] [Info] Application: shutdown...
    [13:28:40.136] [Info] Root: Shutting down Root
    [13:28:40.706] [Info] Application: Destroying SDL Window
    [13:28:41.899] [Info] Application: stopped gracefully
    
     
  17. azimoert

    azimoert Space Hobo

    2-5 FPS in game all the time.

    My specs:
    Windows 10 x64
    Intel i7 4770k
    Radeon 7990 HD 6Gb
    32 Gb ram DDR 3 3900 MHz

    My guess is that there is some kind of optimization issue. I mean my gf play the game just fine when I have PC 4 times better and can not play at all. Possibly latest drivers or any other updates causing this issues. The thing is downgrading for me is not a solution at all.
     
    Last edited: Jul 6, 2017
  18. lazarus78

    lazarus78 The End of Time

    Does not meet the minimum requirements

    For reference, your CPU sores terribly in performance: https://www.cpubenchmark.net/cpu.php?cpu=AMD+E-350+APU
     
  19. Forum_Romana

    Forum_Romana Intergalactic Tourist

    Does no
    Ah, so I'm a dolt then. (My PC is long overdue for an upgrade). The reason I didn't outright assume that was because I can run other games like FTL, Minecraft, or CS:Source which are far more graphically intensive than this.
    Thanks, anyways!
     
  20. Slimonz

    Slimonz Intergalactic Tourist

    Thought I'd jump in even...came back to the game after about a year and am getting 20fps on the title screen and in game. Tried a bunch of things from forums posts and the subreddit but so far no luck. Trying to remain optimistic!

    Laptop specs:
    ASUS ROG G550JK
    Intel Core i7 4700HQ Processor
    DDR3L 1600 MHz SDRAM, 8Gb (could be 16, can't remember and I'm at work)
    NVIDIA GeForce GTX850M
    Windows 10 x64
     

Share This Page