1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Closed Game not connecting to Steam Workshop?

Discussion in 'Starbound Support' started by JumpingJupiter, Jul 28, 2016.

Thread Status:
Not open for further replies.
  1. JumpingJupiter

    JumpingJupiter Big Damn Hero

    I apologize if this has been asked before, I used the search function and couldn't find anything on this particular issue. As the title says, the game for some reason will not connect to the Workshop, so my mods cannot be accessed.
    The game was working fine yesterday, and I have not done anything new since then. I thought it could possibly be because of the small update, but that was done yesterday I think, and was fine when I was playing, so I don't know.
    Does anyone have an idea of what to do? I've turned the game on and off multiple times and have reinstalled as well, and they did not work.
  2. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    I don't have this issue so it should not be related to the updates. Are you running starbound with or without steam? Have you tried resubscribing to the mods?

    ~ Iris ~
  3. JumpingJupiter

    JumpingJupiter Big Damn Hero

    I'm running it with Steam, and have also tried resubscribing to the mods. That doesn't seem to be the issue though, because when I click on the mods wheel in the menu, the workshop button is greyed out, like this:
    starbound mods no work.png
  4. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    It seems that starbound doesn't recognize steam at all. You can try copying your mods from the workshop folder into the regular mod folder. The workshop mods are located here: [your steampath here]\SteamApps\workshop\content\211820
    But starbound won't scan recursive so every folder which contains a content.pak file needs the file being renamed.

    Alternatively you can create a script (batch file) in your starbound folder with following content:
    @echo off
    ;REM Set your steampath here
    ;REM Do not remove the quotes or add an \ at the end otherwise the script will not work properly
    ;REM Example:
    ;REM C:\Program Files(x86)\Steam
    set STEAMPATH="[your steampath goes here]"
    for /f "tokens=*" %%G in ('dir /b /a:d "%STEAMPATH%\SteamApps\workshop\content\211820"') do (
      echo Processing Mod %%G
      if exist mods\%%G.pak (
      if exist %STEAMPATH%\SteamApps\workshop\content\211820\%%G\contents.pak (
      xcopy /D /Y %STEAMPATH%\SteamApps\workshop\content\211820\%%G\contents.pak mods\%%G.pak
      ) else (
      echo Deleting Mod %%G
      rmdir %STEAMPATH%\SteamApps\workshop\content\211820\%%G
      del /Q mods\%%G.pak
      ) else (
      ;REM create fake file for windows if not existent to stop asking if folder or file when copying
      echo Installing Mod %%G
      echo X>mods\%%G.pak
      xcopy /Y %STEAMPATH%\SteamApps\workshop\content\211820\%%G\contents.pak mods\%%G.pak
    I'm using this script for synchronizing the workshop mods with my starbound server. The script also has a nice side effect: it keeps you workshop folder clean because it deletes unsubscribed mod folders.
    At least it is a workaround. I think you're experiencing the same error like the ppl who have the "steam multiplayer greyed out" issue. Unfortunately i can't offer a real fix for this particular issue but maybe you can find something in topics related to steam multiplayer.

    ~ Iris ~
Thread Status:
Not open for further replies.

Share This Page