Modding Help Game Crashing Upon Startup

Discussion in 'Mods' started by fallingforever332, Aug 23, 2018.

  1. fallingforever332

    fallingforever332 Void-Bound Voyager

    I get this exact log every time I try to start my game:

    [21:45:46 INFO SMAPI] SMAPI 2.7 with Stardew Valley 1.3.29 on Microsoft Windows 10 Home
    [21:45:46 DEBUG SMAPI] Mods go here: C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley\Mods
    [21:45:46 TRACE SMAPI] Log started at 2018-08-23T02:45:46 UTC
    [21:45:47 DEBUG SMAPI] Starting game...
    [21:45:51 ERROR SMAPI] The game failed unexpectedly: System.MissingMethodException: Method not found: 'System.Collections.Generic.IEnumerable`1<StardewValley.Farmer> StardewValley.Game1.getOnlineFarmers()'.
    at StardewModdingAPI.Framework.SGame.Update(GameTime gameTime)
    at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
    at Microsoft.Xna.Framework.Game.Run()
    at StardewModdingAPI.Program.RunInteractively() in C:\source\_Stardew\SMAPI\src\SMAPI\Program.cs:line 304
    [21:45:51 INFO SMAPI] Game has ended. Press any key to exit.


    I have tried everything from deleting and reinstalling both SMAPI and Stardew Valley itself as well as restart my computer and verify the game files. I am at a loss. Any help would be much appreciated!!
     
    • Moragaine

      Moragaine Existential Complex

      You're on the newest beta branch, but Smapi hasn't been updated for that yet.
       
      • LeonXross

        LeonXross Void-Bound Voyager

        I have this same problem but I have no idea what you are talking about. Is there a solution here or not? What is beta branch?
         
        • panforever

          panforever Space Hobo

        • LeonXross

          LeonXross Void-Bound Voyager

        • LeonXross

          LeonXross Void-Bound Voyager

          panforever likes this.
        • panforever

          panforever Space Hobo

          yea I take it thats what moragraine meant with opted in beta, but I aint opteed into the beta branch of stardew
           
          • dmiranda9872

            dmiranda9872 Space Hobo

            Last edited: Nov 19, 2018
          • panforever

            panforever Space Hobo

            Yea stardew had a update and so did smapi =3 updating to 2.8 makes it work again.
             
            • virszka

              virszka Void-Bound Voyager

              Yeah it does work, updating smpai I mean, but damn now all the mods crashed
               
              • Mobfi.Steinbaum

                Mobfi.Steinbaum Aquatic Astronaut

                same here.. :/
                 
                • Amu Tsukiyomi

                  Amu Tsukiyomi Master Chief

                  The only question is, if your mods have all crashed because they're "out of date" but SMAPI's mod list says they're compatible with the latest version.....does this mean we download the one that currently says it's for SDV beta/SMAPI 2.8 only because the other one is the version you already have?
                   
                  • Moragaine

                    Moragaine Existential Complex

                    Start with updating Smapi to 2.8.2 and then check what needs updating. And if there isn't a specific update for .32 stable, any of the updates for .32-beta should work.
                     

                    Share This Page