Modding Help Furious Koala 0 Assets!

Discussion in 'Starbound Modding' started by Kairain, Jan 26, 2014.

  1. mescale

    mescale Scruffy Nerf-Herder

    Ahh it can't find the file, its because we're deeper in the directory structure in Mac OS X than on a PC. Try...

    ./asset_unpacker ../../../assets/packed.pak ../../../assets/starbound_assets/
  2. Th33 New Guy

    Th33 New Guy Void-Bound Voyager

    help im using windows and im still new to modding but i have tried moving the unpack.exe to a new folder iv tried running cmd but still i cant get it to worl it just closes as soon as i try to run the unpacker.

    {EDIT} OK i got CMD but it says im missing pcre3.dll and to reinstall the program?? idk what to do about it
    Last edited: Jan 26, 2014
  3. Aznshura

    Aznshura Void-Bound Voyager

    Ok here's what you do in Windows the easy way

    go to steam/steamapps/common/win32/

    when you are in the "win32" folder you will see both "asset_unpacker.exe" and "asset_packer.exe" - Press from keyboard Shift+Right Click Mouse

    you will then see "Open Command Window Here", click it.

    then type/copy "asset_unpacker.exe ..\assets\packed.pak ..\assets\starbound_assets\" - now you have to wait, until you get a new message from command line
    "Unpacked assets to ..\assets\starbound_assets\ in (time of unpacked)seconds"

    Now if you go to the "assets" folder you will see "starbound_assets" which will have all the assets files ;D
    Th33 New Guy likes this.
  4. Th33 New Guy

    Th33 New Guy Void-Bound Voyager

  5. Cefido

    Cefido Intergalactic Tourist

    Wow! that worked!
    Thank you a lot! really!

    Are there differences to windows if i want to pack it again?
  6. mescale

    mescale Scruffy Nerf-Herder

    to pack it you would probably use the command like this...

     ./asset_packer ../../../assets/starbound_assets/ ../../../assets/starbound_custom_package/packed.pak
    Note the command above will pack it into the starbound_custom_package folder, otherwise it might overwrite the one in the assets folder, which might be bad, you can rename the original paked.pak file to keep a backup and copy the newly packed one in there by hand.

    I changed the command to another directory than the starbound assets because if we're putting the packaged file into the folder we're packing bad things could happen ;)
    Last edited: Jan 26, 2014
  7. Th33 New Guy

    Th33 New Guy Void-Bound Voyager

    nope its telling me im missing the asset unpacker but its there
  8. Cefido

    Cefido Intergalactic Tourist

    That sounds logical.
    again, thank you a lot.
    Now i will need to try out a lot :)
  9. mediumkahuna

    mediumkahuna Void-Bound Voyager

    Once the assets are unpacked, will editing the assets in that folder, such as ore distribution/mob encounters etc. affect the game or is purely for modding purposes?
  10. intervencion

    intervencion Existential Complex

    Can anyone put here a .bat file for Windows? Really can't unpack >.<

  11. Cobalt Lightning

    Cobalt Lightning Existential Complex

    What do we do when the command prompt of the .exe does not stay open and nothing happens? Windows version btw
  12. The | Suit

    The | Suit Agent S. Forum Moderator

    You don't run it like a normal program.
    You can only access it via command line, which requires you to use run --> type CMD
    then the command line window opens up.

    You should read the rest of the steps here

    Its much easier to make a batch script.
    Just right click --> new text document.

    and paste
    "C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_unpacker.exe" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\assets\packed.pak" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\Assetbackup"
    and rename the file extract.bat

    The syntax is "[Location of Unpacker]" "[Location of packed.pak file]" "[Location of where you want to unpack]"
    Do not add any enters or extra spaces then what is already above, or it won't work.
    vigilante93 likes this.
  13. SkyPirateRusvul

    SkyPirateRusvul Void-Bound Voyager

    Hey... I'm trying to access my assets as well. I've followed your steps, Freyon, but they have resulted in an error. "The program can't start becaues pcre3.dll is missing from your computer. Try reinstalling the program to fix this problem."


Share This Page