Modding Help Furious Koala 0 Assets!

Discussion in 'Starbound Modding' started by Kairain, Jan 26, 2014.

  1. Kairain

    Kairain Intergalactic Tourist

    So the patch has come out and I was going to check the mod i was working on would open up ect. There was a bug of course so I went to look at any changes to the assets folder when I am met with the bellow. So anyone else suddenly found all the assets have gone walk about?
    So does anyone know where they may have gone or what has happened? as this no longer seems like a mod friendly game to me -.-
  2. Whaleduck

    Whaleduck Big Damn Hero

    Looks like steam MIGHT have fumbled your download because i had more folders in assets then that. try to delete local files and reinstalling. I am trying that at the moment.
  3. dante161

    dante161 Title Not Found

    It's normal, all of your assets are packed into the file packed.pak
    The | Suit and DrPvtSkittles like this.
  4. Miwa

    Miwa Aquatic Astronaut

    Read the patch notes...
  5. Underbalanced

    Underbalanced Phantasmal Quasar

  6. Beta1556

    Beta1556 Void-Bound Voyager

    Everything went into the "packed.pak" file.
  7. Underbalanced

    Underbalanced Phantasmal Quasar

    I like it, Makes coping the files easier. Takes forever with a billion small files.
  8. Kairain

    Kairain Intergalactic Tourist

    so i guess its a case of waiting and looking into how this new pak file works
  9. mescale

    mescale Scruffy Nerf-Herder

    There is an unpacker executable.

    For Windows its a command line tool.

    Go to the Starbound\win32 folder.


    It will tell you

    Usage: asset_unpacker.exe <assets pak path> <output folder>

    So to unpack your package.

    You can type...

    asset_unpacker.exe ..\assets\packed.pak ..\assets\starbound_assets\
    If its successful it might say:

    Unpacked assets to ..\assets\starbound_assets\ in 48.675s

    Using the command as above unpacks the assets to a folder called starbound_assets in the Assets folder. I put it there so I didn't break anything, you could presumably extract it straight into the assets folder, or on your desktop.

    There is also a asset unpacker file in the linux folders, if you're using linux you should be able to work it out.

    I'll try booting into MacOS to see how the mac version works.

    Well on my Mac it seems the game crashes as soon as its run, possibly because I'm on an old version of Mac OS X.

    However I have a theory...

    There is a file in the package for the unpacker, using the terminal you should be able to access it.

    Open a terminal


    cd /Users/andrew/library/application support/steam/steamapps/common/starbound/

    See if it returns something like

    Usage: asset_unpacker <assets pak path> <output folder>

    If it does then you can use the same command as the windows version with your slashes the other way round of course.
    Last edited: Jan 26, 2014
    intervencion likes this.
  10. Cefido

    Cefido Intergalactic Tourist

    Please let me know if you found a way
  11. Freyon

    Freyon Scruffy Nerf-Herder

    Struggled a bit with it, but here's how I've done it:

    (I'm using Windows BTW)

    • Copy the asset_unpacker.exe and asset_packer.exe into another folder, which is where I'll do my modding.
    • Shift+Right Click and select Open Command Window Here
    • Now you'll notice that your cmd has opened in that directory.
    • Type: asset_unpacker.exe (file.pak) (foldername)

    In my case: "asset_unpacker.exe packed.pak test"

    This extracted everything to the test folder.

    For packing, simply do the same, but point the folder you want to pak and the output file name.
    Armed Mosquito likes this.
  12. Kairain

    Kairain Intergalactic Tourist

    thanx guys now i might be able to find whats bugged out with my mod
  13. mescale

    mescale Scruffy Nerf-Herder

    I get a SegFault if I try running Starbound on my Mac Probably because I'm using an old version of Snow-Tiger-Lion. Try the following.

    Open a terminal


    cd /Users/andrew/library/application support/steam/steamapps/common/starbound/

    See if it returns something like

    Usage: asset_unpacker <assets pak path> <output folder>

    If it does then you can use the same command as the windows version with your slashes the other way round of course.
  14. Cefido

    Cefido Intergalactic Tourist

    "no such file or directory"

    Maybe its useless to explain me that, Iam bad at modding.

    I tried that:
    ~ leon$ cd /Users/leon/Library/Application Support/Steam/SteamApps/common/Starbound/

    -bash: cd: /Users/leon/Library/Application: No such file or directory

    Than i thought the space between Application Support/ is the mistake and tried without

    ~ leon$ cd /Users/leon/Library/ApplicationSupport/Steam/SteamApps/common/Starbound/

    -bash: cd: /Users/leon/Library/ApplicationSupport/Steam/SteamApps/common/Starbound/ No such file or directory
  15. mescale

    mescale Scruffy Nerf-Herder

    Oh the space may mean you need to type it in quotation marks try...

    cd "/Users/leon/Library/Application Support/Steam/SteamApps/common/Starbound/"
  16. Tirea

    Tirea Scruffy Nerf-Herder

    Just type in this:
    cd /Users/leon/Library/Application\ Support/Steam/SteamApps/common/Starbound/
  17. Shadow Wolf TJC

    Shadow Wolf TJC Spaceman Spiff

    Somebody really needs to put out a video tutorial of this, because I've got mods that I really want updated to Furious Koala.:pwease:
    Th33 New Guy likes this.
  18. Cefido

    Cefido Intergalactic Tourist

    Wow that works
    Can anyone find my mistake?

    I got that:

    Usage: ./asset_unpacker <assets pak path> <output folder>

    leonsmbp:MacOS leon$ asset_unpacker.exe ../assets/packed.pak ../assets/starbound_assets/

    -bash: asset_unpacker.exe: command not found
  19. mescale

    mescale Scruffy Nerf-Herder

    To run commands in your current directory you need to type ./ first. the directory . is the current directory name, so typing ./ refers to your current directory. It is to stop you from accidentally running a program in your current directory.

    So try.

     ./asset_unpacker ../assets/packed.pak ../assets/starbound_assets/
  20. Cefido

    Cefido Intergalactic Tourist

    Sorry, i have not really used that terminal before :-(

    /assets/packed.pak is missing

    what does that mean?
    i got that:

    leonrsmbp:MacOS leon$ ./asset_unpacker ../assets/packed.pak ../assets/starbound_assets/

    Exception caught: AssetBackendException: Asset database ../assets/packed.pak is missing

    0 asset_unpacker 0x00000001003e7475 _ZN4Star13StarExceptionC2ERKNSt3__112basic_stringIcNS1_11char_traitsIcEENS1_9allocatorIcEEEE + 277

    1 asset_unpacker 0x00000001003aec83 _ZN4Star21AssetsDatabaseBackendC2ERKNS_6StringE + 259

    2 asset_unpacker 0x0000000100398856 main + 86

    3 libdyld.dylib 0x00007fff905805fd start + 1

Share This Page