1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Frequent stutter when screen scrolls after switch from Win7 to Linux

Discussion in 'Mac / Linux Bug Reports' started by ducttape, Jan 19, 2020.

  1. ducttape

    ducttape Void-Bound Voyager

    Hello!
    I have encountered an issue where my game stutters while my character is walking and causing the screen to scroll. It is very distracting and annoying, and I find it makes the game unpleasant enough that I cannot play it.

    I recently (less than a week ago) switched from Windows 7 to Linux Lite. While I had encountered a bit of stuttering previously, on Windows 7, it has never been this bad. I did a few tests, and I found a few things that made it worse, a few things that made it better, but nothing that actually stopped it. Using the Steam framerate tool, I found that my FPS holds steady at around 55-60 regardless.

    Worse:
    1. SMAPI - the game runs more smoothly without SMAPI, but still stutters some
    2. Farm map - the stuttering is worst on the farm map, with the town map moderately affected
    2b. Cluttered areas - the stuttering is much worse in areas with many trees/rocks/weeds/etc.

    Better:
    1. No SMAPI - inverse of above; there is still some stuttering without SMAPI, but it is greatly reduced
    2. High zoom % and windowed mode - running the game in windowed mode and with a zoom of 115% reduces the stutter to nearly the same degree as running without SMAPI' however, this has a very negative effect on the visuals, making the graphics blurrier, and is generally as unpleasant as the stuttering itself

    Recommended Fixes That Did Not Work Or Were Inaccessible:
    • reinstalled game
    • updated graphics drivers
    • disabling f.lux (I don't use it)
    • limiting FPS with Nvidia Profile Inspector (unavailable on Linux, afaik)
    • tweaking graphics card settings (GeForce Experience is also unavailable, and I could not find settings matching the ones the fix described in Nvidia X Server Settings)
    • disabling various mods (some had a mild affect on the stuttering, but not enough that I would call it an improvement)
    • updating XNA (I don't know how to do this, or if it is even possible, on Linux)
    • setting my monitor to 60hz (it has no other setting)
    • various combinations of switching between fullscreen/windowed/borderless modes, with and without vsync (only change is that which was noted above)
    My System:
    OS: Linux Lite 4.8
    CPU: i5-6600k @ 3.50GHz (4 cores, 4 threads)
    RAM: 12215928 KiB
    MOBO: ASUS H170M-E D3
    GPU: GeForce GTX 980
    BuildID: 4490827
    SMAPI Log

    I am afraid that in this instance, my novice understanding of Linux is as much of a barrier as the bug itself; it is quite possible that there is more I could do, but I have not figured it out yet because of my lack of familiarity with the new operating system.

    Thank you for your time and help.
     

    Share This Page