Bug/Issue Flashing Black Screen, crash to desktop

Discussion in 'Support' started by ragnorak02, Aug 10, 2014.

  1. ragnorak02

    ragnorak02 Space Hobo

    Hello. I figured it would be easiest if I showed the bug error report. I have posted it below. When I launch the game from the Steam library my monitor flashes black a few times and eventually brings me back to desktop with this error message. I have tried to update all of my drivers but that doesn't seem to work. I really want to play so figured I may be able to find out how here. Thanks!

    Here are my computer specifications:

    System Type:
    Windows 7 64 bit

    Intel Core i7-2670QM CPU @ 2.20GHz

    Display Adapters:
    AMD Radeon 7400M Series
    Intel(R) HD Graphics Family

    RAM :
    8 GB

    Bug description:

    OS: Windows XP x86, version 5.1
    number of processors: 8
    system property hash: 0xcd6532f

    com.badlogic.gdx.utils.GdxRuntimeException: OpenGL 2.0 or higher with the FBO extension is required. OpenGL version: 1.1.0
    at com.badlogic.gdx.backends.lwjgl.LwjglGraphics.initiateGLInstances(LwjglGraphics.java:246)
    at com.badlogic.gdx.backends.lwjgl.LwjglGraphics.setupDisplay(LwjglGraphics.java:159)
    at com.badlogic.gdx.backends.lwjgl.LwjglApplication.mainLoop(LwjglApplication.java:131)
    at com.badlogic.gdx.backends.lwjgl.LwjglApplication$1.run(LwjglApplication.java:114)

    Display Modes:
    loaded from config: 1280x720x32 (60 hz)
    desktop resolution: 1366x768x32 (60 hz)

    enabled OpenGL software mode: yes
    • CoDi

      CoDi Halfway Developer Developer

      The library we use for OpenGL rendering detects your graphics card to only support "OpenGL 1.1.0". Which seems wrong, as according to http://www.amd.com/en-us/products/graphics/notebook/7400m it supports GL 4.1.

      We'll have a look at it, but it might be difficult to test for this issue without access to similar hardware.

      If you want help us pinpoint the problem, and don't mind to install some 3rd party tool, it would be nice of you to run a tool such as http://www.ozone3d.net/gpu_caps_viewer/ and copy'n paste the version information you find there in this thread. I'm specifically looking for:

      - The entry "OpenGL" in the "GPU" tab.
      - The entry "GL_VERSION" in the "OpenGL" tab.
      • ragnorak02

        ragnorak02 Space Hobo

        I would be happy to help out. I installed and ran gpu caps viewer and got these numbers. I have tried numerous different websites to update all of my drivers. Everytime I look I feel like I find a different place to update. So maybe I am looking in the wrong place. Here are my numbers though. Thanks!

        GPU tab
        Driver: 8.830.6.3000 (5-7-2011) - GL:atig6pxx.dll
        OpenGL: OpenGL 4.4 (AMD Radeon HD 7400M Series with 271 ext.)
        OpenCL: OpenCL 1.2, Caicos compute units:2@750MHz

        OpenGL tab
        Renderer: AMD Radeon HD 7400M Series
        GL_VERSION: version/profile: 4.4.12874 Compatibility Profile/Debug Context
        GLSL version: 4.30
        • CoDi

          CoDi Halfway Developer Developer

          Hm, those outputs look fine. GPU Caps Viewer says your card supports GL 4.4.

          But still, our library gets "1.1.0" as result of querying the GL_VERSION string. Something's terribly wrong here.

          I found some rather old discussions (e.g. related to Minecraft) where users fixed similar problems by uninstalling some utility called "Asus Enhanced Display Driver". No idea if this is still around.
          • CoDi

            CoDi Halfway Developer Developer


            we are still not able to reproduce the error here, but I found one more possible hint in some forums: you might try to disable any secondary monitors before starting the game.
            • Gilou

              Gilou Seal Broken

              I see that you have two video cards on your computer: Intel and AMD. Maybe you are running the game with the Intel card.

              When you run the game, which card is used? To find out, right click on the icon (shortcut or exe), run with graphic card (or something like that), and check if you AMD card is selected.
              • Romanji

                Romanji Space Hobo

                I thought I had the same glitch, but apparently it also happens when you run certain video capture softwares. I was running Xsplit game caster and everytime I moved my screen flickered black and soon crashed to desktop afterwards. I turned off Xsplit and it worked perfectly. Fraps doesn't cause this though. Weird find.

                >Why reply?
                Because I often search for help threads and I wanted to post my experiences in case someone has the same experience I do.
                  Seminus likes this.
                • Seminus

                  Seminus Halfway Developer Developer

                  Thanks @Romanji for pointing this out! Love when players are so supportive! :)

                  Share This Page