1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Tutorial Fixing Lost/Corrupted Universes and Player Files

Discussion in 'Starbound Support' started by Trinosaur, Jul 28, 2016.

  1. Trinosaur

    Trinosaur Big Damn Hero

    Thank you!! I'll add this into the body of my main post. :)
    Metalloman likes this.
  2. Whal

    Whal Aquatic Astronaut

    Question: Is it possible to get a video tutorial of this at some point? I am not intelligent with these kinds of things in the slightest, and it would be useful to see them done, rather than having them explained.
  3. Trinosaur

    Trinosaur Big Damn Hero

    I can certainly try! But it would be difficult to make an all-encompassing video. So if there's something specific you need help with, let me know and I'll try to accommodate.
  4. Whal

    Whal Aquatic Astronaut

    In my case, my character and inventory and ship were saved, but my bookmarks and teleporters were not.
  5. Trinosaur

    Trinosaur Big Damn Hero

    Alright, I'll see if i can't make a video tutorial for you (and others who might find it helpful). I can't guarantee when it'll be done because I am moving countries this week but I will put it on my to-do list. :)
    Whal and Metalloman like this.
  6. Valkyrie_pl

    Valkyrie_pl Big Damn Hero

    Lost my char after power outage. One of the planets and universe file turned to .fail. Sent those and log to that mail address from the 1st post, hopefully they can help. I saw that script thing someone posted earlier, but just looking at the instructions make my eyes glaze over, so I better leave this to professionals. ^^ I have FU universe, hope that's not an issue.

    Also, I tried to restore my char by using bak files, but that just resulted in it being stuck on a ship in an infinite warp.
  7. Pherdnut

    Pherdnut Poptop Tamer

    Alright. Just ran into this issue. I'm a JavaScript developer. We're dealing with JSON (JavaScript Object Notation) and command lines, which all devs deal with.

    Quick gotcha on the instructions (which are much appreciated):

    You're telling people to use the dump_versioned_json.exe command in the part about using the make method. Those who actually know how to copy/paste in the win command line (see below if you don't) are going to have a hard time with that.

    To help reduce command line pain:

    * You can actually get autocomplete of directories in the win command line as you type. Win 10 is more forgiving but even in older win versions you could hit tab after 3-4 characters and as long as you were using derp-windows "\" instead of the less moronic "/" for directory dividers and the exact capitalization of dir-names, it would autocomplete names for a given directory if it could. Rinse repeat and you can work through 6-16 directories in no-time. Linux's is so much better. I still do win for the games.

    * "..\" means back a directory from the one you're in now. Here's my shortened make command after having navigated via "CD <directory name>" the the win32 directory:

    make_versioned_json.exe ..\player.json ..\storage\player\67bad09fa44c63570cb0974391cf9004.player

    * Oh and of course to copy/paste, in win10 at least, right click on the top of the window for the command line for a drop down. IIRC you could r-click anywhere on the window on older win versions. Then select "edit" and "paste" to paste whatever you've ctrl-Ved to your clipboard outside of the command line.

    * Up arrow goes back to previous commands you entered on the command line. Hit enter to re-do those. You can up-arrow multiple times. Helpful for re-making files after undoing bad edits.

    Now, JSON (most of you won't care much about this unless you're unfamiliar and actually want to sort these files out)

    In JS, this is an object or labeled list (stuff referenced via label):


    The basic formatting is:

    "<label for another value>":<value2>

    This is an array or list with no labels (stuff held together based on the order it's in - great for sorting):


    Formatting is simpler:


    In JSON, arrays tend to be lists of objects you'd want to sort based on their properties.

    Now with stuff inside them and JSON-valid:

    "myNotEmptyArray":[1, "cat", {"propertyName":"whatevs"} ]

    If I were writing bookmarks in JS you wouldn't see : [ "<UUID>", [<array of bookmark objects>] ]

    Because that's two unlike things in a generic list. You'd have to write in a rule as you walk through it with code that tells you even items are values, odd items are the UUID they're associated with. I'm not knocking the Starbound devs. It might make a lot of sense to think about it that way if you're dealing with C or god-knows-what regularly, or want to convert from something a little more rigid..

    But in my case you'd see:

    "bookmarks" : {
    "<UUID>": [<array of bookmark objects>],
    "<UUID2>" : [<another perhaps empty array of bookmark objects because power-outage and something quit>]

    But what I had was:

    "bookmarks":[ <universe UUID1>, <bookmarks data1>, <universe UUID2 that agrees with universe.json>, [<nothing here>] ]

    So in my case I'm actually pretty sure my real problem was that I was actually writing the player data to the wrong directory for the first umpteen attempts but solved the problem differently with a different solution by accident anyway.

    I saw this:

    <universe ID not in universe.json>,
    <all my bookmarks>,
    <universe ID from my bookmarks>.
    [] <-- no bookmarks in that array. Just nothing

    So I tried dumping all the bookmarks data into the empty array in the text-file and re-making.

    It worked.

    So try the UUID first but just in case you're having no luck, I did the opposite. I pasted the contents of the entire bookmarks array that was full into the empty array following the UUID that agreed with my universe.json. That works too and might work best if you've got a lot of server play behind you but just want to get your local data back.
    Trinosaur likes this.
  8. Whal

    Whal Aquatic Astronaut

    Another thing about my situation: I fixed the first problem eventually, and I was able to play as normal after replanting my crops. However, the incident happened again, and I was out of range of internet both times. Could it have something to do with syncing with Steam?
  9. smurflee89

    smurflee89 Space Spelunker

    My error wasn't on here, but I do have I guess a lost universe/character of sorts. If someone could help me I would be very greatful. I have asked in the Frackin Universe forums and they had directed me here since they couldn't help me figure it out much. So if I could get help I would appreciate it. I was playing starbound and was in an inventory screen and had went into wiring mode when my screen froze. It was frozen for about 2 minutes before finally crashing. I had restarted Starbound and tried to log into that character like normal, and it only loaded the character with the basic background for about 15 seconds before crashing the game again. I have both the crash file from while I was playing and just from opening the game and trying to launch the character. I tried to go through my .bak files already and all of them still crash. I checked to see if I had a universe fail file but I couldn't find one anywhere in my files. If this isn't the place to be and I need to be directed somewhere else, just let me know. I don't mean to put this in the wrong section. Here are my error logs.
    While I was playing:http://pastebin.com/N7KT0vnw
    Launching character after:http://pastebin.com/i39juPvX
  10. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    One of your mods seems to be faulty, causing an error when in wiring mode. Wiring object have so called nodes and it seems that one of the modded objects messed something up with these.
    It also seems that you removed one or two mods according to your logs which should be unrelated. Also one mod is happily spamming debug stuff ^^'

    Long story short: you will have to find the mod that is causing this error by disabling one after another and contact the appropriate mod author for this particular issue so that the author can fix it.

    ~ Iris ~
  11. Trinosaur

    Trinosaur Big Damn Hero

    My apologies for not responding in the past week or so. I've moved countries and won't be getting stable internet or a proper desk until tomorrow. I'll get back to the video tutorial when I get a chance. As always I appreciate your help, Iris. :)
    Whal and Iris Blanche like this.
  12. smurflee89

    smurflee89 Space Spelunker

    Iris thank you so much for your response! That helped me fix my problem! I appreciate it a lot!
  13. Whal

    Whal Aquatic Astronaut

    *sigh* The issue happened to me again. I have many more teleportation points now, though, so is there any way to recover those? Sorry for having so many issues all over this thread, btw.
  14. Trinosaur

    Trinosaur Big Damn Hero

    Well... I can tell you from experience that I had this issue recently. I'll be using it as an example in my video tutorial on how to fix this stuff. Unfortunately the answer here is that unless you have a back-up set of files for your bookmarks that you created manually, you'll have to hunt the planets down yourself and find all your flags again. That is the only other option unless you took preventative measures; and I gotta say I am VERY glad I did that.
  15. Trinosaur

    Trinosaur Big Damn Hero

    I recorded the video today and I'm currently in the process of uploading my tutorial to Youtube. Look forward to it! :)
    Whal likes this.
  16. Trinosaur

    Trinosaur Big Damn Hero

    OK guys. Here it is! I added it into the body of my main post, but I'll share it here too:

    Iris Blanche and Whal like this.
  17. PriosPrios

    PriosPrios Seal Broken

    Unfortunately, when I picked up my farm animals and put them back down with the new transfer tool, they did not start producing again.

    Even when I tried placing an entirely new farm animal on the planet, that new animal did not produce resources either! It hatched and grew up but never entered a "harvestable" state.

    I tried using /timewarp 99999999 a few times; my crops (which I'd replanted) grew but nothing happened with my animals.

    The only thing that worked was placing a new animal on my ship. Possibly (hopefully) placing animals on another planet would work too. Tearing up my current farm and relocating it to another planet is not my idea of a fun time, though. :(

    ETA: On a mostly-unrelated note, some more relevant universe flags:

    Dash tech challenge: /setuniverseflag outpost_techscientist1
    Distortionball tech challenge: /setuniverseflag outpost_techscientist2
    Killed Dreadwing: /setuniverseflag outpost_beakeasy
    Ursa Miner: /setuniverseflag outpost_ursa_miner
    Trinosaur likes this.
  18. Trinosaur

    Trinosaur Big Damn Hero

    I wish I had some sage advice in this area but unfortunately I don't really know where to even begin. Somebody with more in-depth knowledge of the game, developers even, might know what the problem is. If you haven't already shared your log files etc. with the dev team I certainly would do that.

    And thanks for the flags! I'll add those in for folks who need it as a reference. :)
  19. Whal

    Whal Aquatic Astronaut

    My last backup is from when the issue first started... I'll just have to fix everything and track 'em down, then. Thanks for your help, though. Free cookies for you. :cookie:
    Trinosaur likes this.
  20. baconsama25

    baconsama25 Cosmic Narwhal

    My game is either freezing ( when catching a new fish) or quitting and showing an error message about player.config (when I catch bugs or make a dish for the first time) :

    [Error] Exception caught loading asset: /player.config:collectableUnlock, (AssetException) Could not read JSON asset /player.config:collectableUnlock

    My saves was made in 1.0.0, but it has a ton of mods (including that I unninstalled FU, but I never came to use it at the active saves, there's just one abandoned save that has used it through it's gameplay), it has started since today, but I don't know if it's due to a castlevania mod update or because I didn't try to catch/cook earlier :p ( I'll ask to the author if he overwrote that file, though)

Share This Page