1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Tutorial Fixing Lost/Corrupted Universes and Player Files

Discussion in 'Starbound Support' started by Trinosaur, Jul 28, 2016.

  1. nomaki

    nomaki Space Hobo

    You.. you can grow crops on the ship?!
    Last edited: Aug 5, 2016
  2. Eralia

    Eralia Phantasmal Quasar

    Yes, though i removed them and moth traps.
  3. Koh

    Koh Scruffy Nerf-Herder

    Very needed thread, sir! I was about to make a similar thread until I found this.
    My house had a power shortage, my PC was shut down, and my LAN Server Universe got wiped out. This is so frustrating! I mean, here you're trying to guide players with the same problem in order to "fix" it manually somehow. But I have a different problem: My homeworld is a World with Lush and 4000 Sectors, it's basically a similar but bigger planet than the starting planet. I had hours invested there (plus hours investing exploring in other planets with 3 more players), plus all my seeds, rare decorations and the other player's items are there in storages. My character is safe, but my Universe got reset completely. I have the .fail files but that world isn't Bookmarked for Quests. Is a complete and separate planet. D:

    There's now way this the devs. haven't noticed this threat for us the players. I've seen reports since 2014 addressing this bug while googling it. It's unfair that must do a manual back up every 30 min - 1 hours, instead of being this game giving us a proper assistance to it. I mean, a 2 - 3 years old bug is still in the game and the devs. haven't done anything to fix it? Worse yet, they released the 1.0 version with it! :zombie:
    Last edited: Aug 5, 2016
    Trinosaur likes this.
  4. sjr56x

    sjr56x Yeah, You!

    Speaking of which how do you do the manual backup? I am worried I am going to screw it up
  5. Koh

    Koh Scruffy Nerf-Herder

    Hmm... These are the steps to follow:

    • You need to find the "storage" folder in the Starbound folder. Normally this is the Default Location:

    C:\Program Files (x86)\Steam\steamapps\common\Starbound\storage

    Alternatively you can do this:

    STEP 1: Right click on Starbound and select "Properties".

    STEP 2: Go to LOCAL FILES tab and click on BROWSE LOCAL FILES, it will take you to the Starbound folder. There you will see the "storage" folder.
    • There you will see two folders called "player" and "universe", copy both of them in another place (in Documents folder, for example) every 30 min - 1 hrs playtime. Replace those files with the ones you've backed up if this problem occurs.

    Trinosaur likes this.
  6. Trinosaur

    Trinosaur Big Damn Hero

    Missions themselves aren't really affected. It's really more that the game resets your outpost, thinking you have no mission progress. Redoing the missions via S.A.I.L. seems to trick it back into thinking it's all fine? It's very odd.

    And as far as crops go, I guess you just have to replant them. And Fluffalo seem to fix themselves if you just wait.
  7. Timoth

    Timoth Yeah, You!

    This has happened to me as well. Even after following the steps above, I am unable to teleport to the ark or the outpost. Is there a way to force it through command line?
  8. Trinosaur

    Trinosaur Big Damn Hero

    The very first message of this thread contains a spoiler drop-down with instructions on how to do this through admin controls within the game. Unless you are talking about PC command line...? I don't believe that's possible.
  9. Trinosaur

    Trinosaur Big Damn Hero

    Chances are pretty good that your planet is still there. It's just a matter of finding it again. If you have no active quests to backtrack and find it that way, you are going to have to sift through your universe files to find it. This link ought to help you.
  10. bluntaxe

    bluntaxe Void-Bound Voyager

    So I've been re-playing since 1.0. I haven't played in over a year and don't recall having this issue before. But the game crashed on me today *(when I clicked Quit of all times). I now have lost all of my planets. I tried the suggestion for looking at the files and putting in the coordinates. However there is no star at the given coordinates when I type them in.

    Other issues I experienced prior to the crash.
    1. NPC airlock door closed on me and I was unable to re-open the door or move. Only way I was able to escape was to dash. If I didn't have the dash tech I think I would have been stuck forever.
    2. Quest NPC spawned where I couldn't get. The NPC appeared to be behind a wall/roof of a building (mission arrow was there) but I couldn't get there because the building was protected from being destroyed.
  11. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    When looking for the coords of the planets are you looking in giraffe_storage or storage? The coords of giraffe_storage will not work.

    ~ Iris ~
  12. bluntaxe

    bluntaxe Void-Bound Voyager

    ah yes.. That first post needs to be updated. Thx
    Trinosaur likes this.
  13. Trinosaur

    Trinosaur Big Damn Hero

    My apologies. I was copying that old information for ease of access but forgot to make it known to look in regular storage, not giraffe_storage. Sorry about that! The post has been updated accordingly.
  14. gchristopher

    gchristopher Subatomic Cosmonaut

    I've observed the universe become corrupted on the PC crashing also.

    For recovering bookmarks, Iris Blanche posted the following way to modify the .player file to update the universe UID to the newly generated one:

    That worked to recover all of the waypoints, without the manual effort of searching through the universe storage directory.

    Other symptoms of a crashed universe I see are:
    - Crops stop growing unless replanted.
    - Fluffalo/Mooshi/chickens stop producing forever. (Unless 30-40 hours of IRL gameplay isn't enough, they're never recovering.
    - Tenants stop paying rent/giving quests unless replaced.
  15. Trinosaur

    Trinosaur Big Damn Hero

    Helpful! But I'm not familiar with json so I think I'd be a bit lost here. If there's a guide somewhere on how to do it, I'd happily add it to my main post. :)

    I will be sure to edit the bit about the broken fluffalo etc. though!
  16. gchristopher

    gchristopher Subatomic Cosmonaut

    Okay, here's a quick, but complete writeup on how to fix your player.dat file if the universe has become corrupt. (Just expanding the explanations provided by Trinosaur and Iris Blanche.)

    To fix a player.dat file, you have to be able to run programs from the command line, understand directory structures, and use a text editor.

    Recovering Teleporter Locations After a Universe has Become Corrupted:

    Step 1: Understanding the problem.

    The way Starbound saves progress is very, very fragile. If something interrupts it, like a PC crash or power outage, it might lose data. If the universe data is lost this way, it will throw away the old data and create a new file for the universe, losing important information. This new universe will have a new "UUID," a number that uniquely identifies the universe. All of the planet data is still there, though, so the universe can mostly be fixed.

    If your player file is intact, but a universe that you play in has been re-generated, then your player file will have all of its bookmarks (flags and teleporters) associated with the UUID for the old universe. When you log into the new universe, the UUID has changed and the bookmarks in your player file won't match the new universe UUID, so you will see no stored teleporter locations.

    Step 2: Make a backup.

    Back up the entire contents of the storage/ directory under Starbound, so you can replace anything you accidentally break.

    Step 3: Fixing the problem.

    Using tools provided with Starbound, you can unpack your .player file from its binary format into a human-friendly text format called JSON. Then, using a text editor, you can find where the UUID for the bookmarks is stored, and update it to the UUID for the

    Dumping Files to JSON:

    In the win32 directory under Starbound is dump_versioned_json.exe. (It'll probably be in a different directory if you're not using Windows.)

    You'll need to run dump_versioned_json.exe from the command line. It takes two arguments: the first is a binary .dat file to dump, and the second is the file name to write.

    You should export both the .dat file for the universe, and for the .player file to fix. Here's how it might look. (The filename for the player will be different. Steam purchasers, for example, will have different directories.)

    D:\Games\GOG Games\Starbound\win32>dump_versioned_json.exe "D:\Games\GOG Games\Starbound\storage\universe\universe.dat" "D:\Games\GOG Games\Starbound\universe.json"
    D:\Games\GOG Games\Starbound\win32>dump_versioned_json.exe "D:\Games\GOG Games\Starbound\storage\player\9ca17817bd04c5b382b28ebd162c7ccd.player" "D:\Games\GOG Games\Starbound\player.json"

    Fixing the UUID :

    Open both .json files you just created with a text editor.

    In the universe.json file, you'll see a line like:

        "uuid" : "8f4a5ef782f9e679221d032067bbbac2",
    What you want is the 32 character value inside the quotes. That's the new UUID for the universe.

    Search the player.json file for the word "bookmarks". You'll find at least one line like this:

        "bookmarks" : [["d1f02b748cf6537014abbd0eabc4284f", [{
    I think if that player has played on different servers, you might have a few lines like it. Right after that line will be a bunch of entries with teleport locations. You should recognize one group of them as the ones you've lost.

    See how the two 32 character values are different from the player and universe files? That's why the game can't display your teleport locations correctly. The UUIDs are different.

    Fix the problem by copying the UUID from the universe file into the value in the player file.

    Turn the player JSON file back into a binary:

    There is another tool: make_versioned_json.exe to turn your fixed JSON file back into a .player file.

    Use it just like the dump tool, but with the .json file as the first argument, and the .player file as the second.

    D:\Games\GOG Games\Starbound\win32>dump_versioned_json.exe "D:\Games\GOG Games\Starbound\player.json" "D:\Games\GOG Games\Starbound\storage\player\9ca17817bd04c5b382b28ebd162c7ccd.player" 
    Step 4: Test it out!

    If this was done correctly, when you restart the game and start playing with that player and universe, your teleport locations should be recovered!

    If it didn't work, the best thing to do would be to restore the contents of your storage/ directory from the backup you made earlier and try again. If it gets frustrating, sit down with someone else and walk through the procedure together to try and figure out what might have gone wrong.
    Trinosaur and Iris Blanche like this.
  17. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    The topic should have the tutorial prefix set :nurunaughty: Also it'd be nice to see this one as a sticky. Maybe you can ask for it? :nurunaughty:

    ~ Iris ~

    Edit because i don't want to doublepost:
    I did a force crash to experiment with the .fail files. These files are actual a backup of the broken planets so planets can also be restored by renaming them to their "old" name. As for the universe.dat (universe settings): you should follow the steps above.

    ~ Iris ~
    Last edited: Aug 8, 2016
  18. Trinosaur

    Trinosaur Big Damn Hero

    haha at this point, yeah! It started out as a general bu topic but I then wanted to start chronicling all the issues tied in with it. I'm glad people are finding it so helpful though. That's what I really wanted! How would I go about requesting it to be made sticky?
  19. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    I think asking one of the mods per pn could help but if they will do it or not...i don't know x)

    ~ Iris ~
  20. Chad Klatz

    Chad Klatz Void-Bound Voyager

    hello people i can't teleport to my outpost ( the game keeps send me back to the ship)
    is there a way to fix this? i also deleted my universe folder reach a ark/outpost teleporter and nothing
    this bug affects new characters.
    And neither theese commands work too

    /warp instanceworld":"outpost
    Last edited: Aug 9, 2016

Share This Page