1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Tutorial Fixing Lost/Corrupted Universes and Player Files

Discussion in 'Starbound Support' started by Trinosaur, Jul 28, 2016.

  1. Trinosaur

    Trinosaur Big Damn Hero

    If you experience character/world loss, the most helpful thing you can do is immediately send your starbound.log file and failed player/universe saves to contact@chucklefish.org so that staff can look into what's causing the problem. It's best not to mess around with trying to restore the files first.

    Because of the way the universe backup/save system works, if for any reason your game crashes/closes/computer crashes/power goes out or the game becomes interrupted during save information overwrite: your universe file becomes corrupted and turns into a fail file. When you log back into Starbound, you are transported to a random gentle star and your outpost and main missions are completely reset. Sometimes characters also get deleted during this type of unexpected crash, but fear not, there are ways of recovering them manually. You'll need to follow some of the steps below to get things working again.

    Please be sure to back up your storage folder before attempting anything that might alter your files!

    Hey guys,

    I wrote a repair script back in the day but it was ridiculously outdated and of course wouldn't work with Starbound 1.0. This morning I took some time to update it and while it's not as reliable as the old one I have successfully made a 100% recovery of a Starbound 1.0 failed world.

    I'm running a startup now so I don't have much time to do these things, hence there is no UI to accommodate this, but if someone wants to make it more user friendly that would be greatly appreciated!

    WARNING: Always keep backups for files as this script is not guaranteed to work!

    Here's the repo: https://github.com/blixt/py-starbound

    Quick guide for people on Mac/Linux who can use the command line:

    git clone https://github.com/blixt/py-starbound
    cd py-starbound
    ./repair.py 1234567_8901234_-9876543_6_3.world.1234567890.fail
    # output from script...
    On Windows you should be able to do the equivalent (but use "C:\Python27\python.exe repair.py" instead of "./repair.py"), but you'd have to make sure Git and Python are installed.

    Once the file ending with ".repaired" is written to disk, you can remove everything after ".world" in the filename and put it in your Starbound/storage/universe directory. Keep a backup of the old files though.

    Okay, here's a quick, but complete writeup on how to fix your player.dat file if the universe has become corrupt. (Just expanding the explanations provided by Trinosaur and Iris Blanche.)

    To fix a player.dat file, you have to be able to run programs from the command line, understand directory structures, and use a text editor.

    Recovering Teleporter Locations After a Universe has Become Corrupted:

    Step 1: Understanding the problem.

    The way Starbound saves progress is very, very fragile. If something interrupts it, like a PC crash or power outage, it might lose data. If the universe data is lost this way, it will throw away the old data and create a new file for the universe, losing important information. This new universe will have a new "UUID," a number that uniquely identifies the universe. All of the planet data is still there, though, so the universe can mostly be fixed.

    If your player file is intact, but a universe that you play in has been re-generated, then your player file will have all of its bookmarks (flags and teleporters) associated with the UUID for the old universe. When you log into the new universe, the UUID has changed and the bookmarks in your player file won't match the new universe UUID, so you will see no stored teleporter locations.

    Step 2: Make a backup.

    Back up the entire contents of the storage/ directory under Starbound, so you can replace anything you accidentally break.

    Step 3: Fixing the problem.

    Using tools provided with Starbound, you can unpack your .player file from its binary format into a human-friendly text format called JSON. Then, using a text editor, you can find where the UUID for the bookmarks is stored, and update it to the UUID for the

    Dumping Files to JSON:

    Alright. Just ran into this issue. I'm a JavaScript developer. We're dealing with JSON (JavaScript Object Notation) and command lines, which all devs deal with.

    Quick gotcha on the instructions (which are much appreciated):

    You're telling people to use the dump_versioned_json.exe command in the part about using the make method. Those who actually know how to copy/paste in the win command line (see below if you don't) are going to have a hard time with that.

    To help reduce command line pain:

    * You can actually get autocomplete of directories in the win command line as you type. Win 10 is more forgiving but even in older win versions you could hit tab after 3-4 characters and as long as you were using derp-windows "\" instead of the less moronic "/" for directory dividers and the exact capitalization of dir-names, it would autocomplete names for a given directory if it could. Rinse repeat and you can work through 6-16 directories in no-time. Linux's is so much better. I still do win for the games.

    * "..\" means back a directory from the one you're in now. Here's my shortened make command after having navigated via "CD <directory name>" the the win32 directory:

    make_versioned_json.exe ..\player.json ..\storage\player\67bad09fa44c63570cb0974391cf9004.player

    * Oh and of course to copy/paste, in win10 at least, right click on the top of the window for the command line for a drop down. IIRC you could r-click anywhere on the window on older win versions. Then select "edit" and "paste" to paste whatever you've ctrl-Ved to your clipboard outside of the command line.

    * Up arrow goes back to previous commands you entered on the command line. Hit enter to re-do those. You can up-arrow multiple times. Helpful for re-making files after undoing bad edits.

    Now, JSON (most of you won't care much about this unless you're unfamiliar and actually want to sort these files out)

    In JS, this is an object or labeled list (stuff referenced via label):


    The basic formatting is:

    "<label for another value>":<value2>

    This is an array or list with no labels (stuff held together based on the order it's in - great for sorting):


    Formatting is simpler:


    In JSON, arrays tend to be lists of objects you'd want to sort based on their properties.

    Now with stuff inside them and JSON-valid:

    "myNotEmptyArray":[1, "cat", {"propertyName":"whatevs"} ]

    If I were writing bookmarks in JS you wouldn't see : [ "<UUID>", [<array of bookmark objects>] ]

    Because that's two unlike things in a generic list. You'd have to write in a rule as you walk through it with code that tells you even items are values, odd items are the UUID they're associated with. I'm not knocking the Starbound devs. It might make a lot of sense to think about it that way if you're dealing with C or god-knows-what regularly, or want to convert from something a little more rigid..

    But in my case you'd see:

    "bookmarks" : {
    "<UUID>": [<array of bookmark objects>],
    "<UUID2>" : [<another perhaps empty array of bookmark objects because power-outage and something quit>]

    But what I had was:

    "bookmarks":[ <universe UUID1>, <bookmarks data1>, <universe UUID2 that agrees with universe.json>, [<nothing here>] ]

    So in my case I'm actually pretty sure my real problem was that I was actually writing the player data to the wrong directory for the first umpteen attempts but solved the problem differently with a different solution by accident anyway.

    I saw this:

    <universe ID not in universe.json>,
    <all my bookmarks>,
    <universe ID from my bookmarks>.
    [] <-- no bookmarks in that array. Just nothing

    So I tried dumping all the bookmarks data into the empty array in the text-file and re-making.

    It worked.

    So try the UUID first but just in case you're having no luck, I did the opposite. I pasted the contents of the entire bookmarks array that was full into the empty array following the UUID that agreed with my universe.json. That works too and might work best if you've got a lot of server play behind you but just want to get your local data back.

    In the win32 directory under Starbound is dump_versioned_json.exe. (It'll probably be in a different directory if you're not using Windows.)

    You'll need to run dump_versioned_json.exe from the command line. It takes two arguments: the first is a binary .dat file to dump, and the second is the file name to write.

    You should export both the .dat file for the universe, and for the .player file to fix. Here's how it might look. (The filename for the player will be different. Steam purchasers, for example, will have different directories.)

    D:\Games\GOG Games\Starbound\win32>dump_versioned_json.exe "D:\Games\GOG Games\Starbound\storage\universe\universe.dat" "D:\Games\GOG Games\Starbound\universe.json"
    D:\Games\GOG Games\Starbound\win32>dump_versioned_json.exe "D:\Games\GOG Games\Starbound\storage\player\9ca17817bd04c5b382b28ebd162c7ccd.player" "D:\Games\GOG Games\Starbound\player.json"

    Fixing the UUID :

    Open both .json files you just created with a text editor.

    In the universe.json file, you'll see a line like:

        "uuid" : "8f4a5ef782f9e679221d032067bbbac2",
    What you want is the 32 character value inside the quotes. That's the new UUID for the universe.

    Search the player.json file for the word "bookmarks". You'll find at least one line like this:

        "bookmarks" : [["d1f02b748cf6537014abbd0eabc4284f", [{
    I think if that player has played on different servers, you might have a few lines like it. Right after that line will be a bunch of entries with teleport locations. You should recognize one group of them as the ones you've lost.

    See how the two 32 character values are different from the player and universe files? That's why the game can't display your teleport locations correctly. The UUIDs are different.

    Fix the problem by copying the UUID from the universe file into the value in the player file.

    Turn the player JSON file back into a binary:

    There is another tool: make_versioned_json.exe to turn your fixed JSON file back into a .player file.

    Use it just like the dump tool, but with the .json file as the first argument, and the .player file as the second.

    D:\Games\GOG Games\Starbound\win32>dump_versioned_json.exe "D:\Games\GOG Games\Starbound\player.json" "D:\Games\GOG Games\Starbound\storage\player\9ca17817bd04c5b382b28ebd162c7ccd.player" 
    Step 4: Test it out!

    If this was done correctly, when you restart the game and start playing with that player and universe, your teleport locations should be recovered!

    If it didn't work, the best thing to do would be to restore the contents of your storage/ directory from the backup you made earlier and try again. If it gets frustrating, sit down with someone else and walk through the procedure together to try and figure out what might have gone wrong.

    Edit: Alternative tutorial can be found here

    The following is taken from this reddit post

    Computer crash, power outage, or otherwise unexpected shutdown of your computer in the middle of playing Starbound? Character not showing up in your player menu after such an event? In cases like this, you might have a...

    Corrupt character!
    Oh no! That's unfortunate! What do I do? Is there any way to restore it?

    Fear not, important individual! There are indeed steps you can take to restore your beautiful character, and their ship, from an automatic backup! Just follow these steps carefully, and you'll be chasing Poptops and catching Fawnflies in no-time!

    Step 1: Find your player folder:
    • Right-click "Starbound" in your Steam library (Or "Starbound - Unstable" if you're using Unstable or Nightly)
    • Click "properties"
    • Click "local files"
    • Click "browse local files"
    • Go into "storage". Your "player" folder should be there.

    Step 2: Back up your player folder.
    This will create a backup of all files inside your player folder, just in case something goes wrong in step 3.

    • Copy the folder
    • Paste the folder elsewhere (For example: On your desktop.)

    Step 3: Restore from a backup:
    This assumes your corrupt character was the most recent one you've accessed. If that is not the case, and you've used one or two characters after that, then the files you want will be one or two jumbles further down.

    1. Sort by date accessed, and the most recent one should be the first one. These files will be jumbles of letters and numbers. (Which I will refer to as [jumble] from here on.)

      For example:





    2. Rename [jumble].player.bak1 and [jumble].shipworld.bak1 to [jumble].player and [jumble].shipworld
    3. Delete [jumble].player and [jumble].shipworld

      Note: Do not actually change the jumble of letters and numbers, to [jumble]. Leave them alone, and only change the stuff after the dot.

    This didn't work! My character still doesn't show up!

    Repeat the second-last part of step 3, and then the last part with [jumble].player.bak2 and [jumble].shipworld.bak2

    If that still doesn't work, try with [jumble].player.bak3 and [jumble].shipworld.bak3

    EDIT: This is an old guide but it's still relevant. Please look in your regular storage file, not giraffe_storage, for game files.

    EDIT #2: The original point of this guide is to help you locate planets you've lost due to erased navigation bookmarks. You can plug in the coordinates found in WORLD files to visit that planet. Once you beam down to the planet you'll be able to determine if it's familiar or not. From there, you can hunt around to find any flags you may have left there before. This is how you recreate teleporter bookmarks. You might have to try a lot of planets before you find the one you are looking for. Tedious, but doable.

    April 23rd – How to retrieve your home planet!
    mollygos posted on April 23rd, 2015


    As you may have read in our patch notes, the newest stable update saw the ‘home planet’ feature replaced by planet bookmarks and direct teleporters. This meant that existing characters would lose track of their home planets, as they’d no longer have the ‘home’ marker.

    But never fear! Ideally you’d have written down your planet’s coordinates, but either way your home planet still exists and is intact and you can find it using the following method. :)

    Elite Space Hobo from our community beat us to posting a guide, which you can find here.


    • Find your universe folder. Typically, it should be located in SteamLibrary\SteamApps\common\Starbound\storage\universe.


    • Right click -> sort files by date last modified. If your planet’s been heavily customized/built upon, it should be one of the larger files. If you visit it frequently, it should also be one of the most recent.
    • “What do all these numbers mean?!” World files with names like: 270623995_279217314_-213404188_12.world mean that you’ve visited a planet with the coordinates X -270623995 Y -279217314.

    • Put the coordinates into your ship’s computer and… hopefully, voila! Planet located! If not, try some of the other planets in your universe folder.
    • Now that you’ve found your home planet, don’t forget to create a bookmark. :)
    I hope this proves helpful! We’ll be posting our daily progress update later, as usual. See you then! <3

    For anyone else who finds their way here for the same issue (Outpost progress being reset), paraphrased from this Reddit post are the commands you can type into the chat window to restore your progress:

    First, you will need to make yourself an Admin

    WARNING! This also unlocks absolutely everything from crafting, tech upgrades etc; so for the sake of not ruining all the fun for yourself, try to avoid doing anything whilst Admin mode is enabled!

    If you are playing single player, you can just type:

    to grant yourself Admin rights in your universe

    If you are hosting a multiplayer server, see this update log to add yourself as an Admin to your universe.

    Once you have admin rights, type in one of the following commands based on your prior progress in the story:

    Have you done the scan quest?

    /setuniverseflag outpost_mission1

    Have you found the Floran artifact?

    /setuniverseflag outpost_mission2

    Have you found the Hylotl artifact?

    /setuniverseflag outpost_mission3

    Have you found the Avian artifact?

    /setuniverseflag outpost_mission4

    Have you found the Apex artifact?

    /setuniverseflag outpost_mission5

    Have you found the Glitch artifact?

    /setuniverseflag outpost_mission6

    Dash tech challenge:

    /setuniverseflag outpost_techscientist1
    Distortionball tech challenge:

    /setuniverseflag outpost_techscientist2
    Killed Dreadwing:

    /setuniverseflag outpost_beakeasy
    Ursa Miner:

    /setuniverseflag outpost_ursa_miner

    Once you have made sure your Outpost is back to how it was, just type

    or remove yourself from the server's admin list to disable Admin mode and go back to bounding across the stars!

    If you triggered the final cutscene to enter the ruin, follow this method to re-unlock it:

    Video Tutorial by Me:

    Alternatively, you can re-beat the missions through S.A.I.L. and your outpost will go back to normal. Your universe hasn't actually gone anywhere. It's just corrupted and forcibly resets your current planet and completed missions. All the planets you've been to still exist, and you CAN find them using the linked method above... it's just a pain in the butt because the game doesn't do this for you. All recovery options are manual. This is why I suggest doing your own back-ups (copy both player and universe folders) so that you can restore the information as simply as copying and pasting.

    Other symptoms include:
    - Crops stop growing unless replanted.
    - Fluffalo/Mooshi/chickens stop producing (Some people have reported that even after 30 hours of gameplay they have not recovered).
    - Tenants stop paying rent/giving quests unless replaced.

    Active side missions can also be used to backtrack to whatever planet you were on previously.

    In your quest menu, click on the quest you want to backtrack to a planet you were on before your bookmarks were wiped. Track the quest like so:


    Then on your ship, go into the navigator and click where it says "show quest location"


    From here, you can re-bookmark or travel to the planet as needed. The coordinates are all there and this saves you the trouble of digging through your universe folder for them.

    But having to redo all main missions and re-unlock the outpost is a giant pain. There has GOT to be a better way for the game to overwrite universe files to prevent this from happening. Perhaps if a .fail file is recognized, it could automatically restore it to the last working universe file instead of resetting? This is something staff should look into.

    Example of a .fail file:


    [00:13:14.015] [Warn] Error loading player storage metadata file, resetting: (JsonParsingException) Error parsing json: expected JSON object or array at top level at 1:1
    [00:13:22.098] [Info] UniverseServer: Acquiring universe lock file
    [00:13:22.102] [Info] UniverseServer: Loading settings
    [00:13:22.138] [Error] UniverseServer: Could not load universe settings file, loading defaults (IOException) Wrong magic bytes at start of versioned json file, expected 'SBVJ01'

    I've been seeing this issue posted a lot, myself included. SO I figured I'd write some kind of official post compiling all instances I've found of it. There are some variations to each but the main problem is the same.

    1. http://community.playstarbound.com/threads/character-progress-reset.119187/
    2. http://community.playstarbound.com/threads/ship-save-corruption.119495/
    3. http://community.playstarbound.com/threads/bsod-and-then-lost-all-my-bookmarks.118984/
    4. http://community.playstarbound.com/...ne-planet-launched-on-a-different-one.119788/
    5. http://community.playstarbound.com/...s-suddenly-closed-after-latest-update.119837/
    6. http://community.playstarbound.com/...-character-and-ship-have-been-deleted.119766/
    7. http://community.playstarbound.com/threads/lost-bookmarks-and-quest-progress.119912/
    8. http://community.playstarbound.com/threads/just-lost-a-bunch-of-progress.118660/#post-2966079
    9. http://community.playstarbound.com/threads/bsod-causing-planet-fails.119356/
    10. http://community.playstarbound.com/threads/world-completely-reset.118908/
    11. http://community.playstarbound.com/threads/power-went-out-while-in-game-universe-lost.119004/
    12. http://community.playstarbound.com/threads/corrupted-world-and-main-quest-progress.118937/
    13. http://community.playstarbound.com/threads/player-information-gone.118743/#post-2973997
    14. http://community.playstarbound.com/threads/character-deleted.120570/
    15. http://community.playstarbound.com/threads/outpost-is-broken.120679/
    16. http://community.playstarbound.com/threads/bookmarks-and-teleportlocations-missing-bug.120698/
    17. http://community.playstarbound.com/...al-bookmarks-are-gone-thanks-to-1-0-4.120974/
    18. http://community.playstarbound.com/threads/lost-a-charcter-after-a-crash.120965/
    19. http://community.playstarbound.com/threads/pc-crashed-and-now-my-save-is-gone.121295/
    20. http://community.playstarbound.com/threads/com-crash-ruined-game.121586/
    21. http://community.playstarbound.com/threads/computer-crashed-character-deleted.121719/
    22. http://community.playstarbound.com/...ower-loss-players-lost-teleport-lists.121752/
    23. http://community.playstarbound.com/threads/character-deleted.121722/
    24. http://community.playstarbound.com/threads/need-help-character-disapeared.121922/
    25. http://community.playstarbound.com/threads/character-save-data-is-gone.121979/
    26. http://community.playstarbound.com/threads/power-outage-wrecked-game.121968/
    27. http://community.playstarbound.com/threads/bookmarks-disappeared.122036/
    28. http://community.playstarbound.com/threads/all-data-gone-after-blackout-t_t.122538/
    29. http://community.playstarbound.com/...e-and-ship-moving-without-instruction.122599/

    If you have this problem, please write about it here to keep this post updated. The more information we can provide staff, the more likely it is to be addressed.

    Edit #1: I forgot to mention, the best way to prevent this issue from happening if you want to keep playing is to back up your universe files regularly. That way you can replace the .fail file with a file that actually still works. Better than losing progress entirely.

    These are the steps to follow:

    • You need to find the "storage" folder in the Starbound folder. Normally this is the Default Location:

    C:\Program Files (x86)\Steam\steamapps\common\Starbound\storage

    Alternatively you can do this:

    STEP 1: Right click on Starbound and select "Properties".

    STEP 2: Go to LOCAL FILES tab and click on BROWSE LOCAL FILES, it will take you to the Starbound folder. There you will see the "storage" folder.

    • There you will see two folders called "player" and "universe", copy both of them in another place (in Documents folder, for example) every 30 min - 1 hrs playtime. Replace those files with the ones you've backed up if this problem occurs.

    Edit #2: Some variations of this problem include "missing" player information. Players will log into starbound to see that their character is missing from the player list. There is a thread here that walks you through how to recover lost characters: http://community.playstarbound.com/threads/corrupted-lost-character-and-how-to-recover.104376/

    Edit #3: I'm going to start including lost characters in this as well, since I think the two issues are tied. They both seem to be related to crashes/BSOD/Quit during save information overwrite.

    Edit #4: Here's a better explanation by Iris Blanche on what the cause of this issue is:

    Edit#5: Added a video Tutorial! Check it out above!

    Last edited: Sep 8, 2016
  2. Pentane Pictor

    Pentane Pictor Intergalactic Tourist

    Is the .fail extension a new thing with the previous (two?) patches? Because I hadn't noticed this in my files before. Also, thanks for linking to my thread. (2nd on the list there.) In terms of compiling information, I feel like this thread is vastly more succinct and useful than mine was - which, really, someone creating a thread like this was my hope from the start, so I have to thank you for making this.

    Also, I went on Twitter to check the message that somebody posted to the Starbound account regarding the variants of the backup failures, but the tweet seems to have dead-ended and it hasn't really been made clear how serious of an issue this is to the developers. (At least, as far as I know, they haven't acknowledged the existence of this issue.) It might be best to share this thread over on Twitter and give them another heads-up regarding that previous tweet.
  3. Inker

    Inker Void-Bound Voyager

    Here's hoping for a dev response leading to this issue being fixed!
  4. Trinosaur

    Trinosaur Big Damn Hero

    Thanks for the responses, guys. I'll see about alerting their twitter/emailing them later. It's hard to say what will be most effective in getting their attention (chances are they already know about it) but as long as we keep reporting the problems, something should get resolved eventually!
  5. Tirilka

    Tirilka Scruffy Nerf-Herder

    Frankly, this is disgusting.
    It also happens when you play with a friend, and he quits before you can press "Save and Quit".
  6. Trinosaur

    Trinosaur Big Damn Hero

    No response from staff yet. I'm still keeping an eye on this forum in case more player experiences like these pop up.
  7. Galactic Avatar

    Galactic Avatar Cosmic Narwhal

    So blarg...... I had a brief power outage like a few seconds and when I got back onto Starbound my character was still there (thank goodness for small favors), and I lost all my bookmarks, I
    m going to have to start saving the universe file once a day or something.

    Now I have to bactrack and try to restore my bookmards, and teleporters..... this should be fun. Hopefully my colony is still there. I'll get back to you guys if its not.
  8. Trinosaur

    Trinosaur Big Damn Hero

    Thanks for the reply. "glad" to know this is still an issue. I don't want this swept under the rug.
  9. FalconOSeven

    FalconOSeven Orbital Explorer

    I don't have anything to add to this other than I experienced the same thing that Galactic did yesterday. I backtracked to only my original planet and everything was the same as when I lost power, so I assume all my other worlds are intact as well. However, story and outpost progress was completely gone and having to do all that again is too tedious and makes me not even want to play now because it could happen again.
  10. Trinosaur

    Trinosaur Big Damn Hero

    I felt that way for a while, but in the end I realized I really wanted to keep playing. So I ended up doing manual backups of my universe and player files every couple of hours. That way if it does happen again, you can restore it no problem. I still wish I didn't have to do it, but at least this way I won't live in fear playing it.
  11. Malachai

    Malachai Scruffy Nerf-Herder

    This has happened to me twice so far (they're doing work on my building). Both at around durasteel-tier. Guess I won't be playing until either the work is finished, or a fix is put in place. Damned shame...
  12. Trinosaur

    Trinosaur Big Damn Hero

    Below is an old blog post by staff that is still applicable. If your bookmarks get lost due to this glitch, you can hunt around your universe folder to find the planets you've visited previously:


    As a reminder, your universe hasn't actually gone anywhere. It's just corrupted and forcibly resets your current planet and completed missions. All the planets you've been to still exist, and you CAN find them... it's just a pain in the butt because the game doesn't do this for you. All recovery options are manual. This is why I suggest doing your own back-ups so that you can restore the information as simply as copying and pasting.
    --- Post updated ---
    Found a great reply on another thread regarding this issue that saves you the trouble of having to redo all missions manually:

  13. barbariank

    barbariank Scruffy Nerf-Herder

    How come a bug like this is still present in the 1.0 version of the game, i'm playing on a dedicated server and everytime the server reboot i lose everything, it's clearly not playable as it is and is a terrible game breaking issue

    I hope it will be fixed soon enough, until then i'll keep modding but i don't like this kind of situation at all
  14. Trinosaur

    Trinosaur Big Damn Hero

    I don't like it either... I keep looking around to see where the staff email is to maybe bring this thread to their attention but I've had no luck.
  15. Pentane Pictor

    Pentane Pictor Intergalactic Tourist

    In defense to Chucklefish, I'm assuming they haven't looked into it due to an equally bad bug that is affecting dedicated multiplayer servers and causes crashes and bad performance. Which, considering people often need to pay for dedicated servers, that is quite the priority. The lack of response may just be from the fact that, in general, the developers seem to be buried in their code or inboxes and unable to send many tweets or blog posts. Even their casual replies often relate to bugs or misunderstandings.

    That said, I do wish they'd make the exception and pay attention enough to know that this is serious enough to make a quick heads-up about. I'm optimistic that they are aware of some form of this, personally, but I'm a chronic optimist.
  16. sjr56x

    sjr56x Yeah, You!

    Had this happen to me at durrasteal level, but now everytime I try to start a new game it keeps freezing and then the same thing happens!
  17. Trinosaur

    Trinosaur Big Damn Hero

    Oh yeah, I totally understand. They are a small team so not every issue can be addressed immediately. I just feel that this issue is big enough that they could at least give a little "We are aware" nod somewhere. Ah well... I'm optimistic it will get resolved so long as we keep this thread alive and I keep chronicling new threads regarding it.
  18. Eralia

    Eralia Phantasmal Quasar

    Should it be mentioned that for me, while my warp locations were lost and i was thrown onto a random lush planet and outpost was broken, the missions were fine? No artifact at the end, but for some reason, beating it still fixes Outpost. Outpost was easily fixable for me, because i just had to beat EMF and floran caverns, then it's all back. Looking at what other players have, I'm surprised I haven't got anything very severe.
    This bug is very bad anyway, especially for how common it is. There can be a possible workaround with making universe backups regularly, though it will eat a lot of memory easily, even when compressed, and planets with least filesize(that means barely any changes on it, and players barely explored it) removed.
  19. nomaki

    nomaki Space Hobo

    To add to this, following my Outpost progress being reset I noticed any crops and animals (chickens, cows etc) that you had on your colon(y/ies) at the time of the crash will essentially stop all production.

    To fix the crops, you just need to remove them and re-plant, but I can't figure a way to fix the livestock as you can't attack them or chuck Capture Balls at them, so I think they just remain bork'd.
    Last edited: Aug 5, 2016
  20. Eralia

    Eralia Phantasmal Quasar

    My crops and fluffalo on the ship got broken too, as well as moth traps. While i replanted these, the fluffalo just fixed itself after a while, a day or two, and still grows plant fibre. That's how you fix fluffalo and others, you just wait.

Share This Page