1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue [FIXED...?] Constant flickering in Fullscreen Mode

Discussion in 'Starbound Support' started by Zumobatly, Jul 26, 2016.

  1. Zumobatly

    Zumobatly Void-Bound Voyager

    EDIT 3: Issue fixed! The following procedure helped me to get rid of this problem, it might help you as well if you're suffering the same:

    I'll leave my original post here, in case someone needs to identify the problem, that, by the way, seems to be (probably) caused by the game's vSync.



    Edit 4: Starbound 1.3.3 came out and the issues with V-sync seem to have worsened... even if you use your Graphics Card's v-sync. It'd be nice to have an official fix addressing this problem.
     
    Last edited: Sep 13, 2016
  2. bearffalo

    bearffalo Subatomic Cosmonaut

    Ive had the same issue. Im on Laptop too.
     
  3. T756

    T756 Void-Bound Voyager

    Same issue also on a laptop
     
  4. Hamuelin

    Hamuelin Aquatic Astronaut

    It's definitley not a Laptop-only issue. I'm getting exactly what you're describing on my AMD Desktop. And, same as you, the only fixes i've found are playing in windowed or disabling v-sync. Both of which I'd rather not do. If I find a fix before it gets patched i'll post it here
     
  5. Zumobatly

    Zumobatly Void-Bound Voyager

    Hate to bump this but this is now in the ninth page and it seems that no one has been noticing us. I've seen similar posts and still no support on this matter from devs...
     
  6. jake_elvy

    jake_elvy Space Hobo

    Hey! So I was suffering through the same problem when I updated to 1.0. I was using windows 8, but changed to windows 10 yesterday. Problem was solved.
    So I'm pretty sure it's a software issue. So since you are already using windows ten i'd try windows and driver updates. Sorry i'm not much help, but that's all I can come up with.
     
  7. Zumobatly

    Zumobatly Void-Bound Voyager


    Interesting, I might give updating drivers a shot. Also don't worry, any guidance helps!

    Will update this post if it manages to fix the issue.


    Update: So I decided to check if my drivers were up to date with a Driver list utility, turns out that Windows hasn't been updating them for a long time for some reason... the Intel HD Graphics driver was almost one year old now! I updated the most that I could find, even the ones not directly related to graphics such as Realtek, but the issue is still there. I no longer know what else could be causing this... perhaps a program running in the background?
     
    Last edited: Jul 30, 2016
  8. Icenezz

    Icenezz Void-Bound Voyager

    Bumping this, also have the same issue. If I am playing, I can see the stars from the beginning screen appear in the flashing that is happening to me.

    I have an AMD Radeon HD 8570D / AMD A8-6600K APU
    64 Bit System
    8GB RAM
    Running it on this screen: ASUS VS228

    This issue only happens on MY screen. When I went to show it off on Skype to my friends, they didn't see it. Only I did.
     
  9. Zumobatly

    Zumobatly Void-Bound Voyager

    Bump.

    With 1.0.5 this issue even got worse. Why hasn't Chucklefish noticed this yet?
     
  10. Kulsius

    Kulsius Scruffy Nerf-Herder

    Disable Vsync in game, turn it on in video driver settings (like nVidia control panel) for starbound.exe
    Gives you Vsync and eliminates flicker.
     
    Zumobatly likes this.
  11. Stormchild

    Stormchild Master Chief

    I have the same problem when I play on my desktop who has an older AMD HD6970. I'll try the tip from Kulsius later. This is a bit annoying although not gamebreaking.
     
  12. Zumobatly

    Zumobatly Void-Bound Voyager

    Clever! Don't know why I never thought of this. Normally I had that option set as "defined by app", but toggling it on on the Graphics Control Panel worked like a charm. My game is even smoother now, I can't thank you enough!
     
  13. clubbavich

    clubbavich Space Hobo

    As of right now, using Radeon software version 16.8.2, disabling V-Sync in the game, and forcing it to be on in the AMD settings does NOT enable V-Sync. So, this fix didn't work for me. I hope that Chucklefish are looking into graphical glitches and performance issues while they are adding content.
     
  14. Kamika

    Kamika Void-Bound Voyager

    I have radeon 7970 and now i have the same problem. All solutions i could find are not helping :( It was all fine before last patch. Please help
     
  15. Silent_Mango

    Silent_Mango Space Spelunker

    PLEASE fix this!
     
  16. Sean649

    Sean649 Void-Bound Voyager

    GEEEEEE This game is f*ckin unplayable. Lag spike, screen tearing. FPS drop. What happened? UUUUUGGGGGGGGGGHHHHHHHH

    Got an almost high end PC!


    spec
    AMD FX8320 3.5Ghz
    8gb of ram
    HD Radeon 7950 3gb gdrr5
    Windows 10 64bit
     
  17. DeathQueen

    DeathQueen Void-Bound Voyager

    on ati graphics cards try activating triple buffering from ati Catalyst Controler, i also set vertical refresh to off (don't know if that helped)
     
  18. dbot

    dbot Space Spelunker

  19. Ranso

    Ranso Void-Bound Voyager

    I am having this trouble too. I tryed with the video card vysnc.. but nothing changed. It is unplayable :(

    Any other solution until now?
     

Share This Page