1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/
  2. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Closed [FIX] GraphicsException: Could not create the Direct3d device

Discussion in 'Support' started by denafox, Dec 5, 2013.

Thread Status:
Not open for further replies.
  1. RvLesh

    RvLesh Parsec Taste Tester

    This isn't a "fix," it is a workaround.

    If this resolves your issue and OpenGL mode doesn't work, it is likely that your video card simply isn't supported - it doesn't have the TnL caps needed to render the game.

    If you're using a notebook, try updating your video drivers directly from the maker of your video chipset (i.e. Intel instead of Dell, HP, etc).
     
  2. denafox

    denafox Subatomic Cosmonaut

    Wait.
     
  3. pulchy

    pulchy Void-Bound Voyager

    Uh are you saying wait for it to be fixed, or wait for the process to come up? Because on the v236 version, I see starbound.exe for a second in my Task Manager, and then it disapears.
     
  4. denafox

    denafox Subatomic Cosmonaut

    Hmm, I do not know how to fix it. Maybe it's because of RAM? Because it is necessary to run the 800MB, I noticed it. And if I had to load the system, then closes starbound
     
  5. denafox

    denafox Subatomic Cosmonaut

    Update the driver, this is the worst excuse.And yes, it does not crawl all the textures work fine, and hangs almost there. Just starbaund does not support inline graphics, and need to wait for a fix.
     
  6. denafox

    denafox Subatomic Cosmonaut

    I mean, just the fact that if you run into 3analizere, then the steam will not be shown, that you play.
     
  7. Sodaxi

    Sodaxi Space Hobo

    Can't devs just fix it?!
     
  8. RvLesh

    RvLesh Parsec Taste Tester

    If there is something to fix, sure.

    But the OP in this *specific* thread is using an application to trick the game into believing the adapter has a feature it categorically does not contain.

    Just like trying to use Diesel in a car that only runs on Unleaded, you can't use HW TnL if the drivers/GPU don't support it/report it properly.

    That's not to say there aren't solutions - the devs can remove the feature. But that's not necessarily in the best interest of the game or the playerbase as a whole.

    Instead, if your video card doesn't contain the features required by the game, the solution is to upgrade.
     
  9. denafox

    denafox Subatomic Cosmonaut

    Do not you understand that it supports this feature. The game does not see the built-in video card, do not understand? The game is all texture, as in the original. You behave too pessimistic. Developers said that optimize on slow computers, then optimized. And you have to believe them. And they Fixed and update system only excuse I like "homeless" and can not help. So no need to, once again upset person.
     
  10. pazfam

    pazfam Space Hobo

    FYI as mentioned previously the work around worked for me. Not sure why my Radeon 7900 4 gb machine would not be supported.
     
  11. RvLesh

    RvLesh Parsec Taste Tester

    What Catalyst driver version are you running?
     
  12. RvLesh

    RvLesh Parsec Taste Tester

    What's the exact model of your GPU?
     
  13. KethuDar

    KethuDar Tentacle Wrangler

    Mh, still doesnt wor for me... worked before like a charm, but after a patch last week, it doesnt. As i said in another thread: The launcher (or steam, then the launcher) starts instead the game.
     
  14. RvLesh

    RvLesh Parsec Taste Tester

    Same question to you... what model GPU and what driver version?
     
  15. KethuDar

    KethuDar Tentacle Wrangler

    That doesnt matter... i'm playing Starbound on an older laptop, and the card doesnt support TnL. As i said, it worked very well. ;)
    I think they changed something in the starbound.exe, that makes it impossible to start the game directly via it.
     
    Last edited: Dec 16, 2013
    RvLesh likes this.
  16. denafox

    denafox Subatomic Cosmonaut

    I do not know why you have so. But I have everything working fine. Try to turn off steam, or run the launcher, and then run in 3danalizere starbound.exe
     
  17. pazfam

    pazfam Space Hobo

    The latest version. Can't get on PC right now to check but have tried with last 3 versions and just reinstalled the latest.

    I just checked 13.25.
     
    Last edited: Dec 16, 2013
  18. krakk

    krakk Space Hobo

    This fix works great! but steam just broke it.

    Up until today I could run starbound on my HP4400 laptop and its puny Intel GMA 350 integrated graphics card. Now I cant get it to launch because the executable no longer starts the game, but launches the launcher instead. This throws off the graphics driver fix. It used to be that I told 3d analyser which program to run and how to handle the graphics card without crashing too often, and it launched the game in its simulated whatever - but now it just runs the launcher in its simulated whatever, and the launcher creates another process outside of the 3danalyser's influence which crashes.

    The problem is a change in the launch process diverting 3danalysers influence to the launcher itself. Is there a way to launch starbound's executable from 3danalyser again?
    dxdiag attached.
    screenshot of game not running attached.
     

    Attached Files:

  19. denafox

    denafox Subatomic Cosmonaut

    There is one way, but I do not know him. Because I use it so far and everything is fine. You just run it from win32?
     
  20. Bryancf

    Bryancf Scruffy Nerf-Herder

    I have the same problem as krakk.. Played the game with 3D analyze yesterday just fine, but today when I tried to open it again the graphics exception error appeared again.. D:
     
Thread Status:
Not open for further replies.

Share This Page