1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Fatal Exception caught on Linux Server

Discussion in 'Starbound Support' started by Mercy/Genocide, Sep 24, 2021.

  1. Mercy/Genocide

    Mercy/Genocide Void-Bound Voyager

    So, basically, I have my Starbound server installed on Centos 7, worked pretty much okay except a few crashes here and then.
    The main problem is that Starbound itself doesn't want to start after I rebooted my server today.
    Here is the error:

    [Info] Server Version 1.4.4 (linux x86_64) Source ID: 8cbe6faf22282659828a194e06a08999f213769e Protocol: 747
    [Info] UniverseServer: Acquiring universe lock file
    [Info] UniverseServer: Loading settings
    [Info] Root: Shutting down Root
    [Error] Fatal Exception caught: std::exception: tinyformat: Not enough conversion specifiers in format string
    Caught at:
    ./starbound_server(_ZN4Star14fatalExceptionERKSt9exceptionb+0x42) [0x9d5ce2]
    ./starbound_server(main+0x76b) [0x8aca8b]
    /lib64/libc.so.6(__libc_start_main+0xf5) [0x7f578c001555]
    ./starbound_server(_start+0x2a) [0x8b701a]
    Emergency shutdown (core dumped)

    I'm really frustrated and I hope for your help. Thank you.
     
  2. Rattle189

    Rattle189 Void-Bound Voyager

    Hello,

    This reply is late but I have run across this problem too and I run a server in a specific configuration. I dual-boot Ubuntu and Windows in my computer. My server's mods folder is populated by symbolic links that link to the Windows partition (the symbolic links were also create there) and I have renamed my Windows partition. Because of this, the symbolic links found within my mods folder became invalid and I had to grab new copies of the symbolic links from the Windows partition.

    This may or may not be the solution to your problem, but the thing in common is that it could be related to your mods folder.

    I hope my answer helps you or anyone that may come across this problem.
     

Share This Page