1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Fatal Error: Illegal instruction encountered

Discussion in 'Starbound Support' started by R_C_A^, Jul 22, 2016.

  1. R_C_A^

    R_C_A^ Pangalactic Porcupine

    Welp, downloaded the update to try out 1.0 and i get that. Figures, so i completely uninstalled and deleted the starbound folder just to be sure and re-download, no luck with that, get the same error. Scoured the forums, but no joy, So here's the log...

    [17:50:16.625] [Info] Root: Preparing Root...
    [17:50:16.625] [Info] Root: Done preparing Root.
    [17:50:16.625] [Info] Client Version 1.0 (windows i386) Source Id fbfc7341813b83db61ef5a4b68360b0bf9c927b7 Protocol: 723
    [17:50:16.625] [Info] Root: Scanning for asset sources in directory '..\assets\'
    [17:50:17.234] [Info] Root: Scanning for asset sources in directory '..\mods\'
    [17:50:17.234] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [17:50:17.234] [Info] Root: Detected asset source named 'base' at '..\assets\packed.pak'
    [17:50:17.234] [Info] Root: Detected unnamed asset source at '..\assets\user'
    [17:50:17.234] [Info] Loading assets from: '..\assets\packed.pak'
    [17:50:18.125] [Info] Loading assets from: '..\assets\user'
    [17:50:20.718] [Info] Assets digest is 115bec93a7e9d013a1843b28df8c827e6cbf317e0bfe07ff9fe3200b3725bd48
    [17:50:20.718] [Info] Root: Loaded Assets in 4.09276 seconds
    [17:50:20.734] [Info] Application: Initializing SDL Video
    [17:50:20.828] [Info] Application: Initializing SDL Joystick
    [17:50:21.250] [Info] Application: Initializing SDL Sound
    [17:50:22.203] [Error] Fatal Error: Illegal instruction encountered (c000001d @ 3F001A3F)
    [0] 4ad4ea Star::captureStack
    [1] 4ad725 Star::fatalError
    [2] 4a9052 Star::SignalHandlerImpl::sehTrampoline
    [3] 3f001ff5
    [4] 3f006ebc
    [5] 3f01f1c6
    [6] 3f01f127
    [7] 3f01c52c
    [8] 3f01c6a4
    [9] 3f01c643
    [10] 7c90118a LdrInitializeThunk
    [11] 7c91b5d2 LdrFindResourceDirectory_U
    [12] 7c9162db RtlValidateUnicodeString
    [13] 7c91643d LdrLoadDll
    [14] 7c801bbd LoadLibraryExW
    [15] 2004242 OverlayHookD3D3
    [16] 3b4097ef SteamAPI_SetTryCatchCallbacks
    [17] 3b4092cc SteamAPI_SetTryCatchCallbacks
    [18] 3b409018 SteamAPI_SetTryCatchCallbacks
    [19] 3b409ad7 SteamAPI_Init
    [20] 9cf93a Star::SdlPlatform::SdlPlatform
    [21] 9d1be7 Star::runMainApplication
    [22] 41b59c WinMain
    [23] ae57e6 __scrt_common_main_seh
    [24] 7c81776f RegisterWaitForInputIdle

    So yea, hope someone can shine a light on this. Not the first time a starbound update didn't work for me the same day, oh well :p

    Edit* Source id made a smily, derp

    Edit 2*
    Ok, so i gave up for a bit tried everything ppl where saying to try... New sticky linked to Microsofts redistributel, uninstalled the one i had, installed the one linked. Via steam i get the exact same error, however NOW starbound launches through the EXE in the directory, YAYS!

    So it seems steam is having issues or something, although the first time i tried it gave me a access violation and crashed, 2nd time it worked just fine. Played through earth, landed on the starter world, got the 20 core frags and beamed back to my ship all without anymore access violations...

    Guess we'll see how it goes, will make another edit if anything changes.
    Last edited: Jul 24, 2016
    ErebusAmauro likes this.
  2. ErebusAmauro

    ErebusAmauro Astral Cartographer

Share This Page