RELEASED FarmAutomation.ItemCollector (Unofficial v1.1)

Discussion in 'Mods' started by maddy99, Oct 5, 2016.

  1. qjqqwerty

    qjqqwerty Intergalactic Tourist

    @Xuomi

    You can see that I put a chest and connect it to that path
    (
    / *
    Floor types:
    Wood Floor = 0;
    Stone Floor = 1;
    Weathered Floor = 2;
    Crystal Floor = 3;
    Straw Floor = 4;
    Gravel Path = 5;
    Wood Path = 6;
    Crystal Path = 7;
    Cobblestone Path = 8;
    Stepping Stone Path = 9;
    * /
    "FlooringsToConsiderConnectors": [0, 3, 7, 8, 9],
    ).
    It will automatically harvest all the other in addition to fruit to the chest.

    ps:
    The above content from the translation software!
    If: unreasonable statement / rude / misnomer / error description, etc.
    many thanks for your understanding
    Farm-be.png Farm-af.png
     

      Attached Files:

      Last edited: Sep 28, 2017
    • maddy99

      maddy99 Void-Bound Voyager


      Just to check, trees are only harvested on a new game day, are you waiting a day?
       
      • TwoSides

        TwoSides Void-Bound Voyager

        Is there a Version that works with Stardew 1.22+?

        I use "Automate" at the moment, but I like this this mod more.
         
          Last edited: Oct 6, 2017
        • Xuomi

          Xuomi Zero Gravity Genie

          @TwoSides Github link on the first post.
           
          • tenyson55

            tenyson55 Intergalactic Tourist

            is there any way to make the mod remove the wine before the iridium quality?
             
            • Joeltp85

              Joeltp85 Master Chief

              Is it possible this could be fixed to play nice with Custom Farm Type maps? I tried using Farm Automation in conjunction with zanderb14's Immersive Farm 2 map (which relies on Custom Farm Types) and got a bug where I couldn't get machines to process if they were placed in a shed, barn, or coop. Even a lone furnace that I placed items in myself and wasn't connected to any chest/farm automation system wouldn't work. The raw resource would go in but the machine would get stuck in the processing animation and wouldn't produce the finished product until the next game day after sleeping. If I then put another item in, the machine would get 'stuck' all over again.

              What's interesting is that even after removing the farm automation mod, the problem persisted. I reverted back to the vanilla backup files I had, reinstalling SMAPI, and started a brand new Custom Farm Types map and I still couldn't get the sheds, barns, and coops to work. And this was long AFTER removing Farm Automation. Very weird. The only thing that seems to fix it is doing a full uninstall/re-install of Stardew Valley. But as soon as I add the Farm Automation mod back in, the bug shows up again and won't go away unless I re-install the whole game.

              Again, this only happens in sheds, barns, or coops. Greenhouse works fine as well as every other place on the farm I tested. Vanilla maps also work just fine, whether Farm Automation is installed or not.

              Any idea as to why these mods might conflict and why the resulting bug is so darn difficult to get rid of? Normally if I have an error or a couple of mods are in conflict, I just remove the offending mod(s) from the mod folder and everything works fine again--especially on a brand new save game. But not with this for some reason. Very frustrating and time consuming.

              Edit: Never mind! After a LOT of headache I finally find out what the problem was: SpaceCore. Turns out, if you have the latest version installed, you get all the problems I detailed above. Once a downgraded to an earlier version, everything worked!

              So if anyone wants to use Farm Automation in conjunction with a Custom Farm Types map, use SpaceCore 1.0.2, not the latest version 1.0.3!
               
                Last edited: Oct 13, 2017
                HopeWasHere likes this.

              Share This Page