RELEASED Expanded Crevices [New Version 2.0!]

Discussion in 'Mods' started by Androxilogin, Jan 2, 2017.

  1. ulatz

    ulatz Aquatic Astronaut

    Errr... How did you guys make the mod works? I get tons of red flags on ALL returning errors about missing tilesheets.

    Sorry I'm a noob LOL
    • Aristatide

      Aristatide Tentacle Wrangler

      If you could check the train area too, something odd's going on post-maingame-update there for me, sort of a reset to maximum ground crap and tree-age every day.

      I absolutely love this mod, btw, and I don't think I ever told you that, @Androxilogin ; after the latest updates I'm living with a bunch of minor errors because nononono you will take my beautiful bridge shortcuts from my cold dead hands.

      (Though I'm having an unusually difficult time working out how you get access to the cliff behind Joja Mart.)
        Androxilogin likes this.
      • hwayunhae

        hwayunhae Big Damn Hero

        You have to come at that one from above (from the mountains). Its odd but that's how I found the purchase option in my game. There are requirements for buying things and you have to have bought the previous one first to be able to buy the new one.

        Note for anyone wondering why the bridge to the mine from the little island doesn't appear: Even though you can buy it right away, the condition on that bridge appearing requires the earthquake that reveals the path to the railroad before you can use it.
        • FarmerRen

          FarmerRen Void-Bound Voyager

          There's a text strings error on the sign below the walkway to the farm through the back left of Sciencehouse.
          The one that is next to the minecart with the blinky lanturn.
          It needs to be changed to reflect the new text string format.
          • Androxilogin

            Androxilogin Existential Complex

            You'll find that in all of my mods. I haven't looked in to anything, been working constantly so I never have a moment for anything. I've taken an indefinite hiatus previously mentioned in this thread. As much as I'd love to make mods for a living, it doesn't pay the bills so this will be that way for a while now.
            • hwayunhae

              hwayunhae Big Damn Hero

              I believe I might have fixed that in the hotfix I uploaded (that made the 3 places that looked like they should have gone somewhere actually go somewhere (though I'll have to reposition the beach one, as that little area turns out to be where the beach warp totem goes. >.> either that or upload a beach replacement map that makes the totem passable. -mutters to self about CA and maps that don't reflect all the things when you load them-)
              • FarmerRen

                FarmerRen Void-Bound Voyager

                I wasn't complaining. I just wanted to make sure you knew it was an issue. :speechless:
                • FarmerRen

                  FarmerRen Void-Bound Voyager

                  Where is that?
                  • hwayunhae

                    hwayunhae Big Damn Hero

                    Its the last post on page 5. I'll upload a fix for the beach, and edit the tile the totem appears on to make it passable. Give me a sec.

                    Here's the updated file. Download

                    If the sign isn't fixed, or I forgot to include the stringsfrommaps file, let me know and I'll edit the upload.

                      Attached Files:

                      Last edited: May 20, 2017
                      FarmerRen likes this.
                    • teethewicked

                      teethewicked Void-Bound Voyager

                      I keep getting this error when trying to run the game with your hotfix:

                      [21:06:49 ERROR Advanced Location Loader] Unable to load manifest, json is invalid:D:\Steam\steamapps\common\Stardew Valley\Mods\AdvancedLocationLoader\locations\ExpandedCrevices\manifest.json
                      After parsing a value an unexpected character was encountered: {. Path 'Warps[383]', line 48242, position 1.
                      at Newtonsoft.Json.JsonTextReader.ParsePostValue()
                      at Newtonsoft.Json.JsonTextReader.Read()
                      at Newtonsoft.Json.Linq.JContainer.ReadContentFrom(JsonReader r, JsonLoadSettings settings)
                      at Newtonsoft.Json.Linq.JContainer.ReadTokenFrom(JsonReader reader, JsonLoadSettings options)
                      at Newtonsoft.Json.Linq.JObject.Load(JsonReader reader, JsonLoadSettings settings)
                      at Newtonsoft.Json.Linq.JObject.Parse(String json, JsonLoadSettings settings)
                      at Entoarox.AdvancedLocationLoader.Events.GameEvents_LoadContent(Object s, EventArgs e)
                        samp0ern4 likes this.
                      • samp0ern4

                        samp0ern4 Void-Bound Voyager

                        same here with manifest from hwayunhae i got the same error like teethewicked
                        • FunkMaster

                          FunkMaster Intergalactic Tourist

                          please update for stardew 1.2
                          • Canaa

                            Canaa Scruffy Nerf-Herder

                            After testing, I sadly have to report that Expanded Crevices is causing a bug that results in Willy not appearing in the game except for when he gives you his fishing pole in a newly-started game. He does not appear in the list of villagers in the menu, or in his store, the bar, or any of his fishing locations. Additionally, and perhaps related, the bait and fish displays in the fishing store (which opens at the appropriate times, but without anyone to man it) display strings errors.

                            In testing to find which mod causes this, I've also had Marnie and Haley disappear in the same manner, but only once each, while Willy is consistent across every test I've made while narrowing down which mods causes this. The problem saves into the game file and Willy and any other disappeared characters are still gone if loaded without Expanded Crevices later.
                            • Androxilogin

                              Androxilogin Existential Complex

                              He gets caught in the wood pile on the beach
                              • imoumou

                                imoumou Void-Bound Voyager

                                I had the same issue, so I'm gonna stay away for a while, but this mod is truly awesome.
                                  Androxilogin likes this.
                                • Androxilogin

                                  Androxilogin Existential Complex

                                  I would stick around to correct things but with work I have very little time to myself and my hobbies. Possibly around next holiday I can get enough down time to patch things up. These are some major bugs that need taken care of. Willy gets caught in the wood pile on the beach, everyone else (Shane, Marnie) gets caught in the second portion of the backwoods (added by this mod). I created a manifest to remove this second portion of the backwoods to correct this in a manifest some pages back but Willy remains a mystery. If you pay the cleanup crew and open the path to the forest he should be free again. That's the best advice I've got so far

                                  The cliff behind JoJa is activated by the note on the wall beside the fridge in the mayor's house.
                                  • yuchinin

                                    yuchinin Void-Bound Voyager

                                    There is a loop bug on Stardew Valley Fair after installing this mod, if you talk to Mayor Lewis about start the Grange Display, the dialog message will keep appearing and prevent you from moving.

                                    [20:34:00 ERROR SMAPI] An error occured in the base update loop: System.NullReferenceException: Object reference not set to an instance of an object.
                                    at StardewValley.Event.initiateGrangeJudging()
                                    at StardewValley.Event.answerDialogueQuestion(NPC who, String answerKey)
                                    at StardewValley.Dialogue.chooseResponse(Response response)
                                    at StardewValley.Menus.DialogueBox.receiveLeftClick(Int32 x, Int32 y, Boolean playSound)
                                    at StardewValley.Game1.updateActiveMenu(GameTime gameTime)
                                    at StardewValley.Game1.Update(GameTime gameTime)
                                    at StardewModdingAPI.Framework.SGame.Update(GameTime gameTime) in D:\source\_Stardew\SMAPI\src\StardewModdingAPI\Framework\SGame.cs:line 520
                                    • Androxilogin

                                      Androxilogin Existential Complex

                                      I don't see the error. This mod does not affect the fair nor luau or any other events. While editing these I found they are not an immediate location upon loading the game so they would just cause errors. I intentionally left these parts of code out due to this problem.
                                      • Androxilogin

                                        Androxilogin Existential Complex

                                        Oh, I missed this until now. I meant nothing by it, I just have no time to actually look my messages over because my job is forever and then sleep. Then money day and then sleep. I'm trying to get on top of things, like wifi would be a start.
                                        • Overdreams

                                          Overdreams Void-Bound Voyager

                                          First of all, this mod is very useful and I'd like to compliment the great job you did!!
                                          I'd like to know if it's possible to remove some areas from this mod and how I can do that.
                                          I'm having some problems with the new backwoods, the summit and the seed shop and I want to cut them off. I tried doing this myself by deleting the entries in the manifest file and deleting the maps of the folder, but I guess something went wrong and the game wasn't opening.
                                          I would appreciate some directions, I really want to do this.
                                          Thanks in advance for the attention! :DD

                                          Share This Page