RELEASED Expanded Crevices [New Version 2.0!]

Discussion in 'Mods' started by Androxilogin, Jan 2, 2017.

  1. Androxilogin

    Androxilogin Cosmic Narwhal

    [UPDATE] 07/09/17 - Download this version to remove the "Back Path". This area causes characters to disappear or get stuck! This was a quick fix posted months ago, just moved to the top of the list.

    [UPDATE] 03/20/17 -

    It's finally here! Expanded Crevices v.2.0 (link also below). First of all, I want to say it was quite the experience to get this mod to where it is. I've been working night & day to make this mod as expansive as possible. It is now compatible with farms of all variations, individually tested. The default farm map will have pixel errors of pieces of trees floating behind your farmhouse until you pay for the backwoods shortcut and fence removal. This was currently done to the best of my knowledge to preserve compatibility with tego's farm from his original mod, "Tegos Stardew Expansion" which is no longer in development. However, his new mod is incompatible with this version although I look forward to changing this in a not-so-near future update.

    Here's as much as I could remember that is included:

    Adds a small back yard to the Science House. Regain access to the Summit from the railroad! Also adds the ability to walk home from the desert. Open the tunnel permanently for a price! Access the road to the BusStop from the upper-left of town. Expand the path beside the Community Center to below. Add a shortcut to the mountain from the upper-right side of town. Add a shortcut from the forest to the beach! Unlock the forbidden forest! Open Leah's yard! Open the path through the woods behind your farm! Add the back path! Open the shortcut to the back path from the BusStop! Upgrade the Adventurer's Guild! SeedShop upgrade! Upgrade the Mulners'! Upgrade the Science House! Move those desks in the Archaeology Office! Gain permanent access to Marnie's barn, Haley's dark room and Maru's basement! Move the Mayor's truck and shorten up some town fences to make room for your horse to pass through! Build a bridge or two or three for faster access to other locations. Unlock access to the sewer cliff by building a bridge on the island beside the Hat Mouse's house! Scavenge pieces of JojaMart. Steal the Jojamart sign and gain access to the area to the right of JojaMart! Run between the swings! Go between the bush and Pam's trailer! Move more freely behind the Sam's house, the Mulners and Blacksmith's! Move freely behind trees around town! NOT available from stardewmods.com OR stardewvalleymods.net

    Note that for the time being, the only available latest downloads will be from my Mega account. You will most likely want to install the latest versions of the following mods, as they add to this one.

    Expanded Crevices v.2.0

    Cleanup Crew v.2.0

    TreeLife v.2.0

    VIP v.2.0

    The file structure of each .zip is laid out for drag-and-drop ease! Just double-click it and drag it into the main folder of Stardew Valley.

    If you appreciate this mod or any of its counterparts, please feel free to leave some feedback! Also, consider making a donation if that seems appropriate. This (& its counterparts) have taken me a very long time to get to where they are.

    Reuploading to other sources is STRICTLY prohibited.

    This mod requires SMAPI, Advanced Location Loader, as well as Entoarox Framework to function.

    And I'm sorry to say, but Mac is currently incompatible with Advanced Location Loader, which these mods need in order to function.. So you will not be able to use them if you're using a Mac. I'm unsure of ALL & Linux compatibility as of the moment.

    I also forgot to put in the manifest a thank you to @Entoarox & @Pathoschild for their tools and/or assistance throughout this project.

    And remember..

    [​IMG]
    (There are children present).

    [UPDATE] 03/16/17 -
    Whoa.. It's been that many days already!? Anyway, LOTS of things have been added. After being mentioned in this thread about different farm variants, I began working on those- then got sidetracked by new ideas as I often do. v.1.0 had roughly 8,900 lines of code, the new version has 40,701 as of the moment. Of course I didn't release an alpha as semi-promised with fingers crossed.. There were just too many things I had to workout without the burden of telling everyone "I know" like a snooty jerkface so I avoided it completely.

    Things are just about ready but releasing on the weekend is bad juju so I'll keep ahold of what I have while I continue to age it like a fine wine. So put that in your cask and soak it!

    ALSO!
    I've started a Patreon page for anyone interested in helping fund my insanity.

    [UPDATE] 03/03/17 - Here's a sneak peek at some of the latest additions. These shortcuts/upgrades are attainable through completed tasks. I'd have released an alpha but there are just soo many things going on for compatibility purposes and new ideas coming to light, etc that it's just not a good time but I'm very close to releasing updates for all associated mods. (Cleanup Crew, TreeLife, VIP, OCD).

    sneakpeek.png

    [UPDATE] 02/06/17 - MANY new additions! Open that locked door in Marnie's! Access Maru's basement! Haley's Dark Room! ..Leah's yard!? Even more! Gotta find 'em all! Best for use with the other mods in this post. Get 'em! Experience the awesome! Post your thoughts.. Note, farm backyard warps still being worked in so you will get stuck if you exit to the right. DON'T DO IT! This is why this version hasn't been officially released on Nexus. I didn't have time today.

    Download 1.0 [Alpha bc of the stuff mentioned above; fix probably available tomorrow.]

    [UPDATE] 01/23/17 - New version 0.14a added. Bug fixes, additional crevices, passable trees in town (most notably that tree beside the cemetery), I honestly don't remember what else but just know it's better than the previous release. Download here or below.

    [UPDATE] 01/19/17 -
    New version added for compatibility with the latest Advanced Location Loader & Entoarox Framework. Also added access to Willy's cubby, erm.. his room.

    Download version 0.14 here.

    Here is a portion of a mod I've been working on. There is much more to come but I'm running into errors. Download from Nexus.

    [Description from Nexus] Adds the Summit as it was in the initial release (accessible for a fee) with an area of bushes and trees. Also adds a back yard to the Science House as well as permanent access to the Desert through the tunnel for a fee. You can also walk home from the Desert now. Requires the usual, SMAPI, Advanced Location Loader and Entoarox Framework. This resource will be updated whenever I get more data on my phone to use for uploads whenever that may be. lol. This is an early version.

    [​IMG]

    NOT available from StardewValleyMods.net, StardewMods.com or anywhere else other than Nexus.

    Uploading to other sources is STRICTLY prohibited.
     

      Attached Files:

      Last edited: Jul 9, 2017
    • TenkoKuugen

      TenkoKuugen Void-Bound Voyager

      Heh, I made a "walk home from the desert" mod as well, but it takes you through some wilderness maps I modified from Tego's old mod.
      I was already using a "summit" mod from the nexus(although the summit itself was useless, the modified railroad was useful)
      So lets see how this compares.
      I'll check our the maps and the ALL manifest later, looking forward to pilfer a few things for my personal experience. Maybe I'll learn a trick or two, too, ha.
       
      • Androxilogin

        Androxilogin Cosmic Narwhal

        There are some pixel errors here and there but more bushes and trees. Just reserving my place for an update.
         
        • Sparrows

          Sparrows Scruffy Nerf-Herder

          So I paid the 2000 gold at the sign pasted up on the Saloon, but nothing out in the backwoods seems to have changed...
           
          • Python593

            Python593 Star Wrangler

            @Androxilogin

            I have this ehm... glitch with your mod. Do you know what's the matter?

            [16:17:54 WARN Entoarox Framework] ContentManager: The `D:\Steam\steamapps\common\Stardew Valley\Mods\[2] AdvancedLocationLoader [1.2.9]\locations\ExpandedCrevices\all_sheet_paths_objects\spring\SummitPixels\SummitPixels` file is already being managed, this may cause issues
             

              Attached Files:

            • Androxilogin

              Androxilogin Cosmic Narwhal

              All it should have done is open up the fence in the backwoods and clear obstacles so you can walk through the back yard. However, there are countless pixel errors and I used tego's farm extension during the initial creation. In the future you won't have to pay the price again it will just work correctly. Since I've been working on it a lot I can't say what the issue might be but just know you'll get your money worth!

              It looks as though the SummitPixels tilesheet is already being loaded somewhere.
               
              • Python593

                Python593 Star Wrangler

                Hum... do you mean it may being loaded by a Advanced Location Loader mod?
                 
                • Androxilogin

                  Androxilogin Cosmic Narwhal

                  I'll have to look over your log when I get to a computer but from that caption it seems like it may be loading from somewhere else already such as the Content (or Maps possibly) folder or xnbloader or something as a test? I don't know, I'll have to look at the log to be sure.
                   
                  • SheepMilks

                    SheepMilks Zero Gravity Genie

                    THis is so cool!
                    will there be a way to get Penny a house??? or make the trailer into a house?
                     
                    • Androxilogin

                      Androxilogin Cosmic Narwhal

                      I was going to add something like that but I figure sometime in a future official update things might change there so I'm not all that sure about that one just yet.
                       
                      • Androxilogin

                        Androxilogin Cosmic Narwhal

                        I found the root of the cause.. I was using a personally modified version of tego's Farm. I've added all of this info to the manifest last night line by line. The new version should recognize the regular farm or tegos.. Switching in between may cause some issues with that particular area. I'd have done it all sooner but I've reworked that area soo many times I'm pretty well sick of it.

                        That being said, I have a new release that surpasses all of the others! Just wondering.. Who might be interested!? There are still some things I'd like to change but with enough interest I may release a "pre-copy" alpha version. I will of course have to package all the coorosponding mods that work in conjunction with this one to work correctly. But the enthusiasm doesn't seem to be there so I've been taking my time. :mwahaha: This release should focus on adding the vast amount of new areas, next will focus on tidying them up.

                        I'm sorry, I completely forgot about this. Did you find anything that worked?
                         
                        • Python593

                          Python593 Star Wrangler

                          Don't worry, well, I don't really know what is causing that. What's the corresponding file to "SummitPixels tilesheet"?

                          Edit: By the way, I have another problems with your another mods (Tree Life and Cleanup Crew), while in my farm I saw some of the fences and bushes were totally like... cut. I'll send you an image.
                           
                          • Androxilogin

                            Androxilogin Cosmic Narwhal

                            SummitPixels is a tilesheet I made specifically for this mod. It used to hold only the Summit but has grown. Rather than having multiple files (_spring, _summer, _fall, _winter) it seemed the best way to go.
                             
                            • Python593

                              Python593 Star Wrangler

                              Ok... that's the image, and I give you my log with Cleanup Crew, TreeLife, Visual Improvement Program and Expanded Crevices being used. Those missing bushes and fences are present while I use TreeLife, when I use VIP, I saw more yellow messages warning me about "fixes" file is already being managed, this may cause issues. Just like SummitPixels tilesheet. Do you know what can it be?

                              [​IMG]
                               

                                Attached Files:

                              • Androxilogin

                                Androxilogin Cosmic Narwhal

                                Ah, luckily I DIDN'T release an alpha or else other users would have come across this mess. I'm going to have to do the farm variants one by one. It's the fixes file being screwy now? Because it has since been renamed to crevicefixes.xnb. The problem is most likely just a warning saying that these pixel errors will occur since I hadn't coded for those maps specifically. Thanks, I'll be sure to look these over before the next update. Ugh.. These newer map layouts are my least favorite to edit. As long as it's not crashing on you, these errors will be present until I update everything to know the difference. I often forget the other farm maps were added to the game.
                                 
                                  Last edited: Mar 10, 2017
                                  Python593 likes this.
                                • Python593

                                  Python593 Star Wrangler

                                  Uhm, I don't really know, you see, I don't know much english, so sometimes maybe I can't understand you. I know that you are telling to me you didn't coded for that maps specifically. Ok, I understand that, but why do I have these errors?

                                  [​IMG]
                                   
                                  • Androxilogin

                                    Androxilogin Cosmic Narwhal

                                    Town@10, 37 is a front layer while it should be "AlwaysFront". This is a tree in town that should be replaced by an interactive one. These are most likely an oversight on my part.

                                    All of these mods came from a previous version of ALL that later converted the old versions for new and also removed some things as well as crashed because of some of them in the past. I began to rework from the ground up but got sick of redoing everything and decided to find them while they came to me. It's a long, boring story about a short, boring man.. I've been trying to fix these as I come to them but these mods are also growing so errors will be present but typically not causing any harm.

                                    Edit: Made some changes to the mods in question to make way for compatibility for the other farm maps and it only took about an hour! So as soon as I figure out how to go about some of them I'll be able to lay the ground work. 'Paths' errors were missing the tilesheet id, this has been corrected as well.
                                     
                                      Last edited: Mar 10, 2017
                                    • Karmylla

                                      Karmylla Pangalactic Porcupine

                                      Honestly, your work is fantastic! I honestly hope to reach your level in the future!
                                      Thanks for sharing this, I was hoping to find a way to get into Maru's basement and Willy's living quarters! :D
                                      I'm quite excited for the next update! Kudos!!!
                                       
                                        IronZelly likes this.
                                      • Androxilogin

                                        Androxilogin Cosmic Narwhal

                                        Here are some of the latest additions!

                                        Thank you! But really, it's just an acquired taste- anyone can do it. Once you start mapping something out it's pretty much just copy and paste. Like working tIDE through notepad. And it gets super addictive.

                                        [EDIT] New version 2.0 released! You can find it in the first post of this thread.
                                         
                                          Last edited: Mar 20, 2017
                                          wutangraiseu likes this.
                                        • TheWiseOne13

                                          TheWiseOne13 Master Chief

                                          Love your mods and have been looking forward to the update, However once clicking on the link the progress bar (circle) goes to 100% (all the way around the circle) and nothing happens...

                                          Never mind, Immediately after posting this it fixed itself :/ strange... but I'm happy :D
                                           

                                          Share This Page