1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Closed Error, then Stack Trace. [solved, please read bottom of OP]

Discussion in 'Support' started by Skwee, Dec 5, 2013.

Thread Status:
Not open for further replies.
  1. Skwee

    Skwee Master Chief

    So I launch up the launcher and when I click "Launch Starbound" inside the launcher this pops up:

    [​IMG]

    Clicking "OK" leads to this:

    [​IMG]

    Clicking "OK" here just closes it and there are no further errors, but the game does not launch.

    Reading the actual error I can tell you this, the game is not looking on the correct harddrive. My game is installed to the C:/ Drive, not the E:/ drive. The Steamworks folder does not even exist on my E:/ drive. The game launcher window stays open, and when closed steam believes that I am still in the game. Looking in my task manager I find this:

    [​IMG]

    The largest processes on my entire computer.

    I must end them from the processes window in order to launch the launcher again, but as such there is not much point due to the previous errors.

    I am running on Windows 7 64 bit OS, my account has full privileges. Also running the game .exe directly from the folder that it is actually in still gets me this error even though it is on the C:/ drive.

    EDIT: I tried everything i've come across to workaround the problem and have finally found a solution. The problem is not with running as administrator, since that doesnt work at all, the solution I had to do was this
    Solution:
    Since my user account is the only one on the PC I am using, since I am the owner of said PC, I have administrative rights over everything, I have everything set to run as administrator by default. So setting things to run as admin did not help.
    I had tried every workaround but one, which was an odd one at that, which is to NOT run the game as administrator. In order for me to do this I had to create an entire new user on my PC, log out of my administrator user, and log into this new user I had created as a standard user, then I launch up steam and run the game and it works. This is a bloody awful workaround, as none of my stuff/settings/ etc is on this account. So chucklefish, if you are reading this, please fix this issue ASAP. There is no reason the game should not work when run as an administrator.


    There is no reason I should have to create an entire new user on my PC with less privileges in order to launch something.
     
    Last edited: Dec 6, 2013
    Punkmone likes this.
  2. Jman1177

    Jman1177 Void-Bound Voyager

    Same thing here. No idea how to fix this.

     
    Last edited: Dec 5, 2013
  3. skystomach

    skystomach Yeah, You!

    I am getting the same error
    In the starbound folder it creates a text file with this error in it

    Info: Preparing Star::Root...
    Info: Creating default Star::Configuration
    Info: Done preparing Star::Root.
    Info: Client version 'Beta v. Perturbed Koala' '615' '418'
    Info: Starting from the title screen
    Info: Initialized SDL
    Error: Access violation detected at 0x76a53134 (Read of address 0x76e3322c)
    Error: Stack Trace...
    007D2D00 (E:/Steamworks/Starbound/git/starbound/source/core/StarSignalHandler_windows.cpp:16)
    76A53134
    6FCF4E9C
    6FCF512A
    6FCF5E17
    6FCF2A56
    6FCF7C78
    6FCF7CF5
    76BE6381
    76BD80A9
    76BD8BA1
    7748010A
    76BE60DC
    6812D1DF
    6812FEA0
    68130D87
    6812744B
    68101570
    0040A871 (E:/Steamworks/Starbound/git/starbound/source/application/StarApplicationBase.cpp:32)
    00403830 (E:/Steamworks/Starbound/git/starbound/source/client/StarClientApplication.cpp:15)
    00407798 (E:/Steamworks/Starbound/git/starbound/source/client/main.cpp:47)
    004DB891 (c:\SDL-1.2.15/./src/main/win32/SDL_win32_main.c:318)
     
  4. ptbotwo

    ptbotwo Void-Bound Voyager

    I am having the same Drive E: problem, but from when I try to start the server up. Was fine before update.
     
  5. Zellman

    Zellman Existential Complex

    Yep same error. Mine happened after I saved and exited.

    ...
    Info: Shutting down Star::Root
    Error: Access violation detected at 0x771be41b (Write of address 0)
    Error: Stack Trace...
    007D2B90 (E:/Steamworks/Starbound/git/starbound/source/core/StarSignalHandler_windows.cpp:16)
    771BE41B
    771BE023
    768698CD
    ... (7)
    00A95D6B (E:/Steamworks/Starbound/git/starbound/source/core/StarList.hpp:15)
    ... (7)
    004DB801 (c:\SDL-1.2.15/./src/main/win32/SDL_win32_main.c:318)
     
  6. Skwee

    Skwee Master Chief

    What kind of OS are you guys on?

    My error seems to be a lot simpler than your guys' it just shows one thing.

    Also I tried verifying the game files, and I also redownloaded the game completely, still getting the error before I can even get in game. Also the screenshot of my processes, there are 3 because each time you click the launch button it creates a new process when the errors pop up, so that is why there are 3
     
  7. Alphanos

    Alphanos Orbital Explorer

    FYI guys, although I don't know what error is causing your problem, I can tell you that Starbound isn't looking on the wrong hard drive. The parts of the log you're referring to are just identifying the locations of the source code files at compile-time, on the developers' machines.
     
    NeroAngelo and Vince Noir like this.
  8. Skwee

    Skwee Master Chief

    I find something strange about my error is it does not have an address or whatever, it just says 0
     
  9. frawg

    frawg Space Hobo

    Running from the folder launches the Starbound Launcher instead of the game client. From the executable did yours run the launcher or the client?
    Scratch that wasn't reading everything in the first post.
     
  10. JohnnyKill

    JohnnyKill Astral Cartographer

    To find out what 0 means Find your log It's a file called starbound.log located in your Starbound directory which you can find by right-clicking the game in Steam and clicking Properties -> Local Files -> Browse Local Files
     
  11. Sench

    Sench Void-Bound Voyager

    Same problem here.
    Also, I don't mean to be a jerk, but an executable of over 600 MB? Are you guys trying to make the game have as many problems as possible?
     
  12. JohnnyKill

    JohnnyKill Astral Cartographer

    From what I see A stack overflow is caused that means there are to many on a stack in other words the game is doing this that what 0x7733e3be means A quick fix for stack overflow problems is to run a registry cleaning program or delete browsing this java right, :geek:
     
  13. Zellman

    Zellman Existential Complex

    The game is not written in Java, it is C++, not sure how that changes things because I am not a programmer.
     
  14. Roxyn

    Roxyn Title Not Found

    I'm getting this error when trying to host a server, but I can play the game itself I think. I took some screenshots of the three errors that pop up when it happens:

    First

    Second

    Third

    This has only been happening as of today. I was hosting fine all of last night until around 1am GMT when I went to bed.

    Windows 7 64-bit. Tried running steam and the launcher both as admin as suggested in another thread similar to this one but had no luck.

    Edit: Scratch that, I can't play the game itself either. I just loaded into singleplayer, beamed down to planet, alt tabbed assuming it was working only to notice a similar if not the same error popping up and then closing the game.
     
    Last edited: Dec 5, 2013
  15. hl2dm

    hl2dm Space Hobo

    I found a solution to the problem
    The problem is caused by the universe folder
    At the same time on the server
    You just will file inside this folder to another location
    Can not find the file happens Planet
    This time you can successfully open the server up
    But your mission or operation of the planet information will be re-
    If you can try to bring it back to the planet gear to pull back

    have fun
     
  16. DW01

    DW01 Void-Bound Voyager

    Regarding the E:\ thing, that's the volume the game was COMPILED FROM. Most compilers keep this intact for errors.
     
  17. Levoire

    Levoire Space Hobo

    Is there anyway you can elaborate on this as it looks like your sentences were ending too early?
     
  18. Ynothna

    Ynothna Void-Bound Voyager

    To elaborate on what hl2dm is saying, the "universe" folder in your StarBound folder is where the error is. As soon as I moved the universe folder and started the server again it was recreated and I didn't get the error. I logged in and found my character still has all his stuff because it's stored in the player folder, but the world is new...Currently working to see if I can recover my world. I'll update if I find anything!

    UPDATE:
    The file causing the problem seems to be the largest .world file (makes sense that it's storing all the data). As soon as I moved just that file into my new universe folder the same error returned.
     
  19. Levoire

    Levoire Space Hobo

    I tried moving the folder and I still get the same errors. Tell me, are you clicking the "Launch server" button from the launcher or using "Starbound_server.exe" from within the game directory? The latter doesn't seem to give me an error when used, it just shuts itself down.
     
  20. Ynothna

    Ynothna Void-Bound Voyager

    Strange. I renamed the universe folder to universe.bak and then ran the server from the launcher and it worked first try.
     
Thread Status:
Not open for further replies.

Share This Page