1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Bug/Issue Error: Starbound crashing through Steam Startup

Discussion in 'Support' started by LoganCI, Dec 22, 2016.

  1. LoganCI

    LoganCI Void-Bound Voyager

    Good day, Prior to the 1.2 update my computer, specs of: Macbook pro OS: 10.10.5 Processor: 2.26 GHz Intel Core 2 Duo Memory: 8 GB 1067 MHz DDR3 and Graphics Card: NVIDIA GeForce 9400M 256 MB, ran Starbound at a decent rate and only became sluggish near high particle areas such as the portal to the Ruin. However once the 1.2 update came out I went down to 1-2 frames thus making the game unplayable. I waited patiently for an update to fix this and when I saw others stating that Update 1.2.1 had fixed their fps issues I was estatic. Sadly I now have another issue I can load Starbound by browsing local files and using the launcher in directory Library/Applicationsupport/Steam/steamapps/common/Starbound/osx but launching via steam immediately causes the game to unexpectedly quit. Here is what the log states.

    [20:18:52.747] [Info] Root: Preparing Root...
    [20:18:52.749] [Info] Root: Done preparing Root.
    [20:18:52.749] [Info] Client Version 1.2.1 (macos x86_64) Source ID: f15286d545debbcdb4e5e73680a1805ad29308da Protocol: 729
    [20:18:52.749] [Info] Root: Scanning for asset sources in directory '../assets/'
    [20:18:53.122] [Info] Root: Scanning for asset sources in directory '../mods/'
    [20:18:53.123] [Info] Root: Skipping hidden '.DS_Store' in asset directory
    [20:18:53.123] [Info] Root: Detected asset source named 'base' at '../assets/packed.pak'
    [20:18:53.123] [Info] Root: Detected unnamed asset source at '../assets/user'
    [20:18:53.123] [Info] Loading assets from: '../assets/packed.pak'
    [20:18:53.671] [Info] Loading assets from: '../assets/user'
    [20:18:55.766] [Info] Assets digest is e50bdbcb21170ac0da24ea03ce5b2963dd8fa65b8235e02ee1cae9b08cdc3bd6
    [20:18:55.766] [Info] Root: Loaded Assets in 3.01706 seconds
    [20:18:55.771] [Info] Application: Initializing SDL Video
    [20:18:55.914] [Info] Application: Initializing SDL Joystick
    [20:18:55.916] [Info] Application: Initializing SDL Sound
    [20:18:55.984] [Info] Initialized Steam services
    [20:18:55.986] [Info] Application: Creating SDL Window
    [20:18:56.118] [Info] Application: Enabling VSync with late swap tearing
    [20:18:56.118] [Info] Application: Enabling VSync late swap tearing failed, falling back to full VSync
    [20:18:56.163] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [20:18:56.168] [Info] OpenGL version: '2.1 NVIDIA-10.0.35 310.90.10.05b12
    ' vendor: 'NVIDIA Corporation' renderer: 'NVIDIA GeForce 9400M OpenGL Engine' shader: '1.20'
    [20:18:56.171] [Info] Application: initialization...
    [20:18:56.172] [Info] Root: Loaded Configuration in 0.001073 seconds
    [20:18:56.600] [Info] Application: renderer initialization...
    [20:18:56.606] [Info] detected supported OpenGL texture size 8192, using atlasNumCells 128
    [20:18:56.606] [Info] detected supported OpenGL texture size 8192, using atlasNumCells 64
    [20:18:56.608] [Info] Root: Loaded ImageMetadataDatabase in 5.99999e-07 seconds
    [20:18:56.631] [Info] Application: main update loop...
    [20:18:56.654] [Error] Fatal Error: Segfault Encountered!
    0 starbound 0x00000001048156bc _ZN4Star10fatalErrorEPKcb + 60
    1 libsystem_platform.dylib 0x00007fff81a49f1a _sigtramp + 26
    2 ??? 0x0c3b57947a21311c 0x0 + 881394447296835868
    3 starbound 0x000000010470011c _ZN4Star17ClientApplication10updateModsEv + 92
    4 starbound 0x00000001046fff41 _ZN4Star17ClientApplication6updateEv + 321
    5 starbound 0x00000001051851a1 _ZN4Star11SdlPlatform3runEv + 577
    6 starbound 0x0000000105184de4 _ZN4Star18runMainApplicationENSt3__110unique_ptrINS_11ApplicationENS0_14default_deleteIS2_EEEENS_10StringListE + 180
    7 starbound 0x000000010470411c main + 92
    8 libdyld.dylib 0x00007fff8bbc35c9 start + 1

    Now I've done some perusing but all the answers that seemed to fix others systems have not fixed mine so that is why i'm asking for help.
     
  2. STARGUIDE

    STARGUIDE Aquatic Astronaut

    Greetings!
    Have you tried to launch Starbound with steam closed?
     
  3. Hel

    Hel Music Mistress Forum Moderator

    Your issue here is the Segmentation fault.

    I'm unsure what has caused that, but my advice would be to copy and paste your characters and worlds, universes somewhere else, and reinstall the game completely (press uninstall on Steam but then delete the leftover folders from the Steam X86 Path.

    Try running the game after a nice fresh installation and see if that fixes your issue
     
  4. LoganCI

    LoganCI Void-Bound Voyager

    On a completely Fresh wipe the game still crashed on startup with this error log

    [00:06:56.867] [Info] Root: Preparing Root...
    [00:06:56.868] [Info] Root: Done preparing Root.
    [00:06:56.868] [Info] Client Version 1.2.1 (macos x86_64) Source ID: f15286d545debbcdb4e5e73680a1805ad29308da Protocol: 729
    [00:06:56.868] [Info] Root: Scanning for asset sources in directory '../assets/'
    [00:06:57.814] [Info] Root: Scanning for asset sources in directory '../mods/'
    [00:06:57.814] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [00:06:57.814] [Info] Root: Detected asset source named 'base' at '../assets/packed.pak'
    [00:06:57.814] [Info] Root: Detected unnamed asset source at '../assets/user'
    [00:06:57.814] [Info] Loading assets from: '../assets/packed.pak'
    [00:06:58.491] [Info] Loading assets from: '../assets/user'
    [00:07:02.718] [Info] Assets digest is e50bdbcb21170ac0da24ea03ce5b2963dd8fa65b8235e02ee1cae9b08cdc3bd6
    [00:07:02.718] [Info] Root: Loaded Assets in 5.84994 seconds
    [00:07:02.726] [Info] Application: Initializing SDL Video
    [00:07:04.219] [Info] Application: Initializing SDL Joystick
    [00:07:04.220] [Info] Application: Initializing SDL Sound
    [00:07:04.354] [Info] Initialized Steam services
    [00:07:04.356] [Info] Application: Creating SDL Window
    [00:07:04.604] [Info] Application: Enabling VSync with late swap tearing
    [00:07:04.604] [Info] Application: Enabling VSync late swap tearing failed, falling back to full VSync
    [00:07:04.840] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [00:07:04.845] [Info] OpenGL version: '2.1 NVIDIA-10.0.35 310.90.10.05b12
    ' vendor: 'NVIDIA Corporation' renderer: 'NVIDIA GeForce 9400M OpenGL Engine' shader: '1.20'
    [00:07:04.848] [Info] Application: initialization...
    [00:07:04.848] [Info] Root: no runtime config file, creating new default runtime config
    [00:07:04.848] [Info] Root: Loaded Configuration in 8.31001e-05 seconds
    [00:07:05.302] [Info] Application: renderer initialization...
    [00:07:05.308] [Info] detected supported OpenGL texture size 8192, using atlasNumCells 128
    [00:07:05.309] [Info] detected supported OpenGL texture size 8192, using atlasNumCells 64
    [00:07:05.311] [Info] Root: Loaded ImageMetadataDatabase in 9.00007e-07 seconds
    [00:07:05.334] [Info] Application: main update loop...
    [00:07:05.463] [Error] Fatal Error: Segfault Encountered!
    0 starbound 0x000000010d6f46bc _ZN4Star10fatalErrorEPKcb + 60
    1 libsystem_platform.dylib 0x00007fff8c03bf1a _sigtramp + 26
    2 ??? 0x000000007bb2c11c 0x0 + 2075312412
    3 starbound 0x000000010d5df11c _ZN4Star17ClientApplication10updateModsEv + 92
    4 starbound 0x000000010d5def41 _ZN4Star17ClientApplication6updateEv + 321
    5 starbound 0x000000010e0641a1 _ZN4Star11SdlPlatform3runEv + 577
    6 starbound 0x000000010e063de4 _ZN4Star18runMainApplicationENSt3__110unique_ptrINS_11ApplicationENS0_14default_deleteIS2_EEEENS_10StringListE + 180
    7 starbound 0x000000010d5e311c main + 92
    8 libdyld.dylib 0x00007fff961b55c9 start + 1
    9 ??? 0x0000000000000001 0x0 + 1
    as well when starting with steam closed the game starts up perfectly fine meaning there is a disconnect between my steam and starbound.
     
  5. LoganCI

    LoganCI Void-Bound Voyager

    Ok then so i fixed the problem turns out for some reason my steam wasn't updating to the proper build so i was using a build from July when the latest is a build from December I believe that is what caused the disconnect between Starbound and steam either way Starbound is now working after a fresh copy of Starbound and deleting my steam Config.vfd then getting a fresh copy of that off of steampowered.com
     
  6. eatsomefruit

    eatsomefruit Intergalactic Tourist

    Hey Logan where is the Steam Config.vfd and where/how do you get it off steampowered.com? Can't find it either places for the life of me. Many thanks!
     

Share This Page