1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

ERROR in action number 5 of Create Event for object oInit: Error defining an external function.

Discussion in 'General Discussion' started by Rosello, Jul 8, 2013.

  1. Rosello

    Rosello Space Spelunker

    I could run RoR perfectly fine, but today it suddenly stopped working, displaying this message every time I try to start it up. What's going on?
    • Burby

      Burby Phantasmal Quasar

      It's happened to a couple of people on here before. I don't know the cause, but for some reason trying to play the game again later just fixes it. It might take a while though.
      • Draken09

        Draken09 Black Hole Surfer

        I just had it. Closing Firefox fixed it for me.
        • okok111

          okok111 Scruffy Nerf-Herder

          Are you using a shortcut? I find that it works when im not using a shortcut, but it has trouble defining that pesky external function when I use a shortcut to the exe.
          • Draken09

            Draken09 Black Hole Surfer

            I... Don't think so? I've already checked several times that it works without Firefox for me and gets the error with Firefox. It's possible there's more than one way to trigger the error...
            • Hopscotch

              Hopscotch Scruffy Nerf-Herder

              this bug has randomly started happening to me too, which is weird because it was working earlier in the same day

              the only thing on my computer that changed since then was a windows update

              it's a bit of a pain because it just absolutely wont let me play it now
              • Lmaoboat

                Lmaoboat Void-Bound Voyager

                Check the Readme.
                • Fatalerror66

                  Fatalerror66 Space Hobo

                  I have and did what it told me and i still get
                  In fact i have now:

                  I am running windows 7 64bit
                  have tried windows XP compatibility mode
                  running it as an admin
                  updated my sound drivers
                  Followed the read me instructions
                  I even re-downloaded the game and installed it to a different drive
                  Sadly none of the above worked for me

                  I know I could ignore the bug, by hitting ignore 20+ times. Though I lose sound and that just is not fun to play without it
                  ERROR in
                  action number 5
                  of Create Event
                  for object oInit:

                  Error defining an external function.
                  • Ozymandias

                    Ozymandias Scruffy Nerf-Herder

                    I just bought the beta-version and I'm having the same problem but the demo ran fine :c
                    • hopoo

                      hopoo Risk of Rain Developer Developer

                      Yeah, sadly its an error that seems to be random and related to GM (Hotline Miami has the same problem for some users). I find some things that help are:
                      I had it for a day and it was extremely frustrating, because it made game development pretty much impossible. Doing all of the above seemed to make it go away. Make sure to uninstall VC++ before reinstalling with the link above!
                        Freddy and Draken09 like this.
                      • Ozymandias

                        Ozymandias Scruffy Nerf-Herder

                        Could it be due to the fact that your game is packaged with (and possibly attempts to use) the wrong bit type of VC++? Like x86 vs x64?

                        For the record the only program running besides non-essential programs after starting the computer was Steam.

                        EDIT: As I thought, installing the correct bit version of VC++ fixed the problem immediately. GameMaker may be attempting to poll a version of the redistributable that does not exist because the correct edition (x64) is not installed. I installed x64 version, restarted my comptuer, opened my browser to make sure that had nothing to do with it, and then ran the game. Sure enough it was simply the redist. I would package both redists in the redist folder with a batch file like this:
                        @echo off
                        if "%PROCESSOR_ARCHITECTURE%"=="AMD64" goto 64BIT
                        vcredist_x86.exe /q
                        goto END
                        vcredist_x64.exe /q
                          hopoo likes this.
                        • Naruku

                          Naruku Space Hobo

                          In the vcredist folder i see 2008 and 2010, which one do i get rid of, also when i go to uninstall, i see like 10 different VC++ which on do i uninstall. The problem i have is no music or sound at all. I get the Error in action 5.
                          • EspadaLegend

                            EspadaLegend Space Hobo

                            Same issue I'm currently trying to fix my sound, also which C++ does the game run on?
                            • GordonPayne30

                              GordonPayne30 Yeah, You!

                              I fixed by making it start with admin and then repairing the vcredist things and then restarting steam

                              Share This Page