1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Elunite Race Mod 2.0.1

Adds Elunite as a playable Race!

  1. Natural Aura

    Natural Aura Pangalactic Porcupine

    Any chance you'd be willing to change the name of the file "greenenergybladeparticles" both normal and 2. Along with the corresponding files linking to those files? The reasoning behind this is due to the factor the FU already has a file named the exact same thing (only with the green one). This is causing a conflict with both the weapon and another mod that I have called "Immersive Props" that uses that file as a dependency. owo

    Edit: After getting that one fixed I then started up the game again just to encounter another error regarding "mechainfusion"... that one is a little beyond my understanding to solve. So further testing has came to a halt for me, idk if you use FU or anything, but do you have any idea if it is actually compatible and it is just me, or you simply don't use FU so you didn't make this race with FU in mind.
    Last edited: Aug 6, 2019
  2. Omnija

    Omnija Cosmic Narwhal

    Elunite's used to be supported by FU, but they have dropped support for plenty of custom races. I do play with FU and i have not encountered any issues using any of the weapons or armours.
    ((pastebin) your log would of helped me help you in this sort of thing and possibly a mod list))
    I would update your FU, since there releases are very unstable and have version that will work and others that don't. If the problem persist, send me your log and ill look into changing the particles if it's needed.

    edit: tested with ImmersiveProps-1.6.9, and FU-5.6.3532, and still do not have any issues.

    Lately I've looking into weapons....
    Instead of making tier'd Weapons (currently spears), i figured making them randomly generate would be a little more unique.

    3 Handles 7 Blades.png
    Last edited: Aug 6, 2019
    Saint Apollyon likes this.
  3. Natural Aura

    Natural Aura Pangalactic Porcupine

  4. Omnija

    Omnija Cosmic Narwhal

    Not sure what "redgyutarimbdeocred1.object" is.... Also i just found out... apparently FU breaks lightsaber flipping animations.
    Last edited: Aug 6, 2019
  5. Sotaeko

    Sotaeko Phantasmal Quasar

    [13: 35:14.588] [Error] Could not apply patch from file /objects/protectorate/objects/protectorateradio/protectorateradio.object.patch in source: ..\mods\Frackin Universe - 5.6.3532. Caused by: (JsonPatchException) Could not apply patch to base. (JsonPatchException) Could not apply operation to base. (TraversalException) Could not find "image" to remove
    [13: 35:14.821] [Error] Duplicate projectile asset typeName pushzone. configfile /items/active/weapons/ranged/abilities/protection_sphere/protection_sphere.projectile

    we do not have an abilities folder for ranged weapons ; so my guess its Frackin Races since they use to have support for abilities for our race/weapons.

    You could try and contact FU for the issue.
    Last edited: Aug 6, 2019
  6. Natural Aura

    Natural Aura Pangalactic Porcupine

    Oh, the ability thing is something else entirely, I already know what causes that. [SPOILER ALERT: its "The Eseential Jetpack Mod"]
    and for the radio thing.... huh that's new... going to have to look into that.

    Edit: Think I figured that out, it may be due to the factor that "Prop Pack" and "Frackin Universe" are trying to patch the exact same thing.

    That object there, from what I can tell, is located within the immersive props mod, however I don't think it is the cause at it is just trying to refer to the "greenenergyblade2.particle" which it fails to do as it reads a duplicate upon start up.

    PS: With this mod on, my game ctd on startup, not in-game.
    Last edited: Aug 6, 2019
  7. Omnija

    Omnija Cosmic Narwhal

    did you try deleting it?
  8. Natural Aura

    Natural Aura Pangalactic Porcupine

    Which one, thing are you referring too? The "Props Pack" mod, the redgyutar....object or the "greenenergyblade2.particle" files?
  9. Omnija

    Omnija Cosmic Narwhal

    the "greenenergyblade2.particle" file and if that doesn't work try changing these lines in greenflipslash.weaponability

    "particleEmitters" : {
    "flip" : {
    "active" : false,
    "transformationGroups" : ["weapon"],
    "offsetRegion" : [-4, -4, 5, 5],
    "emissionRate" : 70,
    "particles" : [
    { "particle" : "greenenergyblade"},
    { "particle" : "greenenergyblade2"}


    { "particle" : "jedigreenenergyblade"},
    { "particle" : "jedigreenenergyblade2"}

    then change the particle names to match that located in particles
  10. Natural Aura

    Natural Aura Pangalactic Porcupine

    Yep, and as I'd mentioned in a previous post, that is now solved, it skips past that and then crashes on the "mechainfusion" file instead.

  11. Omnija

    Omnija Cosmic Narwhal

    what errors does the mechinfusion give?
  12. Natural Aura

    Natural Aura Pangalactic Porcupine

    Alright, so I did you edit suggestion and it crashed at the same error. Afterwords I deleted your files to replicate the other error I got and below there is a pastebin showing that.

    Also got rid of the other errors regarding those other two mods... just so they don't distract you.

  13. Omnija

    Omnija Cosmic Narwhal

    I'm not quite sure, since i don't seem to have any issues. As you can see i'm using the full mechafusion outfit and in game.


    Try redownloading the latest version or using the pak i released last page.
  14. Natural Aura

    Natural Aura Pangalactic Porcupine

    Sorry for the delayed response, something came up. I'll try it out again, see if I can figure out what's up and perhaps go through my .pak files to see if anything pops up there.
  15. Natural Aura

    Natural Aura Pangalactic Porcupine

    HAHAHAhahahaha...haaaaaaaa.... This might sound dumb or like REALLY dumb, but I just realized when unziping your file, the folder extracted isn't the race, but rather a folder that contains the race folder plus some user information... I suppose I must apologize now for WAY over complicating all this. This is legit the first mod I've ever seen do this... so I just assumed the first folder that was extracted was the race mod all-in-all.

    This entire time I've just been using the search bar to anylyse all the files contained in my mods location... heh. ^^' Thanks for your help!
  16. Omnija

    Omnija Cosmic Narwhal

  17. Omnija

    Omnija Cosmic Narwhal

    Just a small update notice, Sotaeko has been working on a custom drop ship but we've been stumped currently with before and after ship breaks... due to it being binded to all races making it sort of annoying to deal with. We also have completed 4 warframe weapons which still need fine tuning. Currently supported strun, lato, lanka and braton, we decided to stick with some of the older models as the new ones, didn't look as nice.
    Saint Apollyon likes this.
  18. RexGeneris

    RexGeneris Space Hobo

    I'm not sure if this has been asked already, since it's quite difficult to rummage through all of the random comments and discussion posts, but how do you obtain the discs beyond the Maltese Disc?
  19. zitacore

    zitacore Aquatic Astronaut

    I really like this race, but I want to try it with a different ship. I've unpacked the Elunite race mod and been replacing the ship files from there with another mod. The ship I've been trying to replace it with is the Avali Extra Ship 1.1: https://community.playstarbound.com/resources/avali-extra-ship.3152/

    I've renamed the Avali ship files to match the original Elunite ship name; aviant0.structure -> eluniteT0.structure and so on (as instructed by the Avali mod creator ArRockANsate). Except, there are a few files that can't be matched 1 to 1:

    Avali ship mod has:
    (Also this mod doesn't have T9-T10 ship files)

    While Elunite ship mod has:

    I can't be sure what these files do so I just leave them all in the Elunite ship folder (I do rename aviantblocks.psd to eluniteblocks.psd), re-pack everything back to a .pak file with only the files in the Elunite ship file modified. I go to create my character and skill the intro sequence and I get the same error every time:

    Client ship world has errored.

    I've tested the Elunite Race Mod 2.0.1 on a new character without modifying the original mod file and I can spawn in the original Elunite ship skipping the intro sequence just fine. If anyone has any race ship switching experience I could use their expertise.

Share This Page