1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Modding Help Do's and Don'ts of reporting issues with SMAPI mods

Discussion in 'Mods' started by Entoarox, Oct 5, 2016.

  1. jaregon

    jaregon Space Hobo

    I tried to load up my stardew with Smapi today and it's giving me this error. It was working just fine last night and I tried restarting my computer so I'm not sure whats causing it.
    https://log.smapi.io/TTs1iFHr

    EDIT: NVM Restarted my computer and tried opening it without opening other stuff and it booted up just fine. Must of been a resource problem
    EDIT 2: The error came back now and it's not a resource problem, I really want to know what makes this error show up, cause it seems almost random at this point
    EDIT 3: Updated computer some and now the error is gone again.
     
      Last edited: May 30, 2018
    • Entoarox

      Entoarox Oxygen Tank

      This issue always boils down to one of two things:

      1. You do not have enough memory available while SDV is starting - browsers are usually the culprit in that case.
      2. If you use secondary audio devices (Like headphones) make sure they are disconnected, as XNA can run into issues when there are multiple audio devices to choose from.

      If it isnt the second, and no amount of shutting stuff down fixes the first, be sure to report it, there is a potential solution for this if it *is* memory related. :)
       
      • GumihoDokkebi

        GumihoDokkebi Space Hobo

        Hello. So my game crashes for an unknown reason (at least for me). No specific time or action that I know of, triggers it, so I tried playing the same day 20 times... I tried reinstalling and making a new save file, but the same thing happens over and over again. I was wondering if you guys could give me a solution? Here is my SMAPI log: https://log.smapi.io/Ybyv9eCG . Thanks!

        P.S. works without SMAPI
         
          Last edited: Jun 4, 2018
        • Entoarox

          Entoarox Oxygen Tank

          Memory issue, due to how deep in XNA it is happening, I have to assume your memory is damaged, use a memory-checking tool to confirm either way.
           
          • MayaMilo

            MayaMilo Intergalactic Tourist

            Heya, so ive been having an issue with custom farm layouts where my game crashes when I step on some parts of my farm, and this happens on a couple layouts, the immersive farm 2 and alis secret forest map too. I think it is a problem with smapi, not sure tho. heres the log: https://log.smapi.io/UvqFwSWr . If anyone could take a look id be very grateful :D
             
            • Entoarox

              Entoarox Oxygen Tank

              The mod in question is not setup properly and is using a tilesheet incorrectly, not SMAPI's fault, but that of the mod itself - contact the mod author to fix it.
               
              • MayaMilo

                MayaMilo Intergalactic Tourist

                Ah oke, that makes sense. ty for the reply <3
                 
                • Zosa

                  Zosa Phantasmal Quasar

                  so is this mod compatible with the beta then?
                   
                  • Entoarox

                    Entoarox Oxygen Tank

                    Which mod? :S
                     
                    • Shrous

                      Shrous Void-Bound Voyager

                      Hello. Okay so I have a problem with the game where everything runs normally but when I look in the smapi loader, it shows that some of the mods I use has an error mainly to do with something called harmony? So I was wondering if you can offer me some advice on fixing this problem because I tried to find information about the error itself, but wherever I look, I can't seem to find a concrete answer to fix the problem.

                      Here's my crash log info:
                      https://log.smapi.io/LRHY12LC.

                      P.s. I'm not actually sure when the problem arised from in the first place? It just showed up one day when I started the game which I'm still able to play by the way.
                       
                      • Pathoschild

                        Pathoschild Cosmos Killer

                        @Shrous That's a conflict due to two mods having different versions of Harmony (probably PyTK/Visualize conflicting with Animal Husbandry). That should be fixed in the upcoming SMAPI 2.6, which enforces a single Harmony version all mods use.
                         
                        • Shrous

                          Shrous Void-Bound Voyager

                          oh okay then sorry if this is like really late, my laptop gets stupid when it comes to notifications so I didn't see that you replied to my comment, but thanks for helping me out on finding whats wrong! It's was really driving me crazy, so I'm glad that my problem is now resolved lol
                           
                          • stadoowiec

                            stadoowiec Space Hobo

                            This happened after latest game (1.3.29) and SMAPI (2.7) update - https://log.smapi.io/pLq9v4Su (I installed them today)
                            So far I've tried reinstalling, veryfing and deleting mods, nothing's been working though :cry::cry:.
                            Please help :3 :3
                             
                            • MouseyPounds

                              MouseyPounds Pangalactic Porcupine

                              That beta just came out this morning and SMAPI has not been updated for it yet.
                               
                                stadoowiec likes this.
                              • YeaButNah

                                YeaButNah Intergalactic Tourist

                                Hi! First time playing with mods and have been trying them out for a few days now. I came up this issue where the game would crash during a save at the end of the day. I rebooted the game and went right away to save just to double-check and it crashed again.
                                Link:https://log.smapi.io/q2CfaYSD
                                I'm not sure if it's mod related (I did see the red text showing missing manifests and such) but I'm more worried about the insta-crashes. Many thanks!
                                 
                                • Entoarox

                                  Entoarox Oxygen Tank

                                  Unfortunately this error is happening inside SDV's own code, so I cannot give you a perfect answer without having tested things myself.
                                  What I can tell you is the *likely* cause.

                                  Namely, that one or more of your schedule editing ContentPatcher mods are conflicting with eachother in some fashion.

                                  I hope that this little info helps you find the answer :)
                                   
                                  • Pathoschild

                                    Pathoschild Cosmos Killer

                                    @YeaButNah The log shows a newer version available for Gus Narrative Overhaul. Does the error still happen if you update that?
                                     
                                    • Selhorys

                                      Selhorys Aquatic Astronaut

                                      Hello,

                                      I am unable to get SMAPI 2.8-beta.2 to work with Stardew Valley v1.3.29 on Windows 10.
                                      I am using a fresh copy of SDV beta, there are no mods installed. When I run the SMAPI installer, a command window pops up for a few seconds and closes it does not install SMAPI.
                                      I have done a manual install for SMAPI and when I run StardewModdingAPI.exe, a command window pops up and closes after a few seconds.

                                      Here is the SMAPI log: https://log.smapi.io/gPQYUyke.
                                      I've already tried uninstalling and reinstalling multiple times. I've used SMAPI 2.7 with SDV v1.3.28 and SMAPI installs and runs fine.
                                       
                                      • Pathoschild

                                        Pathoschild Cosmos Killer

                                        @Selhorys That error means you still have some old SMAPI files. I suggest running the SMAPI installer to fix that (it'll clean up previous versions automatically). Try the latest SMAPI 2.8 beta installer, the issue where it closes after a few seconds for some players should be fixed.

                                        If you want to migrate from SMAPI 2.7 to 2.8 manually, you should delete these files in your game folder: 0Harmony.dll, 0Harmony.pdb, Mono.Cecil.dll, Newtonsoft.Json.dll, and all files starting with StardewModdingAPI. On Linux/Mac only, you should also delete System.Numerics.dll and System.Runtime.Caching.dll. Then reinstall SMAPI 2.8, and it should work fine.
                                         
                                        • moou22

                                          moou22 Orbital Explorer

                                          https://log.smapi.io/grhrjqnm

                                          Crashes on save every time. I tried without smapi and it saved normally. I'm not sure which mod might be doing it, if any. I know I have a bunch of abandoned ones in there that I never deleted, but I've had them for a while and previously had no problems like this. During the attempted save, it sort of freezes, fast-forwards time while the character remains stuck in bed, and the menu opens every few game minutes, which pauses the mess, but closing the menu makes more of the same happen. I originally thought it was the save anywhere mod and deleted that, but before I did, saving in the cave brought on a full freeze at the black 'saving' screen, where it never finished. Whenever I try to sleep to save, smapi puts all kinds of mod-related errors at the end, seemingly different each time, so I can't figure out what the problem is. If it's the game itself, is there a work-around, or is it just a use it without smapi for now type situation?

                                          Thanks in advance!!
                                           

                                          Share This Page