Modding Help Dire Need of Assistance with Modding.

Discussion in 'Starbound Modding' started by SeraphixPrime, Aug 29, 2017.

  1. SeraphixPrime

    SeraphixPrime Big Damn Hero

    Hi Guys, I Love Starbound. I Love Modding but I just can't seem to bring the two together at all. Of the 12 mods I've installed only one is showing up. And as it is its useless.

    I've downloaded my mods, unpacked them and placed them into \giraffe_storage\mods.

    I've made sure that .pak files are in the directly in the mod folder. I've put my packed mods E.G dungeon mods so that the folder containing the metadata is within the folder e.g giraffe_storage\mods\Tubula Rasa\<metadata folder>.

    But nothing. Not a single mod. With the exception of the character creator extender mod, I have the window showing up. But as I say it's useless because my Lucario mod doesn't show up at all. The windows just blank.

    Even my .pak file mods are not showing up...

    I've tried everything. I'm at my wit's end here. It's not like I'm new to modding either. I've modded Skyrim and Fallout extensively. (Not suggesting the fault is not mine, I'm merely saying I have some knowledge on the modding process).

    If someone could just help me figure out what's I'm doing wrong I would greatly appreciate it.

    Also where should race mods be installed?
    I've tried the Lucario mod in the mod folder, I've tried putting it in the config folder of the extended race mod. Nothing works.

    Tubula Rasa does not appear in basic crafting. Bill Cipher has not replaced my Novakids Horse AI. Planets have no new dungeons. All weapons and armor are still vanilla. Absolutely nothing is working for me. Except of course that empty window of the custom race mod. Which at this point only serves to highlight that I'm doing nothing right at this point.

    I've installed Starbound to my desktop. And am running the 32 bit .exe, I've also tried launching from the launcher instead of just clicking the exe. But no success. Been up till 3am trying to get something to work and I'm about to turn in after an absolutely fruitless night.

    Thanks For Your Time reading this. Again any help would be appreciated. Im a desperate Novakid here.
  2. bk3k

    bk3k Oxygen Tank

    Wow. I don't mean to make fun, but there are VERY big clues that you're doing this wrong. The install folder no longer includes a giraffe_storage folder at all (so you had to add it) and hasn't for a very long time. It currently DOES have storage and mods. Those should have been very big clues that you are following extremely outdated information.

    Anyhow to cut to the point - all your mods go into \starbound\mods\ and race mods are no different than any other. Don't use the 32bit starbound.exe unless you literally cannot use the 64 bit starbound.exe (because you have an ancient 32 bit system).
  3. SeraphixPrime

    SeraphixPrime Big Damn Hero

    Ah. I Feel a fool. Thank You helping diminish my ignorance Good Sir. Extreme Thanks for the assist. Will attempt when home from work and will inform you of my success (hopefully).

    Much appreciated.
  4. SeraphixPrime

    SeraphixPrime Big Damn Hero

    Hi there thanks for the assist. Turns out my version of Starbound was ancient.

    Got the latest patch, and SUCCESS. Everythings working Perfectly.

    The clue was, I actually did not add the giraffe_storage file myself, seeing your post it all clicked.
    Thanks Again man.

Share This Page