1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/
  2. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Resolved Crash when activating ancient gate console

Discussion in 'Support' started by Jimbob767, Jul 29, 2016.

  1. tuliomir

    tuliomir Void-Bound Voyager

    I also confirm this works! Sad not to see an official response from the devs, but it's a viable workaround!
     
  2. A Fat Lunchlady

    A Fat Lunchlady Space Hobo

  3. Islid

    Islid Scruffy Nerf-Herder

    This also appears to happen if you try to open up the sign-making interface, the little stall just to the west of the Frogg furniture store on the second floor. Closing the sign interface causes the crash.
     
  4. alaisl

    alaisl Void-Bound Voyager


    Tried this one out. Works wonderfully!
     
  5. stop68

    stop68 Space Spelunker

    So I launch the dedicated server, whenever I try to load up Starbound after this, Steam says that the game is already running. I'm sorry that I am kinda a noob to this but any help would be appreciated. Thanks! :)
     
  6. alaisl

    alaisl Void-Bound Voyager

    Seems there's quite a number of bugs in the outpost right now.
     
  7. claan22

    claan22 Space Hobo

    Launch the dedicated server directly (not from Steam). It probably lives in "/Users/YOUR_NAME/Library/Application Support/Steam/steamapps/common/Starbound/osx". The file to run is the shell script, run_server.sh. Then you can run the game normally from Steam and join the dedicated server.
     
  8. AlexKockica

    AlexKockica Void-Bound Voyager

    +1 for @Corractal's fix

    still have problems with other stuff in Outpost causing crashes.. :/
     
  9. The Squid

    The Squid Oxygen Tank

    So I launched the server and cleared my mods folder, but I'm still unable to connect using localhost as the IP. Can somebody please help? This is the message I'm getting
    Screen Shot 2016-07-31 at 10.04.20 AM.jpg
     
  10. Corractal

    Corractal Space Hobo

    If this is happening, try completely quitting steam - this will end any steam processes for sure - then load back up, launch the dedicated server first, and try again. If that doesn't work I imagine claan22's fix might be valid, navigating to "/Users/YOUR_NAME/Library/Application Support/Steam/steamapps/common/Starbound/osx" and launching the run_server.sh file.

    Can you copy and paste the log from your server command prompt window so we could take a look on what the server is seeing?


    Also - good to see the fix is working for everyone. I imagine you can get around the rest of the issues in the outpost in a similar fashion - at least for the tech station, the fix I saw working was to do the same steps with the dedicated server that I mentioned in my previous post, then open the tech station, equip all tech you want, then use the "beam back to ship" button on the righthand side of your screen. It'll still crash your game, but when you load into singleplayer after you'll have the tech you want equipped. I personally haven't tested this (because I don't have any tech on my new character yet) but it seems like it would work with the same logic as the gate (let me know if this isn't the case).

    It's possible that the dedicated server approach could be a viable workaround to many issues, apart from if there are ones that crash immediately upon interaction (just pressing e). Haven't tried with Rob Repairo but I know you can interact with the window at least, it's just closing it that crashes you so I imagine applying the same methodology of accessing Rob on a dedicated server and then crashing and loading back into singleplayer might work.
     
  11. The Squid

    The Squid Oxygen Tank


    #!/bin/sh -e

    cd "`dirname \"$0\"`"

    osascript <<END

    tell application "Terminal"
    do script "cd \"`pwd`\";./starbound_server $@;exit"
    end tell

    END

     
  12. Corractal

    Corractal Space Hobo

    Err - sorry, was looking for a screenshot/pastebin of this window:
    [​IMG]
     
    The Squid likes this.
  13. Hedonic

    Hedonic Space Hobo

    Legit fix, no /admin needed. Thank you!
     
  14. The Squid

    The Squid Oxygen Tank

    Ah, my bad. 1 sec
     
  15. bouche

    bouche Seal Broken

    I have the same problem with latest Starbound on Mac running Sierra 10.12 beta 3. I thought that my problem was because I was running beta OS, but apparently not. I followed Corractal's workaround, and that worked. THANKS! however, I also crashed after clicking the 'X' in one of the interaction windows along the way through the new zone.
     
  16. DesVoeux

    DesVoeux Master Chief

    Same problem on a brand new iMac. Waited until 1.0 was out to buy Starbound for my daughter and then this happens. Hope it's fixed soon.
     
  17. The Squid

    The Squid Oxygen Tank

    My guess is that this will be fixed either on Monday or Tuesday. The developers probably were taking the weekend off and just weren't aware of the problem.
     
  18. soroga

    soroga Void-Bound Voyager

    Darn this is a problem isn't it?
     
  19. Sporkenmier

    Sporkenmier Void-Bound Voyager

    In case the floods of posts don't trigger a red flag to the Gate Portal crash, I am ALSO having the same issue. (MAC OS Yos. 10.10.5) It's a desktop, if that has any merit.

    The dedicated server work around doesn't seem to be working for me, it won't let me connect to my own system, so there are probably some settings I need to tweek, but I think i'd rather wait for the fix to come officially. I will say this...I have a ton of materials, including one Diamond I found when I was farming Core Fragments. Enough housing mats to make a small village and I found mod upgrades to collect liquids and do some painting :3

    -It's all about the silver linings, folks-

    I will sit patiently over here and wait for that fix :D *cheers Chucklefish on*
     
    Jimbob767 and Ed_SNEWBELL like this.
  20. subcide

    subcide Space Hobo

    +1 from me too. Playing vanilla Starbound on a macbook pro. The txt file with console commands to complete the quest worked to at least allow me to progress past the initial tutorial stuff and access multiple worlds and a few more quests, but as others have said, there's very similar crashes when interacting with other stuff at the outpost, the tech upgrades being the major one. Hopefully they get onto fixing this soon.

    The thing that wasn't obvious for me with the console commands is that it looked like I needed to type /admin first to allow console commands, but THEN type /admin again, otherwise you're in god mode. Didn't figure this out until half way through the next major mission.
     

Share This Page