1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Resolved Crash when activating ancient gate console

Discussion in 'Starbound Support' started by Jimbob767, Jul 29, 2016.

  1. The Squid

    The Squid Oxygen Tank

    Any of the devs say something about this yet? Because chances are this problem is occurring on all Macs.
     
  2. mhhv

    mhhv Space Hobo

    Same problem here

    Running:

    OSX EL Capitan 10.11.6
    IMAC Mid-2011

    Crashing to desktop when activating ancient gate console
    Crash to desktop if I press ESC when the gate popup shows
     

    Attached Files:

  3. Dezalien

    Dezalien Space Hobo

    +1 having same issue :(
     
  4. 19alicat74

    19alicat74 Intergalactic Tourist


    Similar crash happens when finishing the fossil dig mini game, win or lose.
     
  5. Hedonic

    Hedonic Space Hobo

    There's a grip of issues, welcome to the launch party!
    --- Post updated ---
    I tried several times in both stable and unstable. Just to clarify for any devs or players sake you can initially use the gate panel but activating or exiting the panel, with or without core fragments, will crash on basically any OS X system. I know the alternate windows game saving option exists, but I'll wait it out because I have no friends because I play games like Starbound :D
     
  6. InvaderLen

    InvaderLen Space Hobo

    Also having this issue. I'm able to get through the gate on multiplayer, but as for single player, I'm stuck. Interacting with the activation window at all causes the game to crash. I'm new to this game, so I guess I'll just improve the planet I started on while I wait for a fix.
     
  7. skajeff

    skajeff Space Spelunker

    [STEAM] Crash when attempting to use the ancient gate during the “Getting Started” quest at the “-Use the Core Fragments to activate the Gate” step.

    OS Version: Mac OS X 10.11.6 (15G31)
    Mac Model: iMac13,2, BootROM IM131.010A.B09, 4 processors, Intel Core i7, 3.4 GHz, 8 GB, SMC 2.11f14
    Fullscreen/Windowed: BOTH

    After collecting the 20 Core Fragments, attempting to use the ancient gate portal crashes the game. Able to replicate this issue 100% and is a blocker for me furthering the main questline. Attached log as requested.
     

    Attached Files:

  8. PAHNKAPIE

    PAHNKAPIE Space Hobo

    I have the same exact problem, same OS only on Macbook Pro. Is this going to be patched anytime soon?
     
  9. drefined

    drefined Space Hobo

    I just skipped the gateway activation by teleporting using admin mode and then turning it off once I've teleported. I do this only once I've gathered the core frags and going to the gate (don't touch/interact with the console) so "I'm not cheating", this way I can progress in the game.

    Note: Type in the commands as if you were chatting with someone. Press <enter> then type, one command at a time.

    Code:
    /admin
    /warp InstanceWorld:outpost:-:-
    /admin
    If you're wondering where the warp takes you, it's close to where you should be after the gate activation.

    Good luck. :)
     
    Last edited: Jul 31, 2016
    andi242, Hedonic and The Squid like this.
  10. primeval15429

    primeval15429 Void-Bound Voyager

    I am having the exact same issue and I emailed the developers and they didn't repond
    --- Post updated ---
    the devs could at least tell us what is going on and when they plan on fixing this
     
    The Squid likes this.
  11. A Fat Lunchlady

    A Fat Lunchlady Space Hobo

    Yep same problem. Mac user.
     
  12. Hedonic

    Hedonic Space Hobo

    I've been wantng to try this, does the quest update upon arriving and is progression in the main story still possible?
     
  13. claan22

    claan22 Space Hobo

    This is also the same problem mentioned in this thread: http://community.playstarbound.com/threads/fatal-crash-on-mac.120479/

    Worth noting that it seems to happen in other places too, including when you X out of the Tech Machine at the Outpost.

    If anyone's looking for workarounds, I was able to work around it by doing co-op, even with 2 players on Mac OS X. My partner activated it for 20 core fragments, and promptly crashed. But my game still worked, and I was able to go through the portal.
     
  14. A Fat Lunchlady

    A Fat Lunchlady Space Hobo

    i was able to get past the problem with the chat solution Drefined made, but I can't seem to finish the mission from there. Any suggestions?
     
  15. drefined

    drefined Space Hobo

    I was able to continue progressing in the story, walk all the way east until you hit Esther, from there it's up to you to figure it out. ;)
     
    The Squid and Hedonic like this.
  16. A Fat Lunchlady

    A Fat Lunchlady Space Hobo

  17. ccwoodside

    ccwoodside Space Hobo

    i'm on 10.11.6 and am having the same problem.
     
  18. Corractal

    Corractal Space Hobo

    For anyone trying to workaround the gate activation bug (whether with admin warping or anything else), I ran into the same problem of not being able to advance the quest.
    Here is how I got around it:

    Close all instances of Starbound/Dedicated Server

    Launch Dedicated Server, let the console fully load.

    After it's loaded, just minimize the window and leave it running.

    Then, load up Starbound, hit "Join Server", and for server ip simply type "localhost".

    If you cannot connect for the server clear out your mods folder and try again (ApplicationSupport/Steam/steamapps/workshop/content/211820).

    Once connected simply activate the portal like you would in singleplayer. The game will crash, however once you load back up and join into your single player world, not into the dedicated server again, the gate will be activated and you can use it to teleport to the outpost.

    Happy exploring!
     
  19. skajeff

    skajeff Space Spelunker

    Can confirm, Corractal's workaround helps get pass the gate activation bug. Thanks!
     
  20. Kitsunestudios

    Kitsunestudios Intergalactic Tourist

    Also having this bug as of 1.0.3. MacOS X as well.
    Corractal's work-around did the trick.
    Reported another bug with the Outpost's Tech Station causing a CTD when pressing "esc" to leave the menu.
     

Share This Page