1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Crash on loading previous save!

Discussion in 'Support' started by nir, Oct 8, 2016.

  1. nir

    nir Void-Bound Voyager

    Ever since 1.1, I've been dreading to launch my game. I launched it the day of release to play, when I realized that my GetDressed mod wasn't appearing on my characters load option. That was fear #1. Upon attempting to load said file, I noticed that my API window had a million pop ups coming in red, so I shut it down immediately. Went to the Mod forum, deleted any mods that I had in my folder that weren't working with 1.1, updated two of them, and tried to go back in. GetDressed still wasn't showing up on my file save, tried to launch and just got to the black loading screen only for it to crash.

    EDIT: Can't make a new game either. I'm nervous no one is really watching the support forums, since after browsing I've seen around 3 or 4 other topics with the same thing happening but no responses.
      Last edited: Oct 8, 2016
    • Ladysarajane

      Ladysarajane Existential Complex

      Sometimes it takes awhile for people to be on. Also if you read other topics and there was a post with suggestions on what to do. You are also trying to run a modded Stardew, and a more appropriate place to get help would be in the Modded section. Saying it crashes doesn't help very much. This support section is mainly for vanilla Stardew.

      1st suggestion: You should have tried to Post a log as described in this Post http://community.playstarbound.com/threads/dos-and-donts-of-reporting-issues-with-smapi-mods.125211/
      That is the biggest thing.

      2nd suggestion:Make sure mods are cleared out of both mod folders. Some may be in the Steam folder under stardew valley and sometimes they sneak in on %appdata%/roaming/stardewvalley/mods

      3rd suggestion: In the %appdata%/stardewvalley/ folder there should be a file called startup_preferences delete that. Then verify file integrity. Basically this is reinstalling Stardew valley. It checks for original files and if they are altered replaces them. This is done in Steam. Then try to start a new game in vanilla Stardew (not with Smapi), see if it runs. It shouldn't crash. If it doesn't run then post the Log as described above with a descriptive problem. If you can start a new game file, then go to Smapi and delete that file and download the latest which would be version 40.1.1-3 http://community.playstarbound.com/threads/stardew-modding-api-0-40-1-1.108375/

      Then try to run the new game file in Smapi, and if that works go to the mods section and look up your mod the GetDressed one and download the version for the 1.11 Stardew Valley (I know it has been updated). I also know there is a glitch with it and the 3rd house upgrade with the dresser not showing. I don't know if they put an update for that yet. If your saved game doesn't work with that back in, then post in that topic the error log. I really don't know if your old save will run without the mod in it. You may have to wait for them to get an update out if you have the 3rd house upgrade. I know they were working on it.

      I know it is frustrating when your game doesn't run. It is equally frustrating for people who do try to help to keep seeing posts on the same thing...HELP my game won't start and there is nothing to go on in the post on when it stops running in the process. That is were the logs come in. Someone can try to see where it stopped in the process. One good thing you did is to post that you did have mods in it.
      • nir

        nir Void-Bound Voyager

        Thank you for responding! I apologize if I sounded irrate when posting, I was just very worried about having to start up a new game. I didn't mean for it to sound harsh or anything. I'm fairly new with modding.. :cry: As for the posting location, since I didn't find anything but mods themselves a page or two into the Modded section. When I mentioned seeing a few other topics with the same problems, I meant they too didn't have anything posted in them. I sadly missed the topics that did have responses, but thank you for linking them!

        With the first suggestion, I've attached the program log. Second, the roaming mod is empty. Unsure if the log is needed since with the third suggestion, the game did run (without SMAPI). I went back to attempt to launch again with SMAPI, but it crashes upon the loading screen again after creating a new game or loading an previous game.

          Attached Files:

        • Ladysarajane

          Ladysarajane Existential Complex

          That is okay. People don't realize that some of us are just other gamers trying to help out someone. First off. Smapi is two versions out. There was some minor bug fixes to it. It should be listed as SMAPI Version: 0.40.0 1.1-3. Update it. It is also still trying to load mods from somewhere and a lot of them.
          Mod List:
          Calendar anywhere is not a problem. It runs fine for me.
          GetDressed..make sure it is the newest one. It should run unless you have the house with the basement. They are working on that update. You did get the lastest version for 1.11?
          GiftTasteHelper should be fine.
          LovedLabels...has been updated http://www.nexusmods.com/stardewvalley/mods/279/?
          SimpleCropLabels....delete it. It is not compatible. It maybe one of the reasons it won't load. There is no update for that.
          CBJ Show item price should be okay. I am running that just fine.
          NPC Locations has that been updated too? There was a new version of that for 1.11. The old version would keep Stardew from running.

          So update Smapi to
          Update GetDressed, LovedLabels, NPC Locations and delete Simple Crop Label.
          See what that does. If it works then to replace Simple Crop Label, I started a using a mod called LookupAnything by Pathoschild http://community.playstarbound.com/threads/smapi-lookup-anything.122929/ I've gotten addicted to hitting F1 to see everything :)
          If these steps don't work then repost the log again. I will be on tomorrow morning.

          Here is a topic that may help you with links and Mods that are now current with 1.11 http://community.playstarbound.com/threads/happy-farmers-v1-11-working-mod-list.125144/
          Of course some people have reported others working that haven't made it on that list. You just need to check to find them.
            fftljoe and nir like this.
          • nir

            nir Void-Bound Voyager

            I had updated the SMAPI after sending the program log, oops! I updated GetDressed again just in case, updated LovedLabels, removed SimpleCropLavels, and added LookupAnything. Aaannnddd.. it works! :chrono:
            Thank you sooo much for your help! It really means a lot!
              Ladysarajane likes this.
            • Ladysarajane

              Ladysarajane Existential Complex

              You are welcome! That is why I ask for logs. Sometimes they give me clues to problems. :)

              Share This Page