1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Bug/Issue Crash on launch Steam version w/no dialog (64 bit)(windows 10)

Discussion in 'Support' started by AktivX, Sep 2, 2017.

  1. AktivX

    AktivX Space Hobo

    So I've owned this game for all of 48 hours at this point, and for the life of me I can't get the game to run. I've tried everything in the help thread, scoured the forums, did everything it said in the threads on steam, on Reddit even sketchy forums in other areas, and nothing has worked. Here's the skinny per the suggested posting rules for bugs.

    1. The crash happens every time on both my Desktop and my laptop. I've reinstalled both the regular and unstable clients a dozen times each to be sure.

    2.Running in compatibility mode (I did this for literally everything that could be set as such) and as administrator does nothing.

    3.A lot of the suggestions for fixing the issue no longer seem to apply, referencing things that don't exist in my folders like a launcher program. The Help thread also mentions that the log file for windows is in the Starbound directory when it is, in fact, showing up in the Storage directory for me.

    4. On my desktop I'm running Windows 10 pro 64 bit, with an fx6300 amd processor and a R9 390 8gb video card and 16gb ram. On my laptop I'm running windows 10 home 64 bit on an amd a8 processor with an r5 on board video.

    5. Running in 64 bit mode causes it to instantly open and close a window without anything else appearing. Running in 32 bit gives me the error window that'll be included at the bottom of this post.

    6. I am using no mods. This is a fresh install (well the 12th fresh install so far). I've downloaded no mods and have not even ever logged into the game successfully.

    Methods tried to fix so far

    1.uninstalling/reinstalling

    2. reinstalling/repairing c++ runtime 2015

    3. Run the game in all possible combinations of Administrator mode, compatibility, no overlay, disabling fullscreen optimizations, overriding DPI scaling behavior

    4. run compatibility tool for windows

    5. reinstalled video drivers on both machines.

    As for reproducing the bug I think I can confirm that I've reproduced the bug about 40 or 50 times now. I can't tell if it's full screen or windowed because I haven't actually gotten to run it yet, so it could be either. Capture.PNG
     

    Attached Files:

  2. Iris Blanche

    Iris Blanche The void Forum Moderator

    On your desktop machine: do you have an onboard chip there too? If yes is starbound set to use the dedicated GPU instead?

    I have seen this message a lot before but atm i have no solution for it. However it *seems* to only affect machines with an onboard chip when the game is using the chip. To be a bit more specific it seems to fail in the step detecting the right texture size.
    The functions "wglCopyContext" and "wglSwapBuffers" in the stack trace are both OpenGL functions for windows and it seems that something with them is failing or that they can't get the necessary information from the hardware.

    ~ Iris ~
     
  3. AktivX

    AktivX Space Hobo

    Negative. It's a gigabyte gaming board so No on board video on the desktop, and the Laptop is an APU so the gpu is part of the CPU
     
  4. AktivX

    AktivX Space Hobo

    Here's a copy of the log from the desktop so you can see if there are any discrepancies between the two
     

    Attached Files:

  5. AktivX

    AktivX Space Hobo

    Bump to keep fresh. Still no solution yet.
     
  6. AktivX

    AktivX Space Hobo

    Nothin? almost 500 views and all I got is one person who can't help? Has nobody any ideas?
     
  7. UltimateCatTree

    UltimateCatTree Intergalactic Tourist

    Having this same exact error dude. Dunno what's going wrong. 64 bit crashes upon startup and 32bit gives me that exact error message. I made a dump file but I cant upload it here.

    Specs:
    AMD FX 4350 Black
    ASRock 970M Pro3
    Dual Crossfire Gigabyte Radeon RX 460
    32 gb Corsair Vengeance DDR3L ram
     
  8. UltimateCatTree

    UltimateCatTree Intergalactic Tourist

    Here's my log
     

    Attached Files:

  9. AktivX

    AktivX Space Hobo

    Yours seems to be a different issue somewhere. Your game seems to crash once it gets to the point where it's generating names, mine fails several steps before that when it tries to render the game. We'll figure this out, I hope.
     
  10. AktivX

    AktivX Space Hobo

    bumping. Still no solution, still no contact.
     
  11. RvLesh

    RvLesh Spaceman Spiff

    -Ensure you're using the most recent drivers (straight from the AMD website) on both machines.
    -If you're running raptr/"AMD Gaming Evolved", close them before playing.
    -Disable the Steam in-game overlay

    -If all else fails, look up a WinDBG tutorial, and try and determine what specific DLL is being called (all those blank entries in the stack trace) when it crashes. I've seen Starbound crash due to a lot of software that injects itself into other applications.
     
  12. AktivX

    AktivX Space Hobo

    Found the solution, at least as far as on my laptop, though I think this might fix my issues with my desktop as well. It both wasn/wasn't a driver issue. It wasn't until I clicked the button to reset my graphics card settings to factory defaults that it started working again. I went back to changing stuff one at a time to see if was any particular setting and I found the culprit. OpenGL triple buffering is what did it. If I disable that, the game works, albeit at about 17fps, but it's working and that's a step in the right direction
     
    RvLesh likes this.
  13. AktivX

    AktivX Space Hobo

    Same thing worked on Desktop. Issue resolved except for framerate issues
     
  14. RvLesh

    RvLesh Spaceman Spiff

    Thanks for actually returning to tell everyone your solution. Most people don't for some reason.
     

Share This Page