1. If you're looking for help-related things (for example, the key rebinding tutorial), please check the FAQ and Q&A forum! A lot of the stickies from this forum have been moved there to clean up space.
    Dismiss Notice

Feedback Compatibility mode messes up the game tickrate

Discussion in 'Starbound Discussion' started by Lekrashar, Jul 5, 2019.

  1. Lekrashar

    Lekrashar Void-Bound Voyager

    Hello there!
    Starbound with a compatibility set causes a big frame drop that makes the game unplayable for me (server tick goes nuts, render fps goes nuts, world fidelity is low to rarely medium, blah blah blah)

    Since 1.4.0 (I insist, 1.4.0, not 1.4.2), I've got a big framerate drop and some worlds just got with a lot of delay for entities, the outpost was running at 24 framerate at zoom x4 and as soon as I opened my inventory my framerate dropped by at least 15.

    One of my friend discovered that unchecking the compatibility mode fixed it (and told me that the game was never that smooth for him). I'm mostly writing this so you can try it on your side if you've got issues.

    The compatibility mode was set to windows 7 and we both were on windows 10. I've heard that some peeps got issues with compatibility while on older windows so it has to be looked at!

    Oh and it MAY be checked by default too. My friend tried a clean install.

    TL DR; uncheck compat mode on the properties. the game may get way smoother for you.

    I hope it fixes issues if you have those and sorry for ma bad English~
     

Share This Page