1. When making a thread, please tag your thread accordingly using the menu to the left of the textfield where you name your thread where applicable. Server Advertisements and Mod Releases should be contained to their respective subforums.

Server Discussion CommandStar: Real-Time Chat, Online Players, and Server Status

Discussion in 'Multiplayer' started by Seriallos, Dec 15, 2013.

  1. Seriallos

    Seriallos Space Penguin Leader

    Made a few changes to the master branch of the repo tonight (not a full release - you have to clone from GitHub to get these)
    • Configurable max chat messages to keep (maxRecentChatMessages)
      • Large servers generate a LOT of chat. This should keep memory consumption and initial page load under control for now.
    • Show max player count in player list (e.g., 4/8 if 4 players are online with a server to maxPlayers of 8)
    • Running the Windows runServer.bat as Administrator should now work.
     
  2. wolvern

    wolvern Orbital Explorer

    btw.... just did a heap of digging on node..... install V.10.22 for windows.... .23 is BUGGED..... found that to be the problem with calling it on windows

    @Mechrior

    also updated the bat file

    @cd "c:\program files\nodejs\"

    call npm install

    @IF EXIST "%~dp0\node.exe" (
    "%~dp0\node.exe" "node_modules\coffee-script\bin\coffee" server.coffee
    ) ELSE (
    node "node_modules\coffee-script\bin\coffee" server.coffee
    )
    PAUSE
     
    Last edited: Dec 19, 2013
  3. NakashimaKun

    NakashimaKun Pangalactic Porcupine

    Heh, You sneaky person you added some of the features I asked for... :D Good man. I have some more if you wanna add them hahaha xD
     
  4. germyliok

    germyliok Intergalactic Tourist

    I had updated node. What should I do now? sorry for silly questions, lol.
    Code:
    german@Germyliok-PC ~/commandstar $ ./runServer.sh
    npm WARN package.json commandstar@0.1.2 No repository field.
    npm WARN package.json node-hipchat@0.2.0 'repositories' (plural) Not supported.
    npm WARN package.json Please pick one as the 'repository' field
    
     
  5. supernet2

    supernet2 Existential Complex

  6. ellbristow

    ellbristow Space Hobo

    I'm trying to get CommandStar to run as a service/upstart but for some reason I'm drawing a blank.

    I have starbound running as a service and tried to add commandstar to the same service... no luck, so I switched to upstart.

    Here's what I have so far in /etc/init/commandstar.conf :

    Code:
    description "CommandStar Ellitopia Wrapper"
    author "ellbristow"
    
    start on starting starbound
    stop on starting shutdown
    
    console none
    
    script
            cd ~/commandstar
            ./runServer.sh
    end script
    
    respawn
    
    If I run runServer manually it runs fine, but forces me to keep the console open. Running "sudo start commandstar" does seem to launch the upstart, but immediately stops it again (status shows it as stop/waiting)

    What am I doing wrong? Any help welcome!
     
  7. DarkOS

    DarkOS Big Damn Hero

    running on win server 2008 r2 64 bit. works great. thanks for this!
     
  8. Endimmion

    Endimmion Big Damn Hero

    Support for CommandStar has been added on Starbound-Servers.net (as you can see in DarkOS signature :) )
     
  9. TheOtherDrew

    TheOtherDrew Big Damn Hero

    @Seriallos thank you for working on this status page.

    I am running ubuntu 12.04.3 server install.

    I am running as root user on my server at the house, since I don't need any real security.

    I installed as per your instructions but had dependency issues along the way, so I went ahead and installed everything that was missing to try and get started.
    Now I'm stuck with this error.
    Code:
    root@SERVER:~/commandstar# ./runServer.sh
    TypeError: Cannot read property 'binPath' of undefined
      at Object.<anonymous> (/root/commandstar/server.coffee:29:28, <js>:43:30)
      at Object.<anonymous> (/root/commandstar/server.coffee:1:1, <js>:310:4)
      at Module._compile (module.js:441:26)
    
    Here is my config file called SERVER.yaml

    Code:
    serverName: "iplaystarbound.com 24/7 Vanilla"
    
    # Port for web server
    # If you use port 80, you'll need to run server.coffee using sudo.
    # This isn't super secure right now so be warned.
    
    listenPort: 8080
    
    maxRecentChatMessages: 100
    
    starbound:
      binPath: "/home/steam/Steam/SteamApps/common/Starbound/linux64"
      assetsPath: "/home/steam/Steam/SteamApps/common/Starbound/assets"
      dataPath: "/home/steam/Steam/SteamApps/common/Starbound/universe"
      logFile: "/home/steam/Steam/SteamApps/common/Starbound/linux64/starbound_server.log"
      configFile: "/home/steam/Steam/SteamApps/common/Starbound/linux64/starbound.config"
    
    # Use something like this for Windows instead of the above lines
    #
    #  binPath: C:\Games\Steam\SteamApps\common\Starbound\win32
    #  assetsPath: C:\Games\Steam\SteamApps\common\Starbound\assets
    #  dataPath: C:\Games\Steam\SteamApps\common\Starbound\universe
    #  logFile: C:\Games\Steam\SteamApps\common\Starbound\starbound_server.log
    #  configFile: C:\Games\Steam\SteamApps\common\Starbound\starbound.config
    
    # Default hipchat configs
    # To enable, you'll need to set the hipchat.token configuration to your API key
    # This is only for relaying in-game chat to a HipChat room.  The web chat
    # works without this.
    # This REQUIRES a version 1 token
    # For more info, check out their website: https://www.hipchat.com/
    
    I commented out all the Hipchat lines since I won't be using that, but I did try without commenting out first.
    I also tried without double quotes around my paths. Still won't work. Not really sure what the issue is.

    I know all the blah blah about running as root, I'm not concerned, unless of course running as root is the issue.
    However I installed the server via these instructions. -> DeMossiah
    Thank you for your time.
     
  10. greglgomez

    greglgomez Scruffy Nerf-Herder

    Has anyone else tried this with any success wondering if it's worth doing..
     
  11. FuzzyThor

    FuzzyThor Existential Complex

    I am not sure if this was asked. But is there going to be a way we can chat with the people in the game with hipchat. And also maybe using irc as an alternative to hipchat.
     
  12. Seriallos

    Seriallos Space Penguin Leader

    Can you PM or post some more details of the problems you were running into? Output from the runServer.bat command would be helpful as well as what version of Windows you are running.
     
  13. Seriallos

    Seriallos Space Penguin Leader

    If you're on windows, you need to double click runServer.bat, not runServer.sh. If that doesn't solve your issue, post back and I'll try to help.
     
  14. Seriallos

    Seriallos Space Penguin Leader

    I'm still being lazy and just run it in a screen session right now... But I'll look at writing some docs on building upstart/init.d scripts at some point.

    If anyone else has already written, please post it here or on the GitHub page. At some point I'll build out the wiki on the GitHub site with info like this.
     
  15. Seriallos

    Seriallos Space Penguin Leader

    Make sure the name of your YAML file is the same as the hostname of the machine you're running on.

    For example, this is from my demo server:

    Code:
    seriallos@betastar: /opt/commandstar master
    $ hostname
    betastar
    
    seriallos@betastar: /opt/commandstar master
    $ ls -1 config
    betastar.yaml
    default.yaml
    runtime.json
    
    I'll try to write up some better documentation of the config system to help with this.
     
  16. Seriallos

    Seriallos Space Penguin Leader

    I'll look to see if there's a simple way to relay chat to IRC. I suspect there are good libraries already out there that I can use.

    For getting chat into the game, there are other folks on this forum who are working on reverse engineering that system. If they are either to successfully get that working and/or Chucklefish adds an API to do it, it will definitely be something I look into implementing.
     
  17. Seriallos

    Seriallos Space Penguin Leader

    Awesome!
     
  18. Mortalsinn

    Mortalsinn Zero Gravity Genie

    Love this! I am using it over at www.world8-4.ca as well

    One small request - can you make it ignore /w so it's not showing private chat? kind of defeats the purpose of private chat.
     
  19. TheOtherDrew

    TheOtherDrew Big Damn Hero

    The reason that seemed to work for me is because of the slow disk IO on VPS I have. I placed the assets in there and it cleared up the slow asset warnings I was getting in logs, and seems to allow the server to read from the asset files fast enough to process the info without lagging the server too bad. If you don't include the music or sfx folders its something like 100mb ish so its not much ram used up. Good luck.
     
  20. Seriallos

    Seriallos Space Penguin Leader

    True story: I didn't even realize Starbound had /w until today. I'm planning on patching the code to ignore all slash commands in the next couple of days.
     

Share This Page