1. Note: Nightly builds are not officially supported and things that appear broken might actually just be broken with no way of fixing it, but community members may still be willing to assist you with common problems.

Tutorial Collection of Admin Codes for Nightly Build

Discussion in 'Nightly Builds Support' started by SivCorp, Jun 17, 2014.

  1. Wictim

    Wictim Void-Bound Voyager

    When this forum was down I tried to figure out this on my own. I chose probably the hardest way to do it, but I achieved what I wanted.
    There is a post on Starbound reddit about this named "Spawning items in-game with any specs and looks aka /spawnitem as a powerful tool" which I wrote about this. (sadly I can't post links yet)
    Hope it helps.
    Last edited: Dec 15, 2015
    MysticMalevolence likes this.
  2. Duck Powers

    Duck Powers Space Spelunker

    i still dont get it! i put in /aiaction {"action" : "showTech", "techName" : ["rocketboots"]} but i still get zilch
  3. Owl_Stalker

    Owl_Stalker Guest

    Are you in admin mode? What exactly is the error you get?
  4. Dunto

    Dunto Guest

    You need single quotes around the whole last part: /aiaction '{"action" : "showTech", "techName" : ["rocketboots"]}'
    That way the whole thing gets passed in as one argument.
  5. MyNameIsJeff228

    MyNameIsJeff228 Void-Bound Voyager

    /spawnitem shipT1(1 to 8)
  6. Sean10M

    Sean10M Scruffy Nerf-Herder

    Not a good idea to do that. Skipping the ship tire quests can mess up a number of other things.
  7. Awbawlisk

    Awbawlisk Phantasmal Quasar

    Is there a way for me to use the /aiaction command to actually reveal a mission? Like say, I want to be able to visit the Lunarbase right away (Even though in this case, the game cheated me and did not give me the Lunar Mission in the Missions Tab and therefore, I'm stuck.)
  8. Sean10M

    Sean10M Scruffy Nerf-Herder

    Not as far as I'm aware but you could spawn the items needed for the quests leading up to the missions. That's what I have often done.
  9. Awbawlisk

    Awbawlisk Phantasmal Quasar

    I don't know what you're talking about?? Without any way of being able to do the first mission, I won't be able to progress any further and unlock any of the further quests, as well as be unable to upgrade my ship. The fact that the Steel Armor mission had failed to show the mission on my SAIL, YET give me the tech necessary to explore the said mission dungeon, it has ultimately rendered me stuck and unable to progress PERIOD.


    I suppose I just have to do some high-level cheating and just forget about progressing like normal and just reach the end and obtain any other shit I need by giving myself those upgrades <_>
  10. Owl_Stalker

    Owl_Stalker Guest

    /warp instanceworld:lunarbase:[your UUID]

    Your UUID is accessible by looking in ../giraffe_storage/player/. Your UUID should be the name of your .player and .shipworld files. If you have multiple different UUIDs, use the most recent one.

    An example would look like this:

    /warp instanceworld:lunarbase:388919abf9022219304154562464abbe

    Red is the command, yellow is the world type, cyan is the world ID, orange is your UUID, and green is the colons.
  11. Awbawlisk

    Awbawlisk Phantasmal Quasar

    Thank you for your help! Unfortunately for me, because I don't have the quest in my list of quests to do, and have absolutely no way of obtaining the missing quest, I'm forever rendered stuck ;-;
  12. Owl_Stalker

    Owl_Stalker Guest

    I think I'm missing something here. What is the exact problem here?
  13. Awbawlisk

    Awbawlisk Phantasmal Quasar

    You know how when you first go to the outposts and complete the first quest there that deals with the iron crafting table? Well, once thats done, you then gain access next main quest, which is the quest where you need to craft a set of steel armor to complete it. Once you complete the quest, you get access to the coordinates to the first mission, the lunar base, AS WELL AS, obtain a QUEST that informs you that you must GO to the lunar base.

    ...And that said quest, unlocks the NEXT branch of the main quests right after it. The problem is, I was SUPPOSE to be given that quest I just finished mentioning, but script screwed itself and didn't grant me the quest. I don't even have the coordinates for it either, and while I could just use the /warp command to get there, it just doesn't matter if you don't have the QUEST.

    See the problem?
  14. Owl_Stalker

    Owl_Stalker Guest

    Well, you could possibly mod in a new NPC type that gives the quest that you're missing, and that could solve your issue.

    If you'd like to know how to do that, I'm recommend sending a PM to me (or someone else experienced with modding), since that's not necessarily on this thread's topic.
  15. btmarcher

    btmarcher Scruffy Nerf-Herder

    So I'm having the same issue here but I actually have the quest in my journal. I tried using your suggestion and I'm still just beaming right back into my ship when using my UUID where you said to find it. I have no issue cheating to move forward but it would be nice to have a workaround for this and other quests that are broken at the moment.

    tried this too, just got a Thing (literally, that's what it's called and it does nothing that I can tell)

    Also tried enabling the Ship Upgrade option like we have to for the Matter Manipulator ATM and opening the dialogue box caused the game to crash. Just wanted to say in case other people wanted to try this.
    Last edited: Jan 8, 2016
  16. Owl_Stalker

    Owl_Stalker Guest

    What mission are you trying to access?

    And what "other broken quests" are you referring to?
  17. Nefer007

    Nefer007 Phantasmal Quasar

    Um... I've found a /warp command that brings you to the start of the world or instance when used. It's in admin mode.

    'Let's do the space warp again'
    The Squid likes this.
  18. btmarcher

    btmarcher Scruffy Nerf-Herder

    This is for the Erchius Mining Facility. The other quest that, I'm assuming is still broken but can't get to it, is the Mysterious Party quest.
  19. GrayArk

    GrayArk Space Spelunker

    i need help spawning mechs it just oes not work it gives me a perfictly genaric item
  20. Orion_Pax

    Orion_Pax Pangalactic Porcupine

    Enyone find command for Tech Test #1 quest?
    jonathonspy likes this.

Share This Page