1. Please be advised of a few specific rules and guidelines for this section.

RELEASED CN Survivalist: Resurrection v3.4.15

WILL YOU SURVIVE, AGAIN?

  1. joshua99944

    joshua99944 Tentacle Wrangler

    Thank you for ansering my question
     
    ColonolNutty likes this.
  2. ColonolNutty

    ColonolNutty Ketchup Robot

  3. ColonolNutty

    ColonolNutty Ketchup Robot

  4. Hoid

    Hoid Space Hobo

    Hey man, this is probably a simple and stupid question but I'm having trouble getting the mod to work. All of my mods so far have been from the steam workshop so this is my first manual attempted. The download link has a file that doesn't appear to have an extension
    "CNSurvivalist.v3.4.14.7z" do I just place this file into the mods folder? I use a Mac by the way, if that makes any difference..? Sorry if this is a stupid question :)
     
  5. ColonolNutty

    ColonolNutty Ketchup Robot

    ".7z" is the file extension, you have to unzip it using 7-zip or some other archive tool.
     
  6. Hoid

    Hoid Space Hobo

    Ah! Haha thank-you! I have never heard of .7z as an extension, silly me
     
  7. Vuldreg

    Vuldreg Cosmic Narwhal

    I recently got this mod but i've already run into a problem, The simple crafting table is missing from the options of craftable items. It shows some other items from this mod but not the crafting table i need.
     
  8. ColonolNutty

    ColonolNutty Ketchup Robot

    It doesn't show up in the empty hands crafting window?
     
  9. Vuldreg

    Vuldreg Cosmic Narwhal


    I looked several times over the list and it's not there.
     
  10. ColonolNutty

    ColonolNutty Ketchup Robot

    Have you picked up one of these? Cobblestone, Log, Wood
     
  11. Vuldreg

    Vuldreg Cosmic Narwhal


    I've picked up all the cobblestone wooden log and timber and nothing showed once i had a bit of each, Also not sure why but there is strangely an option for crafting infinite supply of wooden logs from just having a single block of it, Not sure if that is intended to be there or not but i checked and that recipe is from this mod.
     
  12. ColonolNutty

    ColonolNutty Ketchup Robot

    It sounds like you've got a mod conflicting with this one, causing each of those three sources to not unlock the recipe for you.
     
  13. Vuldreg

    Vuldreg Cosmic Narwhal


    It had taken a while to find but I've found and fixed the problem mod blocking the crafting item from appearing, I found that it was a mod called Better (C) Interface v23 (WIP), I had to get rid of it and just to be sure i removed all the mods that was connected to this one.
     
  14. ColonolNutty

    ColonolNutty Ketchup Robot

    You should let the author of that mod know that their mod conflicts with this one.
     
  15. Vuldreg

    Vuldreg Cosmic Narwhal


    I actually had to do a quick recheck of the mods just to be sure since i removed others that connected to the interface mod, Turned out it was one of the other mods that was working with it that caused the issue of the missing recipe item a mod called Block Printing & Refinery: Addon Support Patch. I have post a comment to the modder who made it so they know to check out the issue.
     
    ColonolNutty likes this.
  16. tigerfestival

    tigerfestival Scruffy Nerf-Herder

    Hey ColonolNutty, it's been a while. I was taking a break from Starbound and recently decided to get back into the game and wanted to try out this mod again, but it looks like a new problem reared it's ugly head, it looks as though this mod REALLY hates desert planets, as I keep being beamed back to my ship each time I go to a desert planet. Here's my log. Upon looking at it, this seems to be the error Caused by: (AssetException) Error loading asset /biomes/distributions.config:potsCommon

    Not sure what it means, but I hope you're able to fix it.
     

    Attached Files:

    ColonolNutty likes this.
  17. ColonolNutty

    ColonolNutty Ketchup Robot

  18. ColonolNutty

    ColonolNutty Ketchup Robot

    Try the latest release, perhaps it will work for you?
     
  19. tigerfestival

    tigerfestival Scruffy Nerf-Herder

    Excellent Job man. I tested 12 desert planets and they all functioned just fine. If more problems arise I'll be sure to inform you. Cheers!
     
    ColonolNutty likes this.
  20. ZeroInfinity

    ZeroInfinity Scruffy Nerf-Herder

    This looks really cool! I never played the original Survivalist mod, so I'm not exactly familiar with the source material. Forgive me if some of this is super obvious stuff from that:
    A few things I've noticed:

    1) CNS Garden worlds seem to be much rarer than normal garden worlds. I've got a lot of new planet mods, and I'm using bk3k's Faster Start, but while a regular garden world takes ~10 minutes at most to find if I disable the starting world file, a CNS garden world seems to take over 30 minutes to find in my test. I'm about to leave for a while and I'll leave a search running, but one of my tries when I was testing things out generated in excess of ~1.4GB of universe searching for a proper starting world. This isn't a problem if you don't load as many planet type adding mods as I do, but is there a way to make CNS garden worlds more common? I tried to do it myself, but clearly I have no idea what I'm doing as the most I could do on the subject was make it crash if I added selectionWeight to the entry for the world. Starbounder's modding pages says it can be used for planets, but I couldn't find an example of that in the core code, as it seemed to be used solely for stars.

    What makes a CNS Garden planet unique, by the way? Nearest I can tell, it seems to have sand (and presumably silt somewhere) underground for various resources, and it seems to spawn less enemies than a regular Garden world. I didn't search the entire surface, but I also didn't find the Frackin Universe big alien quest guy. Is he still there if you're running FU, since he's no longer necessary to repair your ship? If he's not, how are you supposed to get the progression items in the cave he sends you to?

    EDIT: Started the search, haven't left quite yet, but I heard the ship decelerate noise. However, the ship is still going, isn't slowing down, and the universe.chunks file is still growing, and no planet file was generated. I forgot about the ship decelerate noise that happens fairly quickly, honestly. I'll retry this test without bk3k's Faster Start and see if that makes a difference.

    EDIT2: Came back after over an hour, no planet found, had crashed out with a client exception. Restarted, left it to search, stopped after it reached nearly 1.7GB of universe.dat looking for a suitable system. I did get a single engine deceleration noise shortly after starting the search both times, but given it kept generating universe afterwards, I'm not sure it's too critical.

    EDIT7: Alright, I have no idea why that was happening. I'm guessing the engine decelerate noise must have been it finding a world and then deciding it wasn't good enough, because I've got two solar systems with a CNS Garden world in direct proximity, they're not rare at all.

    2) I really like having access to the FU's build a ship function. I was actually seriously concerned when it didn't pop up that I had installed something wrong until I looked through the discussion here and saw the last page and realized it was intentionally disabled. I tried to re-enable it, but I still clearly do not know what I'm doing, as somehow commenting out the line that removes the BYOS button causes the teleporter to be disabled even if I pick the default ship option, and I have no idea how that happens.

    Seeing as I can't seem to figure out how to enable it without breaking the teleporter, I wanted to ask why you disabled it in the first place. Is it to limit the space available to the player more severely?

    EDIT4: Managed to get enabling the BYOS button to not disable the teleporter even when it wasn't chosen, turns out I forgot to comment out every line removing it. Currently attempting to co-opt the lua script to fire a custom byosShipCNS function to enable the teleporter, but I am not very good at syntax and I need to reboot several times to test why it doesn't like what I've done.

    EDIT5: Haha, it worked! It's ugly and hacky and not elegant at all on the code side of things, but I got it to work! Massive props for figuring out how to do all this stuff, this is devilishly complicated. Mostly because I have no idea why my syntax is improper when it fails to load and I barely know any functions at all, I suppose, but the point still stands I think.

    EDIT6: Haha, joke's on me, I didn't modify the story quests and it ate my character when it called the ship upgrade script without consideration for my hacked-together BYOS script. Oh well, I don't lose that much playtime in the grand scheme of things, really. That character was fun, though! Unfortunately I didn't back up my saves, and since the shipworld is what got borked... Actually, maybe I can save the character by copying another functional shipworld.

    EDIT7: Was fixed remarkably easily, shipworld was unborked just by reloading. Admittedly it also didn't enable the interplanetary movement, but once I got the FTL chip it did. Maybe it's due to the FU questline running simultaneously when it shouldn't, but Esther Bright isn't offering any quests after I talked to her. I'm gonna poke around and explore, maybe try to make an advanced knowledge book, but I can't progress without making a machining table, and pretty much every high tech item in the barehanded crafting menu has been hidden. I might have broken it, and that would be my bad, or it might be under one of the Survival crafting benches somewhere. Speaking of, why do those all break and drop half returns? Especially with how expensive some of those get survival points wise, that's pretty frustrating, even if survival points aren't that hard to get.

    3) I tried disabling everything in my Starbound game save for this and Frackin Universe, which I have through the Steam workshop. When I was trying to find the files I needed to do what I tried in 1) and 2), I came across an edit that seems to be intended to add Survival Points into the inventory as a viewable amount, similar to Pixels and Essence. I couldn't see that, however, even after getting a number of survival points from running through the intro stage steps to test it. Was I just looking in the wrong place?

    4) There seem to be a lot of UI changes bundled into this. The quest panel is changed, the inventory's default position is different, the cursors... This particularly bugs me because the quest panel is changed for everything, and it no longer shows item rewards anywhere I can see. The corner UI is kinda nifty, but I'm not exactly a big fan of having everything moved and shuffled around my screen from a mod I thought looked really cool for the gameplay. Why is that?

    5) I'm not even sure if there's anything that can be done about this without some really dirty editing, but is it intentional that while you miss out on the Protector's Broadsword if you skip the intro, it's still present in the chest in the mission? It's significantly better than the branch (which is honestly a bit miserable to use, but it's not exactly intended to be a great weapon). Is it just a little reward for those who play through the intro, like the cosmetic protectorate flower and the extra pixels?

    All in all though, I'm having a lot of fun trying to figure out the systems and playing the game (though I am just about completely stumped on trying to figure out even enough about how anything here was done to modify it). Great work!

    EDIT 3: Bug found, it reads "Reboot Systens" instead of "Reboot Systems" in the SAIL reboot dialogue.
     
    Last edited: Dec 16, 2019

Share This Page