1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Client ship world has errored, no mods

Discussion in 'Support' started by thegrinningcat, May 17, 2017.

  1. thegrinningcat

    thegrinningcat Aquatic Astronaut

    Today i just loaded the game in singleplayer after not playing it for a few months to get a look at my ship, and when I tried loading my main character I got this error and could never get to actually see my ship, only a black screen with the error that brings me back to the main game menu. I tried doing the same thing with a character I had just created when I last played and the same thing happened. I never used any mods and I think the people I played multiplayer with never did either. The only thing we ever did was add abc files to get new songs.
    Does that mean I lost my ship furniture and progress forever?

    [09:37:39.312] [Info] Root: Preparing Root...
    [09:37:39.312] [Info] Root: Done preparing Root.
    [09:37:39.312] [Info] Client Version 1.2.3b (macos x86_64) Source ID: 69bc1c906122a1c61453c6cff15aa088b613db78 Protocol: 729
    [09:37:39.312] [Info] Root: Scanning for asset sources in directory '../assets/'
    [09:37:39.534] [Info] Root: Scanning for asset sources in directory '../mods/'
    [09:37:39.535] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [09:37:39.535] [Info] Root: Detected asset source named 'base' at '../assets/packed.pak'
    [09:37:39.535] [Info] Root: Detected unnamed asset source at '../assets/user'
    [09:37:39.535] [Info] Loading assets from: '../assets/packed.pak'
    [09:37:39.842] [Info] Loading assets from: '../assets/user'
    [09:37:41.085] [Info] Assets digest is 06cbcabd08c255b023a32ab90661887de878dffa9534c11a0de2b083efe882db
    [09:37:41.085] [Info] Root: Loaded Assets in 1.77227 seconds
    [09:37:41.088] [Info] Application: Initializing SDL Video
    [09:37:41.197] [Info] Application: Initializing SDL Joystick
    [09:37:41.198] [Info] Application: Initializing SDL Sound
    [09:37:41.252] [Info] Initialized Steam services
    [09:37:41.258] [Info] Application: Creating SDL Window
    [09:37:41.294] [Info] Application: Enabling VSync with late swap tearing
    [09:37:41.294] [Info] Application: Enabling VSync late swap tearing failed, falling back to full VSync
    [09:37:41.446] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [09:37:41.451] [Info] OpenGL version: '2.1 INTEL-10.22.25' vendor: 'Intel Inc.' renderer: 'Intel HD Graphics 5000 OpenGL Engine' shader: '1.20'
    [09:37:41.454] [Info] Application: initialization...
    [09:37:41.455] [Info] Root: Loaded Configuration in 0.000909 seconds
    [09:37:41.881] [Info] Application: renderer initialization...
    [09:37:41.885] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 128
    [09:37:41.885] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 64
    [09:37:41.887] [Info] Root: Loaded ImageMetadataDatabase in 1e-06 seconds
    [09:37:41.901] [Info] Application: main update loop...
    [09:37:41.934] [Info] No subscribed user generated content
    [09:37:41.954] [Info] Root: Loaded NameGenerator in 0.0193385 seconds
    [09:37:42.112] [Info] Root: Loaded PlantDatabase in 0.157728 seconds
    [09:37:42.463] [Info] Root: Loaded ObjectDatabase in 0.528498 seconds
    [09:37:42.668] [Info] Root: Loaded MonsterDatabase in 0.204651 seconds
    [09:37:42.681] [Info] Root: Loaded ProjectileDatabase in 0.569155 seconds
    [09:37:42.684] [Info] Root: Loaded StagehandDatabase in 0.0021184 seconds
    [09:37:42.686] [Info] Root: Loaded VehicleDatabase in 0.002772 seconds
    [09:37:42.689] [Info] Root: Loaded PlayerFactory in 0.0027511 seconds
    [09:37:42.708] [Info] Root: Loaded NpcDatabase in 0.0395474 seconds
    [09:37:42.709] [Info] Root: Loaded VersioningDatabase in 0.000708 seconds
    [09:37:42.709] [Info] Root: Loaded EntityFactory in 0.01956 seconds
    [09:37:42.759] [Info] Root: Loaded ParticleDatabase in 0.050232 seconds
    [09:37:43.080] [Info] Root: Loaded MaterialDatabase in 0.37121 seconds
    [09:37:43.086] [Info] Root: Loaded TerrainDatabase in 0.0059428 seconds
    [09:37:43.119] [Info] Root: Loaded BiomeDatabase in 0.0326957 seconds
    [09:37:43.120] [Info] Root: Loaded LiquidsDatabase in 0.000828 seconds
    [09:37:43.127] [Info] Root: Loaded StatusEffectDatabase in 0.0073823 seconds
    [09:37:43.395] [Info] Root: Loaded DamageDatabase in 0.267373 seconds
    [09:37:43.407] [Info] Root: Loaded EffectSourceDatabase in 0.0122623 seconds
    [09:37:43.411] [Info] Root: Loaded FunctionDatabase in 0.0041812 seconds
    [09:37:43.445] [Info] Root: Loaded TreasureDatabase in 0.0331176 seconds
    [09:37:43.659] [Info] Root: Loaded DungeonDefinitions in 0.214873 seconds
    [09:37:43.660] [Info] Root: Loaded TilesetDatabase in 1.4e-05 seconds
    [09:37:43.663] [Info] Root: Loaded StatisticsDatabase in 0.003463 seconds
    [09:37:43.663] [Info] Root: Loaded EmoteProcessor in 6.92e-05 seconds
    [09:37:43.668] [Info] Root: Loaded SpeciesDatabase in 0.0051855 seconds
    [09:37:43.685] [Info] Root: Loaded QuestTemplateDatabase in 0.0164558 seconds
    [09:37:43.686] [Info] Root: Loaded AiDatabase in 0.001441 seconds
    [09:37:43.688] [Info] Root: Loaded TechDatabase in 0.0012019 seconds
    [09:37:43.698] [Info] Root: Loaded CodexDatabase in 0.0101972 seconds
    [09:37:43.971] [Info] Root: Loaded BehaviorDatabase in 0.273403 seconds
    [09:37:43.975] [Info] Root: Loaded DanceDatabase in 0.0038861 seconds
    [09:37:43.980] [Info] Root: Loaded SpawnTypeDatabase in 0.0048211 seconds
    [09:37:43.983] [Info] Root: Loaded RadioMessageDatabase in 0.0026209 seconds
    [09:37:44.326] [Info] Root: Writing runtime configuration to '../storage/starbound.config'
    [09:37:45.572] [Info] Root: Loaded ItemDatabase in 2.86424 seconds
    [09:37:45.711] [Info] Root: Loaded CollectionDatabase in 1.72834 seconds
    [09:37:46.348] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [09:38:25.108] [Info] UniverseServer: Acquiring universe lock file
    [09:38:25.113] [Info] UniverseServer: Loading settings
    [09:38:25.114] [Info] UniverseServer: Starting UniverseServer with UUID: d823fc7d74e94aa147ce6dd9c95bdcf8
    [09:38:25.127] [Info] UniverseServer: Logged in player 'Yoko' locally
    [09:38:25.127] [Info] UniverseServer: Logged in account '<anonymous>' as player 'Yoko' from address local
    [09:38:25.132] [Info] UniverseServer: Reviving player at ClientShipWorld:f2aeee22d0ff41ba029d7dd1f56ad2bb
    [09:38:25.132] [Info] UniverseServer: Client 'Yoko' <1> (local) connected
    [09:38:25.138] [Info] UniverseClient: Joined server as client 1
    [09:38:25.217] [Info] UniverseServer: Loading client ship world ClientShipWorld:f2aeee22d0ff41ba029d7dd1f56ad2bb
    [09:38:25.218] [Error] UniverseServer: Could not load client ship ClientShipWorld:f2aeee22d0ff41ba029d7dd1f56ad2bb, resetting ship to default state! (IOException) tmpfile error: Permission denied
    [09:38:25.218] [Info] UniverseServer: Creating new client ship world ClientShipWorld:f2aeee22d0ff41ba029d7dd1f56ad2bb
    [09:38:25.324] [Error] UniverseServer: error during world create: (IOException) tmpfile error: Permission denied
    0 starbound 0x000000010c2dd100 _ZN4Star13StarExceptionC2EPKcNSt3__112basic_stringIcNS3_11char_traitsIcEENS3_9allocatorIcEEEE + 128
    1 starbound 0x000000010c2e208f _ZN4Star4File13ephemeralFileEv + 511
    2 starbound 0x000000010c94cd94 _ZNSt3__110__function6__funcIZN4Star14UniverseServer16shipWorldPromiseERKNS2_24ClientShipWorldIdWrapperINS2_4UuidEEEE3$_8NS_9allocatorIS9_EEFNS_10shared_ptrINS2_17WorldServerThreadEEEvEEclEv + 420
    3 starbound 0x000000010c95ea5c _ZZN4Star10WorkerPool11addProducerINSt3__110shared_ptrINS_17WorldServerThreadEEEEENS_17WorkerPoolPromiseIT_EENS2_8functionIFS7_vEEEENKUlvE_clEv + 188
    4 starbound 0x000000010c2db57e _ZN4Star10WorkerPool12WorkerThread3runEv + 190
    5 starbound 0x000000010c2e5bab _ZN4Star10ThreadImpl9runThreadEPv + 251
    6 libsystem_pthread.dylib 0x00007fffe944faab _pthread_body + 180
    7 libsystem_pthread.dylib 0x00007fffe944f9f7 _pthread_body + 0
    8 libsystem_pthread.dylib 0x00007fffe944f1fd thread_start + 13
    [09:38:25.324] [Info] UniverseServer: Client 'Yoko' <1> (local) disconnected for reason: Client ship world has errored
    [09:38:25.441] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 64
    [09:38:25.441] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 128
    [09:38:25.448] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [09:38:25.448] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [09:38:25.448] [Info] Setting steam rich presence connection as steam id 76561198209280375
    [09:38:25.470] [Error] You were disconnected from the server for the following reason:
    Client ship world has errored
    [09:38:25.530] [Info] UniverseServer: Stopping UniverseServer
    [09:38:25.533] [Info] Clearing steam rich presence connection
    [09:38:27.519] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [09:38:28.815] [Info] Application: quit requested
    [09:38:28.815] [Info] Application: quitting...
    [09:38:28.815] [Info] Application: shutdown...
    [09:38:28.955] [Info] Root: Shutting down Root
    [09:38:29.190] [Info] Application: Destroying SDL Window
    [09:38:29.197] [Info] Application: stopped gracefully

    I'm playing on a Mac with Sierra.

    Thank you for your help!
  2. Iris Blanche

    Iris Blanche Ice pudding fairy Forum Moderator

    Make sure starbound had enough permissions to create, modify and delete files. In your case it seems that starbound fails to create one of its temp files. These are stored in the os defined temp folder. Starbound needs full access to this folder.

    ~ Iris ~

Share This Page