1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Closed Client-Server Connection is no longer valid

Discussion in 'Starbound Support' started by Javalin, Dec 5, 2013.

Thread Status:
Not open for further replies.
  1. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    DJ, are you running any mods? Quite a few of these errors appear to be caused by little errors in vital early places.

    @RyuujinZERO, yeah, mine was having the same problem! Mine was a codex error (missing a comma) but a json validator should find that kind of thing. I'd run any files that are potential concerns through jsonlint.com and see if that catches something!
     
  2. RyuujinZERO

    RyuujinZERO Supernova

    Ooh, thanks for the idea! - Didn't think that a JSON validator might be a thing, but, now you say that it's obvious....

    Later: Apparently it's all fine. :S
     
  3. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    Hmm... Maybe it isn't the codex. I'm not a huge expert on this, but it seems as though Kawa tore his game apart a bunch of times to see if he could fix it. He identified the problem as potentially coming from the ship structure list (universe_server.config), quests (quests/quests.config), or the codex (codex/codex.cofig).

    If you know of anyone getting the problem, I'd run your quests, codex files, and univers_server through jsonlint and see if any of them have problems. If you don't, it could be that your mod is clean and they have another one with an issue!
     
  4. RyuujinZERO

    RyuujinZERO Supernova

    Looks like I'm all clean; but good to know. Looks like i need to keep up and exchange notes with you and kawa to stay on top of modding current affairs and knowledge :p
     
  5. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    I'm not sure if Kawa has found anything else, he just posted that to his mod page and I was reading through that. I'm not hugely good at this stuff
     
  6. Lordwolfe

    Lordwolfe Subatomic Cosmonaut

    OK I'm having the same issue but I've tried the same fixes in this thread, but the problem still persists and I've never ever played on multilayer. also this problem only happened tonight. so something a little more complicated is going wrong here. what is it and how are these files being changed without any input from us what so ever. something really weird is going on here.
     
  7. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    Hmm...
    Do you have any mods installed? From what I've seen, single player troubles with this tend to be related to mods. Also, try reverifying the files through Steam.
     
  8. Binly

    Binly Intergalactic Tourist

    Just ran into this issue, read somewhere above about there being an issue with ships.
    Of course I had installed a ship mod and forgot to change the dropship.structure file back to its original.

    So guys, double check that all your ship files are the original ones, it fixed the problem for me at least in singleplayer!
     
  9. Shintheking

    Shintheking Void-Bound Voyager

    I get this message too and since the patch should be sometime this weekend, it will give me a chance to try EricTheRoo's solution.
     
  10. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    Do you have mods? Chances are its an issue in a codex, ship, quest, or species. It should give a universe exception error.
     
  11. Shintheking

    Shintheking Void-Bound Voyager

    Actually I fixed it just before the patch, and no I don't have mods. Thanks anyway!
     
  12. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    Hey, I'm glad to hear its working!
     
  13. Mailboxhead

    Mailboxhead Master Astronaut

    I keep getting this error a few minutes after I join a server. It only happens in multiplayer, and the only mod I have installed is Extended Songbook.
    I've tested this on multiple servers and it still happens. My friends can play on these same servers just fine, however.
     
  14. Vanich

    Vanich Space Spelunker

    sorry, man
    but i just haven't the default_configuration.config in my game folder. WTF?
    What should i do?
     
  15. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    Do you have any mods installed? For single player this mostly seems to happen because of faulty mod stuff.
     
  16. captroyGbiv

    captroyGbiv Space Hobo

    So i had this problem as well in multiplayer. I was playing in the same server for almost 4 hours and then things just started to bug out, couldn't really do anything in game, and then finally got disconnected. After trying a bunch of network things, i concluded it couldn't be either my or the servers network. So i tried creating a new character which worked and connected fine, so i then tried deleting just my shipworld file of the character i was using when i was disconnected from the server, and that also worked. Hope this helps a few of you.
     
Thread Status:
Not open for further replies.

Share This Page