Tool Chicklet V2.1.4 - Save editor & Map editor

Discussion in 'Mods' started by stefanhaan, Mar 12, 2016.

  1. BryghtShadow

    BryghtShadow Space Spelunker

    The <UpgradeLevel> is not being set to the correct value for the watering cans. (If you set <upgradeLevel> to 0 and <UpgradeLevel> to 4, the game will update <upgradeLevel> to 4 when you sleep.)
    • stefanhaan

      stefanhaan Scruffy Nerf-Herder

      Yep at the moment i place upgradeLevel twice in the XML for watering cans whereas one needs to be as upgradeLevel and the other as UpgradeLevel.
      I can't even grasp why the developer made such a mess out of property naming..
      • princessiap

        princessiap Orbital Explorer

        Thank you soo sooo soo sooo much for this application. I had recently jacked up my game with the CJB spawner and had the locked door in my greenhouse. I went through so much trouble to get it deleted that I ended up messing up my save files and I couldn't be more grateful for being able to get my game back to "normal"!!! Much much love xoxo
        • iheijoushin

          iheijoushin Intergalactic Tourist

          I can't seem to get the auto update to 2.1.4 working. Every time I launch the program (2.0.0 from the first post) I am told there is a new version and opt to download it. The app sits saying it is downloading the update and eventually closes itself. Upon relaunch the app says it's version 2.0.0 and needs to update again. I have tried the following to resolve:

          • Trying both theX32 and x64 binaries
          • Moving both versions to the Program Files folders and running from Downloads folder
          • Turning off security software (Norton 360)
          • Running as Administrator
          Any help would be most appreciated. I really just want to move my barn over two hexes so I can have a nice path.
          • foghorn

            foghorn Pangalactic Porcupine

            Last edited: Aug 23, 2016
          • senlim

            senlim Industrial Terraformer

            Does this work with latest v1.1?
            • ironlion45

              ironlion45 Void-Bound Voyager

              Sort of. It doesn't have the new things added from the patch. So if you try editing your farm, etc. and you used one of the new layouts, strange things are going to happen. You won't find the new items, like coffee beans, either.
              • K480

                K480 Yeah, You!

                It helps me many times, thank you !
                • Zalkyria

                  Zalkyria Phantasmal Quasar

                  Does anyone know where the location of the sava data for stardew would be on the mac?
                  • foghorn

                    foghorn Pangalactic Porcupine

                    @Zalkyria ~/.config/StardewValley/Saves/
                      Zalkyria likes this.
                    • Zalkyria

                      Zalkyria Phantasmal Quasar

                      Thanks! I figured out why I couldn't find it lol, had to figure out how to show hidden folders. I'm a mac newbie, my pc is down for the count so borrowing my dad's mac to continue playing SV :rofl:
                      • stefanhaan

                        stefanhaan Scruffy Nerf-Herder

                        I'm currently working on a new version that supports the most recent updates, and includes some nice to haves for the Mac platform.
                          Koutetsu, senlim, AeroHail and 3 others like this.
                        • Vith

                          Vith Scruffy Nerf-Herder

                          The new update got me into SDV again. Thanks for your continued support!
                          • stefanhaan

                            stefanhaan Scruffy Nerf-Herder

                            Btw on a side note, quite a few things changed in the new versions. To test a few things out I could use a couple of save files, if you'd like to contribute just attach your save file / PM or any other source!
                            • foghorn

                              foghorn Pangalactic Porcupine

                     (links directly to downloadable saves)

                              The site doesn't support heavily modded/serialized saves, so they should work fine for testing.
                              • joprinz

                                joprinz Master Chief

                                @stefanhaan , I have sent you my save file in the PM. I hope you'd find it useful. :kitten2:
                                • rikukun

                                  rikukun Space Hobo

                                  Hi there! I've downloaded & tried v2.0.0 (Mac) and it works great :)
                                  One issue I'm having is when I try to update to the latest version... it gets stuck in "Downloading update" screen for a long time...
                                  I've checked network traffic & the app seems to be downloading just fine until 18.0MB, then the traffic becomes extremely slow/stops.

                                  I appreciate any help on this, and keep up the great work :)
                                  • stefanhaan

                                    stefanhaan Scruffy Nerf-Herder

                                    Unfortunately I only have the 2.1.4 binaries up for Windows, however the auto updater downloads the following file:

                                    If you open the package contents from Chicklet, navigate to Content/Resources/ within that folder replace the app.asar with the one you downloaded and you should have the 2.1.4 version!
                                    • rikukun

                                      rikukun Space Hobo

                                      Worked perfectly fine! Thanks for the help :D
                                      • Scc2463

                                        Scc2463 Space Spelunker

                                        I can't get one of my save files to load, it just gets stuck on Loading and preparing data. Any reason for this?

                                        Share This Page