RELEASED Chicklet - Save file editor & Map Editor V2.1.4

A save file & Map editor for StardewValley

  1. Odd Farmer

    Odd Farmer Big Damn Hero

    Editor won't work anymore. It displays 'The following error occurred: api_response_not_valid.' You can select a file, but it never stops laoding.
     
      maximalochka likes this.
    • WatcherCCG

      WatcherCCG Giant Laser Beams

      It works for me, even with the error. But I suspect the game is starting to update beyond the editor's code. Might be time to update the editor.
       
        gubbsy likes this.
      • hullo50321

        hullo50321 Space Hobo

        Fix: Make a new character.
         
        • Cyflect

          Cyflect Space Hobo

          Is this now dead? ( not being worked on )
           
          • kzintiwife

            kzintiwife Void-Bound Voyager

            i would love to get the2.14 version... can anyone supply that as the auto-updater doesn't work anymore.
             
            • stefanhaan

              stefanhaan Scruffy Nerf-Herder

              I did stop working on it for a long time, if there's enough interest I'll pick it up again but I'll open source it this time for others to contribute as well
               
                cor03 and Koutetsu like this.
              • Koutetsu

                Koutetsu Void-Bound Voyager

                I'd definitely love an update. I love the UI and ability to move stuff around on the maps. Makes my life significantly easier.

                Anyone who's having problems loading a save file - since it's out of date, it dislikes a lot of the stuff added in 1.1. For example, if I have the return scepter, it will not load at all but if I remove that somehow, it loads just fine.
                 
                • bittrswtviktory

                  bittrswtviktory Intergalactic Tourist

                  It would be fantastic if we could get an update. Currently cant use the program to edit the save file once you've upgraded to the 3rd house upgrade with the cellar. Had to revert back to the previous house upgrade to get past the "Missing text" error I was getting. I REALLY LOVE YOUR WORK AND AN UPDATE FOR THIS PROGRAM WOULD BE AMAZING!
                   
                  • Classified123

                    Classified123 Orbital Explorer

                    Everytime i try to save, it just says "saving" forever and never actually saves it
                     
                    • cor03

                      cor03 Space Hobo

                      Pleeeeeease id love it!!!
                       
                      • tiffy961

                        tiffy961 Scruffy Nerf-Herder

                        I'd love that as well tbh. I wanted to change to a new map but can't because everything would be in wrong positions
                         
                        • _space15_

                          _space15_ Space Hobo

                          Hi I'm having a problem where when I save my file doesn't end? it stays on the saving data screen and I don't really know what to do since I'm new to this, I've checked and I'm using 64bit correctly so I'm not really sure what's wrong. Thanks in advance
                           
                          • Corraidhín

                            Corraidhín Supernova

                            If I may be so bold so as to suggest the author of this wonderful save editor, could I ask for a small update, if the task itself is not too big? I tried using it on a recent save now that I am playing again, and I notice that some of the newer items disappear (by newer, I mean post chicklet's latest update). I am unsure if it only affects the Catalogue for furniture from Robin, and the catalogue for wallpapers from Pierre. It is not a huge issue whatsoever, and for the most part it works wonderfuly! it is just that little hiccup, really.
                             
                            • WulfyRoxas

                              WulfyRoxas Void-Bound Voyager

                              Plleaassee.
                              A while back one of my favorite multiplayer saves glitched for my friend and she ended up with mushroom boxes that she placed in our house.
                              I was hoping for the day Chicklet had indoor home editing so I could remove them, as she put it in the doorway and I can't even play that save.
                               
                              • riloujo

                                riloujo Space Spelunker

                                does it works if i have mod on it doesnt seems to load my modded file . . . Welp wtf it does load it because i can click on stuff but the screen is still at its loading page
                                 
                                • Th4owit

                                  Th4owit Yeah, You!

                                  Please please update this to work on new co op update. save file loads but wont save. using nintendo switch saves
                                   
                                  • businessskeleton

                                    businessskeleton Yeah, You!

                                    probably need to assume this is dead.
                                     
                                    • drenai

                                      drenai Space Hobo

                                      -=-PSA-=- 2.14
                                      So, I tried it today and NO it doesn't work with the current version of the game. It will give an error on load about the api but will still load the game save just fine, it will also allow you to edit the save just fine but then when you go to save it will sit at the "saving data..." screen forever and never finish and corrupt the save, forcing you to return to the backup.

                                      I will not post a link to it, but google will show you the way to the save editor on nexus mods website. I tested it and it does work with the current version as of the date i am posting this.

                                      If the guy who made the editor here ever starts it back up again i would be greatly interested because i feel his version was so much better the the other guy's editor.
                                       
                                      • LilSampson

                                        LilSampson Space Hobo

                                        Hello, I have got a problem:After pressing save in the editor, there´s the loading screen, but it doesnt... Could someone help me?
                                        thx
                                         

                                        Share This Page