Can't progress to next day - game is waiting for player who left and can't rejoin

Discussion in 'Multiplayer' started by Davinlo, Dec 3, 2018.

  1. Davinlo

    Davinlo Space Hobo

    Hey fellow people,

    I was just playing together with two friends, when one of them left the game right before going to bed. Now the game is waiting for that player to confirm before progressing to the next day. However, he's not in the game anymore and he can't rejoin before this day ended.
    I'm kinda afraid we will lose our progress for that day, but there's probably nothing we can do about it.
    I just wanted to let everybody know, for players so maybe it won't happen to them, for the dev so he might be able to do something about it, but since the "known issues"-thread is closed, I made a new one.

    Cheers


    PS. Oh yeah, playing on Linux (me) and Windows (both friends)
     
    • Davinlo

      Davinlo Space Hobo

      Okay, so the other friend tried to quit and join again via LAN as the first player that left, but the game still thought the farm was full (we only have the main house and two cabins). But then I also quit, restarted and checked the farm and it actually did save and progress.
       
      • KELLINarchers

        KELLINarchers Void-Bound Voyager

        You have to delete the cabin, go to the carpenter and click on 'build farm blah blah blah' and you can also delete them by clickingthe yellow trianle with the X in it
         
        • Davinlo

          Davinlo Space Hobo

          But that would kick them from the server entirely, right? With all their progress as well?

          The moment I would've wanted to kick them from the actual game just right now, not entirely, was after going to bed and before waking up, so carpenter wouldn't've worked. But also, I only wanted to kick them in order to be able to save the day, progress to the next one and let one of them rejoin. Even though I wasn't able to kick them, the game still saved our progress though, so the problem I first saw didn't actually occur.
          It's still a kind of serious bug though.
           

          Share This Page