1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Can't join multiplayer game with existing character (STEAM)

Discussion in 'Starbound Support' started by Victea350, Jan 1, 2017.

  1. Victea350

    Victea350 Space Hobo

    Hey all,

    When I try to join my friends game via the steam overlay using an already created character, I get the the "Join failed. No server response." error.

    However if I choose to create a new character when it asks me to select one, I can join no problem.
     

    Attached Files:

  2. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    Are you using any mods? If you are there could be an item or something on your primary character that isn't recognised by the server. Maybe,

    If you are using mods clear out your primary character's inventory and see if that works.

    If its completely vanilla, I would need to see a log of the session it happened on.
     
  3. Hogganator

    Hogganator Space Hobo

    I am a new player to the game and am having the same issues, if I make a new character while trying to join a friends server I am able to join in without problems. But after I exit the server and try re join I get " ERROR no server response" and am un-able to join again. no mods are being used by either of us. if someone could help with this issue that would be very appreciated
     
  4. Victea350

    Victea350 Space Hobo

    Neither of us are using mods.

    And here you are.
     

    Attached Files:

  5. wrmderma

    wrmderma Space Hobo

    Having the same issue, any solutions yet?
     
  6. NexusTheBrony

    NexusTheBrony Spaceman Spiff

    rude much? unless u got the same log, then we need ur log too

    i actually do not know what could be causing it, but here's my throw: Was the character created when Join via Steam was disabled on either of u?
     
  7. Archfiend Reaper

    Archfiend Reaper Void-Bound Voyager

    May be a little rude yes. However I think it's rude to watch these questions get ignored for years too. Many of us bought this game for the multiplayer. A multiplayer that is broken to no ends. How many logs are needed for this issue. Logs have been submitted multiple times by multiple people and then ignored for months at a time. We are all having the exact same issue which once again needs explaining to the moderator team.

    This is how my last try at multiplayer went. Which is the same as a year ago when I tried.

    I created a character and played around in single player for awhile. Then saved and exited. Joined friend via steam. Works just fine however game starts to lag over time. Leave and try to rejoin. Rejoining fails every time. Create new character when joining friend and I join with no issues. Leave and try to rejoin. Rejoining fails each time. Googled a public server. Used first created character to join. No issues. Leave and rejoin. No issues.

    Friend joins my first character through steam with no success. He creates new character and boom he's in. This is after our first created characters had been in a steam joined multiplayer once.

    The problem is based around steam joining. The problem has been submitted multiple times since the game hit steam. The logs have been provided each and every time. The thread has then been ignored each and every time. For years I've watched this issue get ignored. I feel I have good right to be upset and rude about this.
     
  8. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    I think if you were able to join and rejoin a public IP and Steam doesn't work out for you then it narrows down the problem

    Have you tried any other means of connectivity other than the Steam button?

    Just a quick search into the Multiplayer section: http://community.playstarbound.com/...r-setup-for-multiplayer-without-steam.119089/

    You could always use a 3rd party app to establish a connection to your friends and use their IP's on the app to join up. I have to do this with people when I play Minecraft.

    Just so you know its not our fault. Its quite rude how you just pinpoint the blame on us.
     
  9. SleepySquidd

    SleepySquidd Tragically Magic Hands

    There is no need to be hostile towards us. Moderators are volunteers, we take time out of our busy day to try and make this community a bit nicer and friendly place. There are numerous reasons why this issue is being looked over. The simplest answer is: we don't understand it. If I don't understand how to fix a bug or other issue, I'm not going to come in and act like I do. I have many more things to do in my daily life than come in and pretend to know what I'm talking about.

    No one will want to help you if you act like this towards them, after all, who would want to help someone treating them like dirt?

    I never use the Steam overlay to join servers, regardless of the game. Try connecting directly to it through the game instead of the overlay. Beyond that, I don't know what the issue is.
     
    Hel likes this.
  10. Archfiend Reaper

    Archfiend Reaper Void-Bound Voyager

    So what your saying is you're to busy to at the very least pop in on these posts and say "Hey we understand your having issues. This is a known problem the devs are looking into." Something? Anything? Months and months go by. A log was asked for. It was provided by op. 3 months later and it took an asshole like me to get a response. That's not being to busy that's ignoring someone asking for help on an issue you know you can't help them with. At least tell them you have no idea. Refer them to a section that will provide other means to play the game online as hel did. It only took 3 months but it finally came.
     
  11. NexusTheBrony

    NexusTheBrony Spaceman Spiff

    no, they're saying they won't post on what they don't know. its a waste of time. if there's a bug, staff could inform the devs without informing you, or the devs could look into it themselves. either way, other than convenience, there is no use to post when you can't help
     
  12. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    I think arguing about this isn't gonna go anywhere.

    Whilst myself of anyone else who has posted here knows why this happens there are some workarounds. I can forward this to developer's attention, but in the meantime use the alternative methods I provided.

    Whilst the issue isn't resolved, workarounds have been provided. If anyone needs help with the set up of the ways I posted you are more than welcome to PM me, I will reply when I can.
     
  13. Katzeus

    Katzeus Chucklefisherman Chucklefish

    Hey guys, if you're having this issue @Hel's workaround should work. There hasn't been enough details shared here to get an idea of what's really happening - the most important info will be the hosts log. That will show if the client is actually able to connect and if not hopefully why they're unable to.

    If anyone still having this issue could gather those details I'm happy to help look into this further!
     
    Hel likes this.
  14. Rohkenzai

    Rohkenzai Void-Bound Voyager

    I'm not really a fan of reviving threads but this one is relevant to me.

    I am having the same bug the OP is, I understand OPs issue fully and can describe it in detail (though I cannot give you the error log, don't know where it is and for the purpose of this attempt I was not the one trying to log on).

    The following actions were taken

    Player 1: makes character
    Player 2: makes character
    P1: Starts normal game with new character
    P1: Invites P2 to game via steam invite
    P2: Successfuly joins game via steam invite
    P2: Leaves game
    P1: Closes game
    P2: Opens game solo
    P2: Closes game
    P1: Opens game
    P1: Invites P2
    P2: Cannot join, error (no server response)

    This is not a random bug. I can replicate it, I have replicated it, and this exact bug happened right after the release of 1.0 when I first tried to use steam invite to play.

    This bug made me hate starbound.

    If there is a known fix I would like to know what it is. If I can help diagnose the source of the bug, I would like to help, but know this. The reason I want steam invite to work is so I DONT need to portforward of launch a dedicated server, I DO NOT want to have to do that, so help solving this is appeciated.

    EDIT: Newly created characters CAN join, but not ones that have already joined
     
  15. Rian17

    Rian17 Space Hobo

    I'm having the exact same problem, pre existing character fails to join every time but when i create a new character it works seamlessly, then i leave and rejoin and the problem starts again, playing with friends was half the reason in buying Starbound and starting from the ground up whenever i want to play with my friends leaves me with mixed feeling on the game
     
  16. AflyingYogert

    AflyingYogert Space Hobo

    Hi,
    Has anyone found a solution to this problem yet? I just tried to play with a friend last night and the same thing that has happened to everyone is now happening with a few extra things i have found.
    Just to speed things up, yes we both have multiple mods with the frackin universe, but we were able to play with these literally a few days before this with no problems. all mods match with each other and even after uninstalling the game and mods the problem still persisted. the only thing left is to delete all my local data and starting fresh but after putting a so much time into the game i would rather not do that since that sounds like a thing i would do for a beta version of a game.
    Here are the things i have been able to find that no one has mentioned yet.
    1) after about a dozen tries i finally was able to join my friends server but then things got really strange.
    2) when i was able to get into his server, i was unable to send or receive in-game invites to form a party.
    3) any upgrades in my ship became unacceptable, i would move towards them, then get stuck in the wall at the edge of the new area of the ship until i moved away.
    4) i was unable to access any boxes or teleporters in my ship.
    5) when i join my own solo game, i can no longer place decorations in my ship or crafting stations.

    This is an old thread but its the only place ive found that is trying to figure out the issue. I hope some of the info is useful and I am willing to meet with either a moderator or developer to try to fix this issue. I love this game and its how i keep up with my little brother across space and time and just want to solve the problem, not make more.
     

Share This Page