1. When making a thread, please tag your thread accordingly using the menu to the left of the textfield where you name your thread where applicable. Server Advertisements and Mod Releases should be contained to their respective subforums.

Server Help Can't host my own server, it terminates in a weird way. Can't lock onto universe.

Discussion in 'Multiplayer' started by BurningJoker, Apr 3, 2014.

  1. BurningJoker

    BurningJoker Void-Bound Voyager

    If I start up Starbound and then try to start my server the server says it can't lock onto the universe string and crashed but Starbound keeps running, but if I do the server first then my game crashes but the server still runs.
    I backed up my data and did a fresh install, and without putting my data back in it still doesn't work.

    Here is what the log says:

    Info: Creating Star::Root with 2 assets sources and config file: '..\starbound.c
    Info: Loading Star::Assets from: '../assets/packed.pak'
    Info: Loading Star::Assets from: '../assets/user'
    Info: Loading Star::Root...
    Info: Loading Star::Configuration from '..\starbound.config'
    Warn: Missing inventoryIcon for chestplant1, using default
    Warn: Missing inventoryIcon for barvent, using default
    Warn: Missing inventoryIcon for wreckvent, using default
    Info: Done loading Star::Root.
    Info: Server version 'Beta v. Enraged Koala - Update 6', protocol 642
    Info: Running from : C:\Program Files (x86)\Steam\steamapps\common\Starbound\win
    Info: Scanning for router for portforwarding
    Info: Done scanning for router for portforwarding
    Info: Acquiring universe lock file
    Info: Shutting down Star::Root
    Error: StarException: Could not acquire lock for the universe directory
    UniverseServer::UniverseServer(String, bool, CelestialCoordinate)

    That's if I start the game first then the server. When I start the server first the error shows up in a windows box instead of the server log and closes the game.
    Does anyone have a idea what is going wrong? It worked in the past but then I didn't play for a couple months and then this happened. I can still connect to friends servers but not my own even after a fresh install.
  2. Moved to server discussion, hopefully the people in there will be able to help! :giggle:
  3. BurningJoker

    BurningJoker Void-Bound Voyager

    Sorry, didn't know where to put it and I was in a rush, thanks for moving it!
    Ἄνουβις likes this.
  4. teihoo

    teihoo Ketchup Robot

    Error: StarException: Could not acquire lock for the universe directory

    It cant get a lock on universe folder which is located in Starbound/universe you might wanna check what's up with that. Something wrong with the folder or its locked by another starbound process.
  5. BurningJoker

    BurningJoker Void-Bound Voyager

    Well like I said in the OP, I deleted everything and did a fresh install, so I don't know why it still can't get a lock, every thing should be in its default place.
    Unless for some reason I have to manually move it somewhere I figure something else is going wrong.
    Right now the universe folder is in "Steam / Steamapps / common / Starbound / universe"
  6. teihoo

    teihoo Ketchup Robot

    I think if you have the game client running in single player mode it will already lock the universe folder, same if you have server running and try to enter in single player mode. Could be that.
    Callak likes this.
  7. cj0005

    cj0005 Yeah, You!

    I had the same problem.

    Last time I played (about 2 month ago) I started startbound server and then started starbound singleplayer.

    With Version Update v. Enraged Koala 18/02/2014 i had to start it it differenlty.

    Method 1: Just start starbound singleplayer, no server

    Method 2: Start starbound server then start starbound multiplayer and connect to your local system (localhost or IP)
  8. BurningJoker

    BurningJoker Void-Bound Voyager

    Yeah that fixed it, thanks, don't know what I was thinking.
    Mods feel free to delete this thread!
    Thanks for everyone's help!
  9. LittleReaper

    LittleReaper Space Spelunker

    I tried this way but it didint work :(
  10. MiamotoRei

    MiamotoRei Starship Captain

    I got same problem on version 1.4.1. No matter in what order I start server/game, it always sends me this.

Share This Page