1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Cannot deploy to Grand Pagoda Library

Discussion in 'Starbound Support' started by uberhank, Aug 25, 2016.

  1. uberhank

    uberhank Space Hobo

    Hi folks. I'm loving the game! Here's my one problem so far: I found all the Hylotl artifacts and my mission is now to go to the Grand Pagoda Library. So, I go to my ship AI and click "deploy" to teleport to the library, and after the cool loading screen, I respawn back on my ship! I've tried it many times; I've tried going to another planet and doing it; I've tried going to a planet and then coming back to the ship to do it; nothing I've tried works!!! Any thoughts or ideas? Thanks.

    Uberhank
     
  2. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

  3. uberhank

    uberhank Space Hobo

    You bet, here's the relevant additional information:

    Windows 10 (version 1607, build 14393.82)
    No mods being used
    Full screen

    It never crashed, so there is no crash report.

    starbound version 1.0.5 (windows i386)
     
  4. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    A starbound.log is created everytime when running the game. It's located in your storage folder.
    Also what are your system specs?

    ~ Iris ~
     
  5. uberhank

    uberhank Space Hobo

    System specs:
    Intel Core 2 Duo E6750 @2.66GHz
    4 GB RAM
    Windows is 32-bit

    I have five starbound.log files. Do you want all of them?
     
  6. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    .1-.5 are older ones. starbound.log is the latest (will be displayed as "starbound" when showing file extensions is disabled).

    Edit: i'll need the log from the session it happened. So best would be starting a new session, reproduce it, closing and then attach the log ^-^

    ~ Iris ~
     
  7. uberhank

    uberhank Space Hobo

    There we go.
     

    Attached Files:

  8. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    How high is your ram usage when entering the mission? Also what's your graphic device? (nvm forgot that the gpu is listed in the log >v< )

    ~ Iris ~
     
  9. uberhank

    uberhank Space Hobo

    Here's a pic taken right after I reappear on my ship that shows my RAM usage having been monitored.
     

    Attached Files:

  10. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    It seems starbound is eating too much ram when creating the mission and fails in allocating the last few things. That would explain the error in the log.
    Your log says:
    Code:
    [18:49:14.709] [Error] WorldServerThread exception caught: std::exception: bad allocation
    which can be related to your ram usage. Therefor the world errors:
    Code:
    [18:49:15.263] [Error] UniverseServer: World InstanceWorld:hylotlmission1:047abc5f46644d99281ca06a51233e0a:- has stopped due to an error
    And causes you to reappear on your ship.

    You can try stopping EVERY unneeded software for this mission (i assume same error could show up at the apex mission though).

    ~ Iris ~
     
  11. uberhank

    uberhank Space Hobo

    Okay. This may be a stupid question, but is there any way I can decrease the amount of RAM needed?
     
  12. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    You can't affect the ram usage by starbound itself but you can try stopping every unneeded software which eats up ram and hope that it will be sufficient.

    ~ Iris ~
     
  13. Mooncalf99

    Mooncalf99 Ketchup Robot

    Here's a tip for reducing RAM consumption:
    First, remove all the furniture. Yes, it's annoying when you have a big ship and you have everything in the right places, but it needs to be done. Take a screenshot if needed, then shove everything into boxes and stow them somewhere safe.
    Second, position yourself next to S.A.I.L.'s panel and save the game and quit. Then start the game, load your character, and immediately try to go to the mission. If you get booted back, just quit, reload, and try again.

    If you still fail over and over, dismiss some of your crew, then try the second step again.

    I can't promise that this will work for you, but I've had much success with it, personally. Good luck!
     
  14. Geth270

    Geth270 Scruffy Nerf-Herder

    This shouldn't be happening anyway with 4GB of ram and 50% usage when the game is already running, that would mean grand pagoda would take up more than 2GB of ram by it self which is absolutely ridiculous and not true (the minimum requirements for the game only request 2GB of ram...). I'm certain that amount of memory is not an issue here at all, just don't have any idea on what else it could be.
     

Share This Page